! Даю 100 баллов?

Информатика | 5 - 9 классы

! Даю 100 баллов!

Помогите пожалуйста!

Напишите программу в Python 2.

7 или 3.

3 По данному числу N выведите все целые степени двойки, не превосходящие N, в порядке возрастания.

! Операцией возведения в степень пользоваться нельзя!

Входные данные : Вводится натуральное число Выходные данные : Выведите ответ на задачу Пример Входные данные : 50 Выходные данные : 1 2 4 8 16 32.

Ответить на вопрос
Ответы (1)
Kekin13371 14 дек. 2020 г., 03:46:30

Var n, st : integer ;

begin

write('n = ') ; readln(n) ;

st : = 1 ;

while st< ; = n do

begin

write(st, ' ') ;

st : = st * 2 ;

end ;

writeln ;

end.

Пример :

n = 50

1 2 4 8 16 32.

Doroshenko2002 5 февр. 2020 г., 23:51:13 | 10 - 11 классы

Помогите написать программу на PascalABCNET Дано сначала число n, а затем n натуральных чисел, не превосходящих 100?

Помогите написать программу на PascalABCNET Дано сначала число n, а затем n натуральных чисел, не превосходящих 100.

Выведите на экран в порядке возрастания только те из них, которые встречаются в данной последовательности ровно один раз.

ВХОДНЫЕ ДАННЫЕ В первой строке вводится одно число n — натуральное, не превосходящее 10000.

Во второй строке вводятся n натуральных чисел, не превосходящих 100.

ВЫХОДНЫЕ ДАННЫЕ Выведите в порядке возрастания те из них, которые встречаются в последовательности ровно один раз.

Alesker 11 нояб. 2020 г., 00:55:58 | 5 - 9 классы

По данному числу N распечатайте все целые степени двойки, не превосходящие N, в порядке возрастания?

По данному числу N распечатайте все целые степени двойки, не превосходящие N, в порядке возрастания.

Операцией возведения в степень пользоваться нельзя!

Www1955 6 дек. 2020 г., 22:51:23 | 5 - 9 классы

Даны два натуральных числа n и m?

Даны два натуральных числа n и m.

Если одно из них делится на другое нацело, выведите 1, иначе выведите любое другое целое число.

Входные данные Вводятся два числа.

Выходные данные Выведите ответ на задачу.

(Примеры : входные данные - 2, 8.

Выходные - 1).

P. S.

Решить надо в Паскаль АБЦ!

Halmetova2000 3 мар. 2020 г., 05:26:02 | 5 - 9 классы

Решить в Паскаль АБЦ?

Решить в Паскаль АБЦ!

Даны два натуральных числа n и m.

Если одно из них делится на другое нацело, выведите 1, иначе выведите любое другое целое число.

"Входные данные" Вводятся два числа.

"Выходные данные" Выведите ответ на задачу.

(Примеры : входные - 2, 8.

Выходные - 1).

Ilililililil 19 окт. 2020 г., 06:29:49 | 5 - 9 классы

ЛЮДИ ДОБРЫЕ ПОМОГИТЕ?

ЛЮДИ ДОБРЫЕ ПОМОГИТЕ!

25баллов Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N.

Входные данные Задано единственное целое число N Выходные данные Необходимо вывести все точные квадраты натуральных чисел, не превосходящие данного числа N.

Примеры входные данные 15 выходные данные 1 4 9.

Fokin05 29 апр. 2020 г., 09:31:01 | 10 - 11 классы

Дано сначала число n, а затем n натуральных чисел, не превосходящих 100?

Дано сначала число n, а затем n натуральных чисел, не превосходящих 100.

Выведите на экран в порядке возрастания только те из них, которые встречаются в данной последовательности ровно один раз.

ВХОДНЫЕ ДАННЫЕ В первой строке вводится одно число n — натуральное, не превосходящее 10000.

Во второй строке вводятся n натуральных чисел, не превосходящих 100.

ВЫХОДНЫЕ ДАННЫЕ Выведите в порядке возрастания те из них, которые встречаются в последовательности ровно один раз.

Range1337 26 янв. 2020 г., 08:19:22 | 5 - 9 классы

Напишите программу на Python Даны два четырехзначных числа А и В?

Напишите программу на Python Даны два четырехзначных числа А и В.

Выведите в порядке возрастания все четырехзначные числа в интервале от А до В, запись которых содержит ровно три одинаковые цифры Входные данные - 1900 ; 2100 Выходные данные - 1911 ; 1999 ; 2000 ; 2022.

Delkup 2 сент. 2020 г., 23:37:51 | 5 - 9 классы

Напишите программу, которая считывает два целых числа a и b и выводит наибольшее значение из них?

Напишите программу, которая считывает два целых числа a и b и выводит наибольшее значение из них.

Числа — целые от 1 до 1000.

При решении задачи можно пользоваться только целочисленными арифметическими операциями + , - , * , / / , %, = .

Нельзя пользоваться нелинейными конструкциями : ветвлениями, циклами, функциями вычисления модуля, извлечения квадратного корня.

Использование функции max запрещено!

Входные данные Вводятся два целых числа a и b.

Выходные данные Выведите ответ на задачу.

Примеры входные данные 8 5 выходные данные 8 входные данные 5 8 выходные данные 8 входные данные 5 5 выходные данные 5 Заранее спасибо.

: - ).

Saiaanowa 4 окт. 2020 г., 13:20:39 | 5 - 9 классы

Дано двузначное число?

Дано двузначное число.

Найдите число десятков в нем.

Входные данные Вводится двухзначное число.

Выходные данные Выведите ответ на задачу.

Bkmz7002 24 нояб. 2020 г., 07:18:42 | 5 - 9 классы

1. Дано несколько чисел?

1. Дано несколько чисел.

Подсчитайте, сколько из них делятся на 3 и 2, и выведите это количество.

Входные данные

Cначала вводится число N, затем вводится ровно N целых чисел.

Выходные данные

Выведите ответ на задачу.

Написать программу на python!

Вы перешли к вопросу ! Даю 100 баллов?. Он относится к категории Информатика, для 5 - 9 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.