Нужна помощь с программой?

Информатика | 10 - 11 классы

Нужна помощь с программой.

Язык си.

После ввода переменной Х должна считать и выводить мне Y, но, почему - то, выводит мне Х.

#include < ; stdio.

H> ; #include < ; stdlib.

H> ; #include < ; math.

H> ; #include < ; conio.

H> ; / * run this program using the console pauser or add your own getch, system("pause") or input loop * / int main(int argc, char * argv[]) { double x = 0 ; double a ; double b ; double c ; double y = 0 ; printf("Enter X = \ n ") ; scanf("%d", & ; x) ; a = sin(x) ; printf("%d \ n", a) ; b = pow(cos(x), 2) ; c = 1 + tan(x) ; y = 4 * pow(a, 2) + x * (pow(b, 2) + x * (pow(c, 2) + x * (a * b + pow((a + b), x)))) ; printf("%d \ n", y) ; return 0 ; }.

Ответить на вопрос
Ответы (1)
Lemonthree 8 сент. 2020 г., 21:19:37

#include < ; stdio.

H> ;

#include < ; math.

H> ;

int main(int argc, char * argv[]) {

float x, a, b, c, y ;

printf("Enter X = \ n ") ;

scanf("%f", & ; x) ;

a = sin(x) ;

printf("%f \ n", a) ;

b = pow(cos(x), 2) ;

c = 1 + tan(x) ;

y = 4 * pow(a, 2) + x * (pow(b, 2) + x * (pow(c, 2) + x * (a * b + pow((a + b), x)))) ;

printf("%f \ n", y) ;

return 0 ;

}.

84193135 11 июн. 2020 г., 00:41:12 | 10 - 11 классы

Язык С?

Язык С.

Написать программу, которая печатает объем памяти занимаемый одной переменной для типов int, short int, long int, float и double.

Viktoriyabosko 15 авг. 2020 г., 21:38:20 | 10 - 11 классы

Помогите плиииз = ))) у меня есть программа но вней 2 ошибки нужно сделать с помощью динамического массива?

Помогите плиииз = ))) у меня есть программа но вней 2 ошибки нужно сделать с помощью динамического массива.

/ / laba4_2.

Cpp : Defines the entry point for the console application.

/ / #include "stdafx.

H"

#include "stdio.

H" / / #include "math.

H"

using namespace std ;

int main ( )

{ float * a ; int i, n ; printf("n = ") ; scanf("%i", & ; n) ; a = (float * )malloc(N * sizeof(float)) ; for( i = 0 ; i< ; = n - 1 ; i + + ) { printf("a[%i] = ", i ) ; scanf("%i", & ; a[i]) ; } for (i = 0 ; i< ; = N - 1 ; i + + ) { if (a[i]< ; 0) { printf("oshibka \ n") ; } else { if (a[i] / 2 = = 0) { printf("chetnoe \ n") ; } else { printf("nechetnoe \ n") ; } } } return 1 ;

}.

326852 20 дек. 2020 г., 20:00:35 | 10 - 11 классы

СИ + + Осуществите циклический сдвиг компонент заданного вектора A(N) влево на одну позицию, то есть получите вектор А = (a2 , a3 , ?

СИ + + Осуществите циклический сдвиг компонент заданного вектора A(N) влево на одну позицию, то есть получите вектор А = (a2 , a3 , .

, aN , a1 ).

#include < ; stdio.

H> ; #include < ; stdlib.

H> ; #include < ; conio.

H> ;

Sonyamuratova 28 мая 2020 г., 14:08:55 | 10 - 11 классы

Литерные (символьные) (AnsiChar, WideChar, Char) ; (Real48, Single, Double, Extended, Comp, Currency, Real)?

Литерные (символьные) (AnsiChar, WideChar, Char) ; (Real48, Single, Double, Extended, Comp, Currency, Real).

Что каждое из них значит в программировании?

:

Koloverdova87 28 окт. 2020 г., 19:50:09 | 10 - 11 классы

Объясните пожалуйста как такой ответ выходит?

Объясните пожалуйста как такой ответ выходит?

#include< ; stdio.

H> ; #include< ; conio.

H> ; int main() { int i = 0 ; int s = 0 ; while(i< ; 4) { s + = i ; i + + ; printf("%d", i) ; } getch() ; } что программа выводит на экран?

Ответ : 6.

Ulugbekjon 17 июл. 2020 г., 20:12:43 | 5 - 9 классы

С + + Include conio h Include stdio h Дано натуральное число?

С + + Include conio h Include stdio h Дано натуральное число.

Верно ли, что количество его цифр есть чётное число?

Maryevdokimova9 13 июн. 2020 г., 07:04:58 | 10 - 11 классы

Где здесь ошибка :long double g = 0hff1205 ?

Где здесь ошибка :

long double g = 0hff1205 ;

Шмекер 31 окт. 2020 г., 19:39:12 | 10 - 11 классы

Вопрос по С + + Надо было составить программу чтобы считывала текст из файла и выводила количество маленьких (4 - 8 символов) слов во всех строках текста То что придумал #include "stdafx?

Вопрос по С + + Надо было составить программу чтобы считывала текст из файла и выводила количество маленьких (4 - 8 символов) слов во всех строках текста То что придумал #include "stdafx.

H" #include #include #include #include using namespace std ; int main(int argc, _TCHAR * argv[]) { FILE * text ; char * filename = "C : \ \ Myfile.

Txt" ; char buf[101] = "" ; char commentStr[101] = "" ; if (!

(fopen_s(& ; text, filename, "r"))) { while (fgets(buf, 100 , text)) printf_s("%s", buf) ; char * pmin = NULL ; size_t pminlen = 0 ; char * head ; char * tail ; while ( * tail) { for (head = tail ; * head & ; & ; !

Isalnum( * head) ; + + head) { ; } for (tail = head ; * tail & ; & ; isalnum( * tail) ; + + tail) { ; } if (head < ; tail) { if ((pmin = = NULL) || (pminlen > ; tail - head)) ; { pmin = head ; pminlen = tail - head ; } } } if (pmin) { printf(" \ n") ; printf("min = %.

* s \ n", pminlen, pmin) ; } system("pause") ; return 0 ; } ничего не выдает в чем ошибка ( как мне кажется их тут дофига).

89132730587 18 нояб. 2020 г., 03:41:12 | 10 - 11 классы

Что не так в программе?

Что не так в программе?

Нужно вывести минимальный элемент, который есть в массиве.

С + +

#include

#include

#include

#include

#include

int main()

{

int a[5], i, min ;

srand (time(0)) ;

printf("a : \ n") ;

for (i = 0 ; i.

Anastasizi 24 сент. 2020 г., 17:33:03 | 10 - 11 классы

C + + Нужно создать одномерный массив A[5] где числа будут введены случайным образом от 0 до 1?

C + + Нужно создать одномерный массив A[5] где числа будут введены случайным образом от 0 до 1.

Я делал вот что у меня получается : #include #include #include using namespace std ; int main () { float A[5] = {} ; srand(time(NULL)) ; for (char i = 0 ; i< ; 5 ; i + + ) { A[i] = (char)rand()%1 ; cout< ; } return 0 ; } Проблема в том, что выводит только нули Помогите пожалуйста.

Вопрос Нужна помощь с программой?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 10 - 11 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.