УмоляюююююююююююююююПЛИИИИЗТОЛЬКО НА ПАСКАЛЕЕЕЕЕНапишите функцию bool Xor (bool x, bool y) (C / C + + ), function _Xor (x, y : boolean) : boolean (Pascal), def xor(x, y) : (Python) реализующую функцию?

Информатика | 5 - 9 классы

Умоляююююююююююююююю

ПЛИИИИЗ

ТОЛЬКО НА ПАСКАЛЕЕЕЕЕ

Напишите функцию bool Xor (bool x, bool y) (C / C + + ), function _Xor (x, y : boolean) : boolean (Pascal), def xor(x, y) : (Python) реализующую функцию "Исключающее ИЛИ" двух логических переменных x и y.

Функция Xor должна возвращать true, если ровно один из ее аргументов x или y, но не оба одновременно равны true.

Входные данные Вводится 2 числа - x и y (x и y равны 0 или 1, 0 соответствует значению false, 1 соответствует значению true).

Выходные данные Необходимо вывести 0 или 1 - значение функции от x и y.

Ответить на вопрос
Ответы (1)
Shamgunova20rokki 26 авг. 2020 г., 19:55:06

Function _Xor (x, y : boolean) : boolean ;

begin

_Xor : = x< ; > ; y ;

end ;

var x, y : byte ;

begin

write('x = ') ;

readln(x) ;

write('y = ') ;

readln(y) ;

writeln(ord(_Xor(x = 1, y = 1))) ;

end.

Пример :

x = 1

y = 0

1.

Stalker5659 16 авг. 2020 г., 21:21:06 | 10 - 11 классы

1. Какой тип данных могут иметь аргументы и возвращаемые значения математических функций?

1. Какой тип данных могут иметь аргументы и возвращаемые значения математических функций?

2. Какой тип данных могут иметь аргументы и возвращаемые значения строковых функций?

Zlata6511 25 сент. 2020 г., 06:38:22 | 10 - 11 классы

Помогите пожалуйста - что обозначает bool bl = true в с + + , именно bl ?

Помогите пожалуйста - что обозначает bool bl = true в с + + , именно bl ?

Olenkapodg 6 апр. 2020 г., 15:21:22 | 5 - 9 классы

Напишите функцию Multiple для двух целых чисел, которая определяет, кратно ли второе число первому?

Напишите функцию Multiple для двух целых чисел, которая определяет, кратно ли второе число первому.

Функция должна получать два целых аргумента и возвращать 1 (true), если второе число кратно первому, и 0 (false) - в противном случае.

C + +.

Dant1wka 25 нояб. 2020 г., 16:31:39 | 10 - 11 классы

1. Выберите правильный вариант а) not(true xor true) = false б) false and (not true) = true в) true or (not false) = false г) not (not false) = false 2?

1. Выберите правильный вариант а) not(true xor true) = false б) false and (not true) = true в) true or (not false) = false г) not (not false) = false 2.

Выберите правильный вариант а) true and true = false б) true and false = true в) false and true = false г) false and false = true 3.

Оберіть правильне твердження : а) true or true = false б) true or false = true в) false or true = false г) false or false = true 4.

Выберите правильный вариант а) true xor true = false б) true xor false = false в) false xor true = false г) false хor false = true.

TheDenJekov 31 янв. 2020 г., 07:20:19 | 10 - 11 классы

Напишите функцию bool f(int x, int y, int z), которая возвращает true, если x ^ 2 + y ^ 2 = z ^ 2 иначе возвращает false?

Напишите функцию bool f(int x, int y, int z), которая возвращает true, если x ^ 2 + y ^ 2 = z ^ 2 иначе возвращает false.

Задача в Visual Studio, язык c + +.

ANUBISS 17 февр. 2020 г., 06:59:22 | 10 - 11 классы

C + + как записать эту программу?

C + + как записать эту программу?

Напишите функцию bool f(int x, int y), которая возвращает true, если x делится нацело на y, или наоборот, y делится нацело на x, иначе возвращает false.

Предполагается, что значения параметров больше нуля.

Aru4ik 13 мая 2020 г., 07:25:43 | 10 - 11 классы

По возможности кто сколько сможет?

По возможности кто сколько сможет.

Умоляяяю поподробнее, срочно 1.

Как записать на Паскале утверждение «икс не равен пяти»?

2. Как записать на Паскале утверждение «игрек не при * надлежит отрезку [3, 5]»?

3. Чему равен результат операции true or false and false?

4. Правильно ли записано выражение (х< ; 0) or (х + 2)> ; 3?

5. Чему будет равен результат операции true xor false xor true?

Korobova99 12 авг. 2020 г., 12:02:59 | 10 - 11 классы

). Сколько существует различных наборов значений логических переменных x1, x2, x3, x4, x5, x6, x7, x8, x9, x10, которые удовлетворяют всем перечисленным ниже условиям?

). Сколько существует различных наборов значений логических переменных x1, x2, x3, x4, x5, x6, x7, x8, x9, x10, которые удовлетворяют всем перечисленным ниже условиям?

(x1 xor x2) or (x3 xor x4) = 1.

(x3 xor x4) or (x5 xor x6) = 1.

(x5 xor x6) or (x7 xor x8) = 1.

(x7 xor x8) or (x9 xor x10) = 1.

Приведите полное решение задачи с пояснениями.

9175708580Eva 30 мар. 2020 г., 03:17:54 | 5 - 9 классы

Какой тип переменных может принимать значения True и false : boolean , integer , byte, single?

Какой тип переменных может принимать значения True и false : boolean , integer , byte, single.

Akolesova2002 30 нояб. 2020 г., 01:46:11 | 5 - 9 классы

Дано натуральное число N?

Дано натуральное число N.

Напишите функцию (Pascal), вычисляющую сумму цифр числа N.

Входные данные

Задано единственное число N

Выходные данные

Необходимо вывести сумму цифр числа N.

Примеры

входные данные

12

выходные данные

3

ПРОГРАММА БЫЛА, НО ВВОДИЛ 12 И ВЫВОДИЛ ВМЕСТО 3, 0.

На этой странице вы найдете ответ на вопрос УмоляюююююююююююююююПЛИИИИЗТОЛЬКО НА ПАСКАЛЕЕЕЕЕНапишите функцию bool Xor (bool x, bool y) (C / C + + ), function _Xor (x, y : boolean) : boolean (Pascal), def xor(x, y) : (Python) реализующую функцию?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 5 - 9 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.