ИНФОРМАТИКИ, ПОМОГИТЕ ПОЖАЛУЙСТА Написать программу решения следующей задачи : Найти целочисленные элементы и номера строк и столбцов, в которых они расположены, для матриц А(5, 8) ; В(6, 4)?

Информатика | 10 - 11 классы

ИНФОРМАТИКИ, ПОМОГИТЕ ПОЖАЛУЙСТА Написать программу решения следующей задачи : Найти целочисленные элементы и номера строк и столбцов, в которых они расположены, для матриц А(5, 8) ; В(6, 4).

Использовать подпрограмму.

(язык паскаль).

Ответить на вопрос
Ответы (1)
Абвгдеёжзийк 24 июн. 2020 г., 05:00:47

{Предвещая недовольство : мне самому не нравится эта подпрограмма, но динамические массивы обычно не изучают в школьной программе} / / Pascal ABC.

NET v3.

1 сборка 1219

Const

n1 = 5 ;

m1 = 8 ;

n2 = 6 ;

m2 = 4 ;

Type

matrixa = array[1.

N1, 1.

M1] of integer ;

matrixb = array[1.

N2, 1.

M2] of integer ;

procedure FindInd(f : integer ; maa : matrixa ; mab : matrixb) ;

Vari, j : integer ;

s : string ;

begin for i : = 1 to n1 do for j : = 1 to m1 do if maa[i, j] = f then s : = s + '[' + inttostr(i) + '][' + inttostr(j) + ']' + chr(10) + chr(13) ; writeln('For A : ') ;

writeln(s) ; s : = '' ; for i : = 1 to n2 do for j : = 1 to m2 do if mab[i, j] = f then s : = s + '[' + inttostr(i) + '][' + inttostr(j) + ']' + chr(10) + chr(13) ; writeln('For B : ') ;

writeln(s) ;

end ; Var

maa : matrixa ;

mab : matrixb ;

i, j, f : integer ;

begin

randomize ;

writeln('Matrix A : ') ;

for i : = 1 to n1 do begin for j : = 1 to m1 do begin maa[i, j] : = random(20) ; write(maa[i, j] : 4) ; end ; writeln ;

end ;

writeln('Matrix B : ') ;

for i : = 1 to n2 do begin for j : = 1 to m2 do begin mab[i, j] : = random(20) ; write(mab[i, j] : 4) ; end ; writeln ;

end ;

readln(f) ;

FindInd(f, maa, mab) ;

end.

Пример ввода :

2

Пример вывода :

Matrix A : 14 10 13 11 6 9 14 9 10 5 12 11 17 5 1 8 4 6 0 19 17 0 1 8 16 13 6 9 15 12 14 18 2 2 15 1 0 7 10 5

Matrix B : 4 9 13 19 13 11 10 2 2 18 9 18 15 2 7 14 9 4 14 13 2 4 13 18

For A :

[5][1]

[5][2]

For B :

[2][4]

[3][1]

[4][2]

[6][1].

Di4308 26 февр. 2020 г., 09:09:51 | 10 - 11 классы

Помогите написать программу на Паскале?

Помогите написать программу на Паскале.

В целочисленной матрице размером 10x10 найдите максимальное значение и индексы всех элементов, равных ему.

Kiryashonok1 1 июл. 2020 г., 00:45:12 | 10 - 11 классы

Дана целочисленная квадратная матрица?

Дана целочисленная квадратная матрица.

Найти число строк, сумма элементов которых равна сумме элементов главной диагонали данной матрицы.

Нужна на языке си.

Lerusay 30 авг. 2020 г., 11:42:38 | 10 - 11 классы

Написать программу на ПАСКАЛЕ : Дана матрица А, имеющая N строк и N столбцов?

Написать программу на ПАСКАЛЕ : Дана матрица А, имеющая N строк и N столбцов.

Сформируйте два одномерных массива.

В один перешлите четные, а в другой - нечетные элементы матрицы.

Выведите на экран все массивы.

ИЛИ

написать программу на ПАСКАЛЕ : Вычислить произведение n!

До значения 1255534676756.

Пожалуйста решите какую сможете.

Gdaria3488 21 февр. 2020 г., 05:33:56 | 10 - 11 классы

Сформировать целочисленную матрицу 3х4?

Сформировать целочисленную матрицу 3х4.

Найти максимальный элемент в каждой строке матрицы и выбрать наибольший из них.

Код в паскале.

Polina2101203 23 дек. 2020 г., 10:22:02 | 10 - 11 классы

Pascal?

Pascal.

Паскаль.

Написать программу, которая меняет знак всех положительных элементов, расположенных в строке и столбце матрицы с максимальным элементом.

Lenaishim 27 окт. 2020 г., 15:05:16 | 10 - 11 классы

Задача по информатике (Паскаль)Пожалуйста помогите сделать задание в паскале?

Задача по информатике (Паскаль)

Пожалуйста помогите сделать задание в паскале.

Дана матрица А(3.

3)

1) Найти число отрицательных элементов под главной диагональю.

2) Найти сумму элементов первой строки по формуле.

3) Поменять местами элемент третей строки и первого столбца на S.

Kris656 29 мая 2020 г., 11:19:10 | 10 - 11 классы

Написать программу и блок - схему для решения следующей задачи?

Написать программу и блок - схему для решения следующей задачи.

В двумерном массиве, состоящем из целочисленных элементов, поменять местами : в каждом столбце первый и последний отрицательные элементы ;

(Паскаль).

Iwanrikowм 30 окт. 2020 г., 06:40:49 | 10 - 11 классы

Написать программу на паскале : определить количество строк матрицы, в которых хотя бы один элемент равен t?

Написать программу на паскале : определить количество строк матрицы, в которых хотя бы один элемент равен t.

Yanabrizhasheva 2 июн. 2020 г., 22:39:42 | 10 - 11 классы

Паскаль написать программу которая для прямоугольной целочисленной матрицы 3×4 определяет номер самого левого столбца содержащего только положительные элементы?

Паскаль написать программу которая для прямоугольной целочисленной матрицы 3×4 определяет номер самого левого столбца содержащего только положительные элементы.

Если такого столбца нет выводится сообщение.

Викуська45 22 нояб. 2020 г., 05:58:15 | 5 - 9 классы

Решите пожалуйста задачу : Заданы две целочисленные матрицы A и B?

Решите пожалуйста задачу : Заданы две целочисленные матрицы A и B.

Матрица A состоит из N строк и M столбцов, Матрица B состоит из M строк и P столбцов.

Требуется вычислить произведение данных матриц A * B.

Язык паскаль.

На этой странице сайта вы найдете ответы на вопрос ИНФОРМАТИКИ, ПОМОГИТЕ ПОЖАЛУЙСТА Написать программу решения следующей задачи : Найти целочисленные элементы и номера строк и столбцов, в которых они расположены, для матриц А(5, 8) ; В(6, 4)?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 10 - 11 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.