Задача по информатике (Паскаль)Пожалуйста помогите сделать задание в паскале?

Информатика | 10 - 11 классы

Задача по информатике (Паскаль)

Пожалуйста помогите сделать задание в паскале.

Дана матрица А(3.

3)

1) Найти число отрицательных элементов под главной диагональю.

2) Найти сумму элементов первой строки по формуле.

3) Поменять местами элемент третей строки и первого столбца на S.

Ответить на вопрос
Ответы (1)
Katty34 27 окт. 2020 г., 15:05:17

Program Matrix ;

Var A : Array [1.

3, 1.

3] of Integer ;

b, i, j : Integer ;

S : Real ;

Begin

Randomize ;

WriteLn('Начальный матрица : ') ;

For i : = 1 To 3 Do

Begin

For j : = 1 To 3 Do

Begin

A[i, j] : = Random(100) - 50 ;

Write(A[i, j], ' ') ;

End ;

WriteLn ;

End ;

b : = 0 ;

For i : = 1 To 3 Do

Begin

j : = i - 1 ;

While j > ; 0 Do

Begin

If A[i, j] < ; 0 Then

b : = b + A[i, j] ;

j : = j - 1 ;

End ;

End ;

S : = 0 ;

For j : = 1 To 3 Do

S : = S + Sin(1 * i + (A[1, j])) ;

A[3, 1] : = Round(S) ;

WriteLn('Сумма отрицательных элементов под главной диагональю равна ', b) ;

WriteLn('Начальный матрица : ') ;

For i : = 1 To 3 Do

Begin

For j : = 1 To 3 Do

Write(A[i, j], ' ') ;

WriteLn ;

End ;

ReadLn ;

End.

Irina03081958 16 нояб. 2020 г., 00:07:51 | 10 - 11 классы

Задача на c + + Дана целочисленная матрица?

Задача на c + + Дана целочисленная матрица.

Определить : А) номер первой из строк, содержащей хотя бы один положительный элемент Б) характеристику каждой строки матрицы.

Характеристикой строки матрицы называется сумма ее отрицательных элементов.

Lera184567 21 февр. 2020 г., 13:53:50 | 10 - 11 классы

ТЕМА : ОБРАБОТКА ДВУМЕРНЫХ МАССИВОВ?

ТЕМА : ОБРАБОТКА ДВУМЕРНЫХ МАССИВОВ.

ПО ПАСКАЛЬ!

Задание : Дан двумерный массив А состоящий из 4 строк и 5 столбцов .

Найти, сколько положительных элементов содержит данная матрица в каждом столбце.

Kiryashonok1 1 июл. 2020 г., 00:45:12 | 10 - 11 классы

Дана целочисленная квадратная матрица?

Дана целочисленная квадратная матрица.

Найти число строк, сумма элементов которых равна сумме элементов главной диагонали данной матрицы.

Нужна на языке си.

Polina2101203 23 дек. 2020 г., 10:22:02 | 10 - 11 классы

Pascal?

Pascal.

Паскаль.

Написать программу, которая меняет знак всех положительных элементов, расположенных в строке и столбце матрицы с максимальным элементом.

Коля2004 21 мар. 2020 г., 13:08:48 | 1 - 4 классы

Дана матрица А(3, 3)?

Дана матрица А(3, 3).

В строках с отрицательным элементом на главной диагонали найти суммы всех элементов.

Вывести номера строк, суммы, а так же матрицу А по строкам.

Паскаль.

Opi 16 мая 2020 г., 13:26:17 | 10 - 11 классы

Помогите пожалуйста составить блок схему : Найти сумму элементов первой и третьей строк матрицы?

Помогите пожалуйста составить блок схему : Найти сумму элементов первой и третьей строк матрицы.

Kovaleva8431492 17 мая 2020 г., 06:07:21 | 10 - 11 классы

Дана прямоугольная матрица?

Дана прямоугольная матрица.

Найти строку с наибольшей и наименьшей суммой элементов.

Вывести на печать найденные строки и суммы их элементов.

Kris656 29 мая 2020 г., 11:19:10 | 10 - 11 классы

Написать программу и блок - схему для решения следующей задачи?

Написать программу и блок - схему для решения следующей задачи.

В двумерном массиве, состоящем из целочисленных элементов, поменять местами : в каждом столбце первый и последний отрицательные элементы ;

(Паскаль).

Ivanchikunov 30 авг. 2020 г., 23:13:39 | 10 - 11 классы

Построить матрицу B , поменяв местами строки и столбцы в Паскале?

Построить матрицу B , поменяв местами строки и столбцы в Паскале.

Маша999910 26 мар. 2020 г., 23:07:43 | 5 - 9 классы

Дан одномерный массив из n элементов, найти max, поменять его местами с первым элементом, результат вывести на экран( Программа в Паскале)?

Дан одномерный массив из n элементов, найти max, поменять его местами с первым элементом, результат вывести на экран( Программа в Паскале).

Вы перешли к вопросу Задача по информатике (Паскаль)Пожалуйста помогите сделать задание в паскале?. Он относится к категории Информатика, для 10 - 11 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.