Даны целые числа a, b и с?

Информатика | 5 - 9 классы

Даны целые числа a, b и с.

Написать программу подсчитывающую кол - во положительных и кол - во отрицательных чисел среди данных.

Входные данные - 2 4 - 1 выходные 2 1.

(язык программирования Паскаль АБС).

Ответить на вопрос
Ответы (1)
Maxim222 15 июл. 2020 г., 18:23:25

Program alpha ; var a, b, c, p, v : integer ; begin read (a) ; read (b) ; read (c) ; p : = 0 ; / / количество отрицательных чисел v : = 0 ; / / количество положительных чисел if a < ; 0 then p : = p + 1 else v : = v + 1 ; if b < ; 0 then p : = p + 1 else v : = v + 1 ; if c< ; 0 then p : = p + 1 else v : = v + 1 ; writeln ('Кол - во положительных = ', v) ; writeln ('Кол - во отрицательных = ', p) ; end.

Layzy 28 нояб. 2020 г., 08:35:55 | 5 - 9 классы

Напишите программу, которая переводит переданное её целое число (возможно, отрицательное) в двоичный код?

Напишите программу, которая переводит переданное её целое число (возможно, отрицательное) в двоичный код.

Используйте процедуру входные данные 5 выходные данные 101 входные данные - 14 выходные данные - 1110.

Jorjiya 21 дек. 2020 г., 13:54:33 | 10 - 11 классы

Даны 5 чисел, найти сумму и кол - во положительных и произведение и кол - во отрицательных?

Даны 5 чисел, найти сумму и кол - во положительных и произведение и кол - во отрицательных.

Dodydyd 13 янв. 2020 г., 18:54:23 | 10 - 11 классы

Даны три целых числа?

Даны три целых числа.

Определить, сколько среди них положительных чисел.

Составить программу на языке Паскаль.

DimaDey 13 февр. 2020 г., 02:59:01 | 5 - 9 классы

Выведите число, поданное на ввод?

Выведите число, поданное на ввод.

ВХОДНЫЕ ДАННЫЕ Одно целое положительное число, не превышающее 1000.

Одно целое положительное число, не превышающее 1000.

ВЫХОДНЫЕ ДАННЫЕ Выведите то же самое число.

На языке С.

Lstava 29 авг. 2020 г., 16:10:38 | 10 - 11 классы

Написать программу с процедурой подсчет кол - во часов, минут, секунд в данном числе суток входные данные число суток?

Написать программу с процедурой подсчет кол - во часов, минут, секунд в данном числе суток входные данные число суток.

1735 9 дек. 2020 г., 23:48:10 | 5 - 9 классы

Напишите программу(НА ПИТОНЕ), которая переводит переданное её целое число (возможно, отрицательное) в двоичный код?

Напишите программу(НА ПИТОНЕ), которая переводит переданное её целое число (возможно, отрицательное) в двоичный код.

Используйте процедуру.

Программа должна вывести двоичное представление переданного её числа.

Примеры входные данные 5 выходные данные 101 входные данные - 14 выходные данные - 1110 (НА ПИТОНЕ!

).

Anna20031407 8 июн. 2020 г., 13:09:02 | 10 - 11 классы

Помогите написать программу на паскале абс "Файловый тип данных?

Помогите написать программу на паскале абс "Файловый тип данных.

" Дан целочисленный файл А.

Записать в файл В все положительные числа.

Izgaraeva 22 нояб. 2020 г., 06:16:43 | 10 - 11 классы

Дан массив, состоящий из целых чисел?

Дан массив, состоящий из целых чисел.

Напишите программу, которая подсчитывает количество положительных чисел среди элементов массива.

Входные данные Сначала задано число N — количество элементов в массиве (1N10000).

Далее через пробел записаны N чисел — элементы массива.

Массив состоит из целых чисел.

Выходные данные Необходимо единственное число - количество положительных элементов в массиве.

Java.

Ole4ka2la 22 нояб. 2020 г., 14:06:13 | 10 - 11 классы

Даны целые числа a, b, c?

Даны целые числа a, b, c.

Написать программу, подсчитывающую сумму тех из данных чисел, которые больше нуля.

Kisaa00101 10 нояб. 2020 г., 04:12:57 | 5 - 9 классы

Даны два целых числа от 1 до 1 000 000 000?

Даны два целых числа от 1 до 1 000 000 000.

Найти сумму этих чисел.

Входные данные : два целых числа.

Выходные данные : целое число.

На Паскале.

Вопрос Даны целые числа a, b и с?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 5 - 9 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.