Ребят, помоги в паскале?

Информатика | 10 - 11 классы

Ребят, помоги в паскале.

Напишите программу которая вводит с клавиатуры числа до тех пор пока не будет введено число 0.

В конце работы программы на экран выводится сумма и произведение введенных чисел.

Ответить на вопрос
Ответы (1)
Salievnik 4 июн. 2020 г., 06:42:09

Var a, s, p : integer ;

begin

p : = 1 ;

read(a) ;

if(a = 0) then p : = 0 ;

while(a< ; > ; 0)do begin s + = a ; p * = a ; read(a) ; end ;

writeln(s, ' ', p) ;

end.

Egorov0404 1 сент. 2020 г., 08:21:09 | 5 - 9 классы

Написать программу ввода целых чисел до тех пор, пока не будет введен ноль, посчитать сумму введеных чисел и их среднее арифметическое?

Написать программу ввода целых чисел до тех пор, пока не будет введен ноль, посчитать сумму введеных чисел и их среднее арифметическое.

Помогите пожалуйста!

KsyshaCet 12 нояб. 2020 г., 06:21:35 | 5 - 9 классы

Напишите программу, которая вводит с клавиатуры числа до тех пор, пока не будет введено число 0?

Напишите программу, которая вводит с клавиатуры числа до тех пор, пока не будет введено число 0.

В конце работы программы на экран выводится минимальное и максимальное из введенных чисел (не считая 0).

RAW2002 12 февр. 2020 г., 05:22:29 | 10 - 11 классы

Очень прошу помогите с Паскалем?

Очень прошу помогите с Паскалем!

) Натуральное число вводятся с клавиатуры до тех пор, пока не будет введено число 0.

Найти среднее арифметическое введенных чисел, а также максимальное минимальное значение.

Изобразить графически алгоритм и напишите программу для решения этой задачи.

Romakomarow 23 мая 2020 г., 05:10:32 | 10 - 11 классы

С клавиатуры пользователь вводит числа до тех пор, пока не будет введен 0?

С клавиатуры пользователь вводит числа до тех пор, пока не будет введен 0.

Вычислите сумму введенных чисел.

C923816 2 июл. 2020 г., 04:45:09 | 5 - 9 классы

С клавиатуры вводятся целые числа до тех пор пока не введенно трехзначное число?

С клавиатуры вводятся целые числа до тех пор пока не введенно трехзначное число.

Найдите сумму введенных чисел, кроме последнего.

Paskal.

Lomar100 12 февр. 2020 г., 19:03:58 | 5 - 9 классы

Ребят, помогите пожалуйста, очень надо)))) Напишите программу, в которой осуществляется ввод целых чисел ( ввод осуществляется до тех пор, пока не будет введен ноль) и определение максимального (наибо?

Ребят, помогите пожалуйста, очень надо)))) Напишите программу, в которой осуществляется ввод целых чисел ( ввод осуществляется до тех пор, пока не будет введен ноль) и определение максимального (наибольшего) из введенных чисел.

Используйте оператор repeat.

Программу нужно написать в паскале.

Katusya 30 июн. 2020 г., 06:21:23 | 5 - 9 классы

С клавиатуры вводят последовательность чисел до тех пор пока не будет введено число 3?

С клавиатуры вводят последовательность чисел до тех пор пока не будет введено число 3.

Требуется найти сумму введенных чисел.

Viktoria3311 9 нояб. 2020 г., 18:19:25 | 5 - 9 классы

Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введен нуль) и подсчет суммы и среднего арифметического введенных положительных чисел?

Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введен нуль) и подсчет суммы и среднего арифметического введенных положительных чисел.

Используйте оператор repeat.

Kriss959 20 окт. 2020 г., 01:52:04 | 10 - 11 классы

С клавиатуры вводится последовательность чисел до тех пор, пока не будет введено число 0?

С клавиатуры вводится последовательность чисел до тех пор, пока не будет введено число 0.

Требуется найти произведение нечетных чисел из введенной последовательности.

Решение с помощью while, подробно.

8Dreams 27 нояб. 2020 г., 16:12:22 | 10 - 11 классы

Написать программу в Паскале, которая прибавляет к 1 число 7 до тех пор, пока полученная сумма не превысит max число, введенное с клавиатуры?

Написать программу в Паскале, которая прибавляет к 1 число 7 до тех пор, пока полученная сумма не превысит max число, введенное с клавиатуры.

После каждого действия вывести полученную сумму, если она меньше max числа.

На этой странице сайта размещен вопрос Ребят, помоги в паскале? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 10 - 11 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.