Помогите пожалуйстаДаны 3 числа a, b, c?

Информатика | 10 - 11 классы

Помогите пожалуйста

Даны 3 числа a, b, c.

Определить минимальное из них.

Если минимальное число окажется отрицательным , то определить количество отрицательных чисел , а иначе все положительные числа заменить на отрицательные .

Написать программу и блок схему.

Ответить на вопрос
Ответы (1)
Viks1992 21 дек. 2020 г., 05:15:46

Program project1 ;

uses

crt, math ;

var s : real ; i, j, f : real ; a : integer ;

begin

writeln('vvedite 1 chislo ') ; readln(i) ;

writeln('vvedite 2 chislo ') ; readln(j) ;

writeln('vvedite 3 chislo ') ; readln(f) ;

s : = i ;

if j< ; s then s : = j ;

if f< ; s then s : = f ;

if s< ; 0 then

begin

if i< ; 0 then inc(a) ;

if j< ; 0 then inc(a) ; if f< ; 0 then inc(a) ; writeln('kolichestvo otricatelnix ', a : 2) ;

end

else

begin if i> ; 0 then i : = i * - 1 ;

if j> ; 0 then j : = i * - 1 ;

if f> ; 0 then f : = i * - 1 ;

end ;

writeln('min chislo ', s : 2 : 0) ;

readln ;

end.

Помошник107 3 февр. 2020 г., 19:47:01 | 10 - 11 классы

PascalОпределить среди 3 введенных чисел сумму отрицательных и положительных?

Pascal

Определить среди 3 введенных чисел сумму отрицательных и положительных.

Если больше сумма положительных, то найти разность первого и второго числа, а иначе найти произведение 3 - х чисел.

ТОЛЬКО ПРОГРАММА.

BaNeK34 5 июл. 2020 г., 20:53:00 | 5 - 9 классы

Написать программу на алгоритмическом языке программирования для вычисления минимального отрицательного числа и максимального положительного числа из 15 чисел введенных с клавиатуры(Язык с + + )?

Написать программу на алгоритмическом языке программирования для вычисления минимального отрицательного числа и максимального положительного числа из 15 чисел введенных с клавиатуры(Язык с + + ).

Отличница52014 8 сент. 2020 г., 21:26:38 | 5 - 9 классы

Даны числа a, b, c?

Даны числа a, b, c.

Определить, сколько среди них положительных чисел, сколько отрицательных, сколько равны нулю, какое максимальное, минимальное и среднее арифметическое.

Составить на языке C + +.

Аня1210 5 июн. 2020 г., 08:29:44 | 5 - 9 классы

Помогите пожалуйста, нужно написать программу в паскале которая будет вводить целые числа до 5, подсчитать количество положительных и отрицательных чисел, где 0 будет считаться положительным числом?

Помогите пожалуйста, нужно написать программу в паскале которая будет вводить целые числа до 5, подсчитать количество положительных и отрицательных чисел, где 0 будет считаться положительным числом.

NRyabikovaNN 25 сент. 2020 г., 05:39:05 | 10 - 11 классы

Написать программу в Pascal даны целые числа а1?

Написать программу в Pascal даны целые числа а1.

Аn. Если в данной последовательности ни одно четное число не расположено после нечетного.

То получить все отрицательные члены последовательности иначе - положительное.

Radabuntarka 12 янв. 2020 г., 17:26:08 | 10 - 11 классы

Даны 3 вещественных числа, определить сколько из них отрицательных?

Даны 3 вещественных числа, определить сколько из них отрицательных.

Нарисовать блок схему!

Nik209 19 июн. 2020 г., 10:57:35 | 5 - 9 классы

Написать в программе Паскаль программу :Вывести сначала положительные числа из отрезка [a ; b], а потом отрицательные числа из отрезка [a ; b] и количество положительных и отрицательных чисел из отрез?

Написать в программе Паскаль программу :

Вывести сначала положительные числа из отрезка [a ; b], а потом отрицательные числа из отрезка [a ; b] и количество положительных и отрицательных чисел из отрезка [a ; b].

Danil110901 28 окт. 2020 г., 15:13:12 | 10 - 11 классы

Написать программу и блок - схему?

Написать программу и блок - схему.

Дано три числа a, b, c.

Найти среди них минимальное?

Юляффка12 17 дек. 2020 г., 15:18:27 | 5 - 9 классы

Написать программу в которой вводятся целые числа и подсчёт количества введённых положительных и отрицательных чисел?

Написать программу в которой вводятся целые числа и подсчёт количества введённых положительных и отрицательных чисел.

Mdbrother5 11 июн. 2020 г., 10:19:48 | 5 - 9 классы

Напишите программу, которая в последовательности целых чисел определяет минимальное ОТРИЦАТЕЛЬНОЕ число, кратное 6?

Напишите программу, которая в последовательности целых чисел определяет минимальное ОТРИЦАТЕЛЬНОЕ число, кратное 6.

Программа получает на вход количество чисел в последовательности, а затем сами числа.

В последовательности всегда имеется ОТРИЦАТЕЛЬНОЕ число, кратное 6.

Плиззз дам мноого балов.

Вопрос Помогите пожалуйстаДаны 3 числа a, b, c?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 10 - 11 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.