Составить программу поиска элемента в одновимирному массиве ?

Информатика | 5 - 9 классы

Составить программу поиска элемента в одновимирному массиве !

ТУРБО ПАСКАЛЬ ПОЖАЛУЙСТА ОЧЕНЬ НАДО СРОЧНО НАПИШИТЕ КОД.

Ответить на вопрос
Ответы (1)
Vika86682 4 окт. 2020 г., 03:19:22

Программа поиска элемента в произвольном массиве :

const n = 10 ;

var a : array[1.

N + 1] of integer ;

p, i : integer ;

begin

Randomize ;

writeln('Исходный массив : ') ;

for i : = 1 to n do

begin

a[i] : = random(21) ;

write(a[i] : 4) ;

end ;

writeln ;

write('p = ') ; readln(p) ;

a[n + 1] : = p ;

i : = 1 ;

while a[i]< ; > ; p do i : = i + 1 ;

if i< ; = n

then writeln('Искомый элемент найден, его номер = ', i)

else writeln('Искомый элемент не найден') ;

end.

Пример 1 :

Исходный массив : 7 17 16 13 0 1 19 20 12 5

p = 13

Искомый элемент найден, его номер = 4

Пример 2 :

Исходный массив : 20 4 5 12 14 10 11 16 18 20

p = 15

Искомый элемент не найден.

FroZen007 14 нояб. 2020 г., 19:08:11 | 10 - 11 классы

Напишите программу пожалуйста в паскалепроизведение элементов массива, расположенных между максимальным и минимальным элементами ?

Напишите программу пожалуйста в паскале

произведение элементов массива, расположенных между максимальным и минимальным элементами ;

Froburl 14 мар. 2020 г., 09:31:52 | 10 - 11 классы

Написать программу поиска значения максимального элемента массива?

Написать программу поиска значения максимального элемента массива.

Vikik123 2 апр. 2020 г., 08:19:27 | 10 - 11 классы

Напишите программу поиска минимального и максимального элементов матрицы?

Напишите программу поиска минимального и максимального элементов матрицы.

Программа должна менять максимальный и минимальный элементы между собой и выводить на экран исходную и преобразованную матрицы (Турбо Паскаль).

Maximova802 19 сент. 2020 г., 09:34:59 | 10 - 11 классы

Помогите с программой на Паскале?

Помогите с программой на Паскале.

Сложение двумерных массивов.

Сложение элементов первого с элементами второго.

При этом в первом массиве порядок элементов нормальный, а во втором - задом наперед.

Версия паскаля не имеет значения) я пользуюсь "АВС" и Турбо - паскалем.

TheKratos 9 авг. 2020 г., 06:24:30 | 5 - 9 классы

Плиз напишите ответы ( с программы Турбо паскаль )?

Плиз напишите ответы ( с программы Турбо паскаль ).

Komar96 25 дек. 2020 г., 20:23:52 | 10 - 11 классы

Прошу помочь с решением?

Прошу помочь с решением.

Не понимаю как его сделать.

Составить алгоритм и программу поиска наименьшего элемента массива X(n).

На бейсик, си или паскаль.

Pasha1417 26 апр. 2020 г., 04:55:31 | 10 - 11 классы

Помогите c С#?

Помогите c С#!

На основании алгоритмов напишите программу поиска максимального элемента в массиве из 10 элементов.

Наталья19951 14 февр. 2020 г., 14:04:32 | 5 - 9 классы

Помогите, пожалуйста?

Помогите, пожалуйста.

Нужно составить программу в Турбо Паскаль, которая находит минимальный элемент в массиве и ставит его на первое место, при этом все остальные элементы сдвигаются.

Вывести на экран новый массив.

Thanking 19 нояб. 2020 г., 17:34:55 | 5 - 9 классы

Составить программу поиска элементов массива, значение которых совпадает с индексом?

Составить программу поиска элементов массива, значение которых совпадает с индексом.

Olgalavrinenko 21 дек. 2020 г., 03:22:35 | 10 - 11 классы

Напишите программу печатающую номера элементов массива больших 30 (Паскаль)?

Напишите программу печатающую номера элементов массива больших 30 (Паскаль).

Вы находитесь на странице вопроса Составить программу поиска элемента в одновимирному массиве ? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 5 - 9 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.