Напишите программу пожалуйста в паскалепроизведение элементов массива, расположенных между максимальным и минимальным элементами ?

Информатика | 10 - 11 классы

Напишите программу пожалуйста в паскале

произведение элементов массива, расположенных между максимальным и минимальным элементами ;

Ответить на вопрос
Ответы (1)
КаПрИзУлЬкАD 14 нояб. 2020 г., 19:08:15

Const n = 10 ;

var min, max, i : integer ; p : real ; a : array[1.

N] of real ;

begin

p : = 1 ; min : = 1 ; max : = 1 ;

for i : = 1 to n do read(a[i]) ;

for i : = 1 to n do if a[i]> ; a[max] then max : = i else if a[i]< ; a[min] then min : = i ;

if max< ; min then for i : = max + 1 to min - 1 do p : = p * a[i] else for i : = min + 1 to max - 1 do p : = p * a[i] ;

write(p)

end.

Veronica1902 22 окт. 2020 г., 22:58:05 | 10 - 11 классы

Помогите пожалуйста написать программу на паскале : дан массив целых чисел?

Помогите пожалуйста написать программу на паскале : дан массив целых чисел.

Найти количество элементов, кратных 5, расположенных между максимальным и минимальным элементами массива (включая их).

Vikik123 2 апр. 2020 г., 08:19:27 | 10 - 11 классы

Напишите программу поиска минимального и максимального элементов матрицы?

Напишите программу поиска минимального и максимального элементов матрицы.

Программа должна менять максимальный и минимальный элементы между собой и выводить на экран исходную и преобразованную матрицы (Турбо Паскаль).

Рома127 11 апр. 2020 г., 09:47:12 | 10 - 11 классы

Посчитать сумму элементов массива, заполненного случайными числами, и произведение максимального и минимального элементов?

Посчитать сумму элементов массива, заполненного случайными числами, и произведение максимального и минимального элементов.

Настя122004 1 мар. 2020 г., 21:25:50 | 5 - 9 классы

Напишите пожалуйста программу, которая находит максимальный и минимальный из элементов массива с четными положительными значениями?

Напишите пожалуйста программу, которая находит максимальный и минимальный из элементов массива с четными положительными значениями.

Если в массиве нет элементов с четными положительными значениями, нужно вывести сообщение об этом.

С объяснением!

Romanys 27 февр. 2020 г., 14:35:19 | 10 - 11 классы

Найти количество элементов массива, расположенных между первым минимальным и последним максимальным?

Найти количество элементов массива, расположенных между первым минимальным и последним максимальным.

Программа нужна в Pascal.

Lob2004 10 янв. 2020 г., 04:47:43 | 10 - 11 классы

Написать программы в паскале : 1?

Написать программы в паскале : 1.

Найти среднее арифметическое положительных элементов.

2. Вычислить сумму элементов, расположенных после максимального элемента.

3. Найти произведение элементов, расположенных до минимального элемента.

4. Заменить все отрицательные элементы их моделями.

Так же надо использовать массив.

Катюшащенок 21 нояб. 2020 г., 01:23:06 | 10 - 11 классы

Помогите написать программу В одномерном массиве, состоящем из 15 вещественных элементов (значения элементов массива задать случайными числами из интервала [ - 10 ; 10]), вычислить произведение элемен?

Помогите написать программу В одномерном массиве, состоящем из 15 вещественных элементов (значения элементов массива задать случайными числами из интервала [ - 10 ; 10]), вычислить произведение элементов массива, расположенных между максимальным и минимальным элементами.

Сформировать из этих элементов новый массив.

SpiderMan1997 3 авг. 2020 г., 10:04:59 | 10 - 11 классы

Написать в программу в паскале (сразу все) - найти максимальный и минимальный элемент в массиве?

Написать в программу в паскале (сразу все) - найти максимальный и минимальный элемент в массиве.

Polinok290 8 янв. 2020 г., 04:29:13 | 10 - 11 классы

Напишите программу которая находит максимальный и минимальный из чётных пложителных элементов массива?

Напишите программу которая находит максимальный и минимальный из чётных пложителных элементов массива.

Если в массиве нет чётных положительных элементов, нужно вывести сообщение об этом.

По информатика с ответам.

Slideq 30 окт. 2020 г., 04:08:28 | 5 - 9 классы

Найти номера минимального и максимального элементов массива, в Паскале?

Найти номера минимального и максимального элементов массива, в Паскале.

Перед вами страница с вопросом Напишите программу пожалуйста в паскалепроизведение элементов массива, расположенных между максимальным и минимальным элементами ?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 10 - 11 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.