Вывести все совершенные числа в промежутке от 1 до 100 ?

Информатика | 5 - 9 классы

Вывести все совершенные числа в промежутке от 1 до 100 .

Совершенное число это натуральное число равное сумме своих собственных делителей(отличных от самого числа).

Ответить на вопрос
Ответы (1)
Bogdan265921 16 нояб. 2020 г., 19:48:21

Var i, j, s : integer ;

Begin For j : = 1 to 100 do Begin s : = 0 ; For i : = 1 to (j div 2) do if (j mod i = 0) then s : = s + i ; if (j = s) then writeln(s) ; End ;

End.

Pilkovavika71 5 мар. 2020 г., 05:21:40 | 10 - 11 классы

Паскаль?

Паскаль!

Напишите логическую функцию, которая определяет, верно ли, что число N - совершенное, т.

Е. равно сумме своих делителей, меньших его самого.

Laylaakberova 15 янв. 2020 г., 02:13:56 | 5 - 9 классы

Натуральное число называется совершенным, если оно равно сумме всех своих собственных делителей, т?

Натуральное число называется совершенным, если оно равно сумме всех своих собственных делителей, т.

Е. делителей отличных от самого числа.

Примером совершенного числа является, например, 6 = 1 + 2 + 3.

Напишите программу, позволяющую вычислить, когда наступит следуюций совершенный год.

Seortega 27 апр. 2020 г., 16:20:11 | 5 - 9 классы

СРОЧНО?

СРОЧНО!

Напишите логическую функцию в паскале, которая определяет верно ли, что число N - совершенное, т.

Е. равно сумме своих делителей, меньших его самого.

110186 17 янв. 2020 г., 18:17:24 | 10 - 11 классы

Помогите , задача Паскаль?

Помогите , задача Паскаль!

В промежутке от 1 до n вывести все числа, сумма делителей которых(включая 1 и не включая само число) равна самому числу.

Vavavalavaltos 17 сент. 2020 г., 04:43:46 | 10 - 11 классы

Помогите написать программы в паскаль, пожалуйста?

Помогите написать программы в паскаль, пожалуйста!

1. Дано число х.

Найти и вывести на экран все его делители и их сумму.

2. В промежутке от 1 до n вывести все числа, сумма делителей которых равна самому числу.

NickYzeCyshestvyet 8 июл. 2020 г., 20:25:35 | 10 - 11 классы

Напишите программу которая вводит натуральное число N и находит все совершенные числа в диапазоне от 1 до Npascal?

Напишите программу которая вводит натуральное число N и находит все совершенные числа в диапазоне от 1 до N

pascal.

Kotyara766 8 сент. 2020 г., 11:50:42 | 5 - 9 классы

Ввести натуральное число и вывести в строчку все числа от 1 до этого числа?

Ввести натуральное число и вывести в строчку все числа от 1 до этого числа.

1Aruzhan3 21 дек. 2020 г., 05:14:14 | 5 - 9 классы

С клавиатуры вводится целое число K (K< ; = 5)?

С клавиатуры вводится целое число K (K< ; = 5).

Найти и вывести на экран первые К совершенных числа.

Совершенное число - - натурально число, равное сумме всех своих собственных делителей (т.

Е. всех положительных делителей, отличных от самого числа).

Donierakramov 2 нояб. 2020 г., 04:52:03 | 5 - 9 классы

Для каждого натурального числа в промежутке [m ; n] вывести все делители, кроме единицы и самого числа?

Для каждого натурального числа в промежутке [m ; n] вывести все делители, кроме единицы и самого числа.

M и n вводятся с клавиатуры.

Выводить в формате число : делители.

Nikita234596 21 июл. 2020 г., 11:29:08 | 10 - 11 классы

Натуральное число называется совершенным, если оно равно сумме всех своих делителей, включая единицу и исключая само себя?

Натуральное число называется совершенным, если оно равно сумме всех своих делителей, включая единицу и исключая само себя.

Вводится натуральное число.

Проверьте его на совершенство и выдайте ответ «Да» или «Нет».

Подсчитайте количество операций в вашем ал - горитме и выпишите его в виде функции от параметра n, где n – вводи - мое число.

Плюс два балла за правильный эффективный алгоритм про - верки числа.

На этой странице сайта вы найдете ответы на вопрос Вывести все совершенные числа в промежутке от 1 до 100 ?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 5 - 9 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.