1 Дано слово , , КОМПЬЮТЕР"?

Информатика | 5 - 9 классы

1 Дано слово , , КОМПЬЮТЕР".

Составить программу получения слов , , КОМ", , , РЕТРО'', , , РОК", используя только буквы исходного слова.

2 Задана исходная строка , , КОМПЬЮТЕР''.

Поменять местами i и последний символ строки.

Номер i задаётся пользователем .

3 Составить программу шифрования слова , , ПАР", используя шифр Цезаря (со сдвигом на 4 позиции).

Составить в Паскале.

Ответить на вопрос
Ответы (1)
D123mir62 1 нояб. 2020 г., 06:36:02

* * * 1 * * * / / PascalABC.

NET 3.

1, сборка 1267 от 10.

07. 2016

begin var w : = 'КОМПЬЮТЕР' ; Writeln(w[1 : 4]) ; Writeln((w.

Right(3).

Inverse) + w[w.

Length] + w[2]) ; Writeln(w[w.

Length] + w[2 : : - 1])

end.

Результат

КОМ

РЕТРО

РОК * * * 2 * * * / / PascalABC.

NET 3.

1, сборка 1267 от 10.

07. 2016

begin var w : = 'КОМПЬЮТЕР' ; var i : = ReadInteger('i = ') ; Swap(w[i], w[w.

Length]) ; Writeln(w)

end.

Тестовое решение

i = 5

КОМПРЮТЕЬ * * * 3 * * * / / PascalABC.

NET 3.

1, сборка 1267 от 10.

07. 2016

begin var w : = 'ПАР' ; / / исходное слово var k : = 4 ; / / константа сдвига шифра Цезаря var a : = 'АБВГДЕЖЗИЙКЛМНОПРСТУФХЦЧШЩЪЫЬЭЮЯАБВГ' ; for var i : = 1 to w.

Length do begin var p : = Pos(w[i], a) ; if p> ; 0 then w[i] : = a[p + k] end ; Writeln(w)

end.

Результат

УДФ.

Aiwa2004 24 мая 2020 г., 05:50:09 | 10 - 11 классы

Паскаль :Дано слово?

Паскаль :

Дано слово.

Удалить из него третью букву.

(Условие(желательно но необязательно) : присваивание последнему символу исходной строки значение "_".

).

Innapavlova19 5 сент. 2020 г., 01:26:09 | 10 - 11 классы

Составить программу на паскале находящюю самое длинное слово в строке начинающееся на букву А , и выводящуюю количество букв в нём?

Составить программу на паскале находящюю самое длинное слово в строке начинающееся на букву А , и выводящуюю количество букв в нём?

Crilovpav99 20 мар. 2020 г., 10:09:29 | 10 - 11 классы

Шифр Виженера?

Шифр Виженера.

Это шифр Цезаря с переменной величиной сдвига.

Величину сдвига задают ключевым словом.

Например, ключевое слово ВАЗА означает следующую посл едовательность сдвигов букв исходного текста : 3 1 9 1 3 1 9 1 и т.

Д. Используя в качестве ключевого слово ЗИМА, закодировать слова : АЛГОРИТМИЗАЦИЯ, КОМПЬЮТЕР, ИНТЕРНЕТ.

Помогите , как это делать , очень срочно нужно .

Vikaviking 12 янв. 2020 г., 10:53:41 | 10 - 11 классы

Cтроки?

Cтроки.

Паскаль.

1. Задано слово - последовательность произвольных символов.

Сделать программу, в которой составляется слово перевертыш к данному ( символы записываются в обратной последовательности.

) 2. Дана символьная строка.

Слово - последовательность символов между пробелами, не содержащая пробелы внутри себя.

Составить программу, в которой выводились бы все слова, в которых есть заданный символ.

Katyabulanova 18 нояб. 2020 г., 20:22:27 | 10 - 11 классы

С клавиатуры вводят слово и символ?

С клавиатуры вводят слово и символ.

Составить программу, которая : а)проверяет есть ли в этом слове заданный символ б)определяет позицию заданного символа в)подсчитывает количество вхождений заданного символа.

Temich1999 7 окт. 2020 г., 13:57:55 | 10 - 11 классы

Составить программу, которая считает количество букв "а" в заданном слове?

Составить программу, которая считает количество букв "а" в заданном слове.

В паскаль.

Golden6 3 окт. 2020 г., 07:48:36 | 10 - 11 классы

Составить программу которая удаляет из заданной строки заданное слово паскаль?

Составить программу которая удаляет из заданной строки заданное слово паскаль.

АнетаХ 15 июн. 2020 г., 10:09:08 | 10 - 11 классы

Составить программу в паскале которая проверяет наличие введенного слова в строке?

Составить программу в паскале которая проверяет наличие введенного слова в строке.

Enjegilmanova 22 мая 2020 г., 04:54:16 | 10 - 11 классы

Кому не сложно помочь с PascalABC?

Кому не сложно помочь с PascalABC?

Дана строка.

Некоторые из слов взяты в круглые скобки.

Написать программу, выводящую исходную строку без скобок.

Ринато5 31 окт. 2020 г., 02:13:12 | 5 - 9 классы

Смоделировать шифр Цезаря : пусть пользователь вводит 3 - х буквенные слова?

Смоделировать шифр Цезаря : пусть пользователь вводит 3 - х буквенные слова.

Программа должна выводить зашифрованные слова с сдвигом Цезаря, решить в паскаль.

Помогите пожалуйста, очень срочно!

Заранее благодарю.

Вы зашли на страницу вопроса 1 Дано слово , , КОМПЬЮТЕР"?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 5 - 9 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.