Смоделировать шифр Цезаря : пусть пользователь вводит 3 - х буквенные слова?

Информатика | 5 - 9 классы

Смоделировать шифр Цезаря : пусть пользователь вводит 3 - х буквенные слова.

Программа должна выводить зашифрованные слова с сдвигом Цезаря, решить в паскаль.

Помогите пожалуйста, очень срочно!

Заранее благодарю.

Ответить на вопрос
Ответы (1)
Asemaasemka 31 окт. 2020 г., 02:13:15

Для строчных русских букв :

var s : string ;

k, i, c : integer ;

begin

writeln('Введите 3 - x буквенное слово : ') ;

readln(s) ;

write('Введите ключ : ') ;

readln(k) ;

for i : = 1 to length(s) do

begin

c : = ord(s[i]) + k ;

if c> ; 1103 then c : = c - 32 ;

s[i] : = chr(c) ;

write(s[i]) ;

end ;

end.

Crilovpav99 20 мар. 2020 г., 10:09:29 | 10 - 11 классы

Шифр Виженера?

Шифр Виженера.

Это шифр Цезаря с переменной величиной сдвига.

Величину сдвига задают ключевым словом.

Например, ключевое слово ВАЗА означает следующую посл едовательность сдвигов букв исходного текста : 3 1 9 1 3 1 9 1 и т.

Д. Используя в качестве ключевого слово ЗИМА, закодировать слова : АЛГОРИТМИЗАЦИЯ, КОМПЬЮТЕР, ИНТЕРНЕТ.

Помогите , как это делать , очень срочно нужно .

Виктория1456 4 февр. 2020 г., 06:53:43 | 1 - 4 классы

Шифр Цезаря - один из самых простых и известных методов шифрования, в котором каждый символ в тексте заменяется символом, находящимся на некотором постоянном числе позиций левее или правее него в алфа?

Шифр Цезаря - один из самых простых и известных методов шифрования, в котором каждый символ в тексте заменяется символом, находящимся на некотором постоянном числе позиций левее или правее него в алфавите.

Например, слово КОНКУРС, зашифрованное шифром Цезаря со сдвигом 3, выглядит как НСРНЦУФ.

Сколько гласных букв в исходном сообщении, которое в зашифрованном виде со сдвигом 4 записано как ДПЖТФМЦР?

А Б В Г Д Е Ё Ж З И Й К Л М Н О П Р С Т У Ф Х Ц Ч Ш Щ Ъ Ы Ь Э Ю Я.

Накуси 8 дек. 2020 г., 05:34:54 | 5 - 9 классы

Слово было зашифровано шифром Цезаря?

Слово было зашифровано шифром Цезаря.

Получилось ЭРБИБДГ.

Расшифруйте его.

Используйте русский алфавит, состоящий из 33 букв.

Ответ запишите заглавными русскими буквами.

Msnuraika98 1 сент. 2020 г., 05:31:38 | 5 - 9 классы

Программа на паскале?

Программа на паскале.

Ввести натуральное число N, удалить из него все значащие нули, образовав новое число.

Пример : вводим 46008090, выводим 4689 Помогите пожалуйста, заранее благодарю).

Шабанова 7 апр. 2020 г., 18:54:31 | 10 - 11 классы

Расшифруйте слово НУМТХСЁУГЧМВ , закодированное с помощью шифра Цезаря?

Расшифруйте слово НУМТХСЁУГЧМВ , закодированное с помощью шифра Цезаря.

Ĉñĕгуřőчķäа 28 нояб. 2020 г., 09:37:00 | 5 - 9 классы

Закодировать слово ПРОЦЕССОР с помощью шифра Цезаря, используя смещение на 2 символа вправо?

Закодировать слово ПРОЦЕССОР с помощью шифра Цезаря, используя смещение на 2 символа вправо.

Бра908 2 июл. 2020 г., 12:06:44 | 5 - 9 классы

Помогите с расшифровкой Цезаря : Расшифруйте ?

Помогите с расшифровкой Цезаря : Расшифруйте .

Фирхвдуя , и с шсусыгв тсжcзг Задание : Сообщения закодированы шифром Цезаря со сдвигом на 3 буквы вправо .

Декодируйте сообщения .

Madameglit 1 нояб. 2020 г., 06:35:59 | 5 - 9 классы

1 Дано слово , , КОМПЬЮТЕР"?

1 Дано слово , , КОМПЬЮТЕР".

Составить программу получения слов , , КОМ", , , РЕТРО'', , , РОК", используя только буквы исходного слова.

2 Задана исходная строка , , КОМПЬЮТЕР''.

Поменять местами i и последний символ строки.

Номер i задаётся пользователем .

3 Составить программу шифрования слова , , ПАР", используя шифр Цезаря (со сдвигом на 4 позиции).

Составить в Паскале.

Бакенхо 11 янв. 2020 г., 17:36:21 | 5 - 9 классы

Зашифровать слово с использованием шифра Цезаря ( кодовое число 2)?

Зашифровать слово с использованием шифра Цезаря ( кодовое число 2).

АлинаSum 6 мар. 2020 г., 12:31:33 | 5 - 9 классы

Сообщение "НБСЩСФУЙИБУПС" закодировано шифром "Цезаря" со сдвигом?

Сообщение "НБСЩСФУЙИБУПС" закодировано шифром "Цезаря" со сдвигом.

Вопрос Смоделировать шифр Цезаря : пусть пользователь вводит 3 - х буквенные слова?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 5 - 9 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.