Три точки заданы своими координатами?

Информатика | 5 - 9 классы

Три точки заданы своими координатами.

Определите, можно ли построить треугольник с вершинами в этих точках.

Составьте программу в Pascal, пожалуйста!

Ответить на вопрос
Ответы (1)
Danabrkv 4 июн. 2020 г., 02:19:53

/ / Pascal ABC.

NET v3.

0 сборка 1111

Var

x1, y1, x2, y2, x3, y3 : integer ;

a1, a2, a3 : real ;

begin

read(x1, y1, x2, y2, x3, y3) ;

a1 : = sqrt(sqr(x1) + sqr(y1)) ;

a2 : = sqrt(sqr(x2) + sqr(y2)) ;

a3 : = sqrt(sqr(x3) + sqr(y3)) ;

if (a1< ; (a2 + a3)) and (a2< ; (a1 + a3)) and (a3< ; (a2 + a1)) then writeln('Yes') else writeln('No') ;

end.

Пример ввода :

1

2

3

4

5

6

Пример вывода :

No.

Tohaplus 19 авг. 2020 г., 09:15:57 | 10 - 11 классы

Написать программу на Pascal, попадает ли точка с заданными координатами в область?

Написать программу на Pascal, попадает ли точка с заданными координатами в область?

Lizgardlove 24 янв. 2020 г., 17:53:55 | 10 - 11 классы

Определить попадет ли точка с заданными координатами в заштрихованную область?

Определить попадет ли точка с заданными координатами в заштрихованную область?

PASCAL.

Baterfly23 9 нояб. 2020 г., 10:25:01 | 10 - 11 классы

Вариант 5?

Вариант 5.

Точка на плоскости задана своими координатами X и Y.

Построить таблицу, содержащую координаты пяти точек, для каждой из которых необходимо определить, принадлежит ли точка заштрихованной области.

Gayanegrigorya 1 сент. 2020 г., 20:32:42 | 5 - 9 классы

Составьте программу, проверяющую, лежит ли точка с заданными координатами вне круга с радиусом R и началом в точке O(a, b)?

Составьте программу, проверяющую, лежит ли точка с заданными координатами вне круга с радиусом R и началом в точке O(a, b).

Sweta230985 9 сент. 2020 г., 01:21:24 | 5 - 9 классы

Составьте программу для определения принадлежности точки заданными координатами (х, у) заштрихованной области?

Составьте программу для определения принадлежности точки заданными координатами (х, у) заштрихованной области.

Lizabydanova 28 апр. 2020 г., 09:30:02 | 10 - 11 классы

ПОЖАЛУЙСТА ПОМОГИТЕ?

ПОЖАЛУЙСТА ПОМОГИТЕ!

ОЧЕНЬ СРОЧНО!

Точка на плоскости задана своими координатами X и Y.

Построить таблицу, содержащую координаты пяти точек, для каждой из которых необходимо определить, принадлежит ли точка заштрихованной области.

Романбанан 25 февр. 2020 г., 11:12:05 | 5 - 9 классы

Три точки заданы своими координатами?

Три точки заданы своими координатами.

Определите, можно ли построить треугольник с вершинами в этих точках.

Напишите программу в Pascale.

Пожалуйста!

Laragon2014 10 янв. 2020 г., 06:55:07 | 5 - 9 классы

Проверить принадлежит ли точка, заданная координатами, заштрихованной области?

Проверить принадлежит ли точка, заданная координатами, заштрихованной области.

Pascal.

Dimarasher 14 окт. 2020 г., 15:01:02 | 10 - 11 классы

Написать программу вычисления значений функции в заданных точках (Turbo Pascal) Очень нужно?

Написать программу вычисления значений функции в заданных точках (Turbo Pascal) Очень нужно.

Мяусик1 8 нояб. 2020 г., 20:39:47 | 10 - 11 классы

Написать программу вычисления значений функции в заданных точках (Turbo Pascal) Очень нужно?

Написать программу вычисления значений функции в заданных точках (Turbo Pascal) Очень нужно.

На этой странице вы найдете ответ на вопрос Три точки заданы своими координатами?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 5 - 9 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.