Составьте программу которая определяет по номеру месяца количество дней в этом месяце и количество ошибок при вводе N месяца?

Информатика | 5 - 9 классы

Составьте программу которая определяет по номеру месяца количество дней в этом месяце и количество ошибок при вводе N месяца.

ABC PASKAL Через for, repid, writeln, readln , begin.

Даю 30 баллов.

Ответить на вопрос
Ответы (1)
Natasha16106 2 дек. 2020 г., 10:11:55

/ / PascalABC.

NET 3.

1, сборка 1198 от 11.

03. 2016

begin var k : = 0 ; var Terminate : boolean ; repeat Terminate : = True ; var n : = ReadInteger('Введите номер месяца : ') ; case n of 1, 3, 5, 7, 8, 10, 12 : Writeln('31 день') ; 4, 6, 9, 11 : Writeln('30 дней') ; 2 : Writeln('28 дней в обычном году и 29 - в високосном') else begin Writeln('Вы ошиблись, номер должен быть от 1 до 12') ; Inc(k) ; Terminate : = False end end until Terminate ; if k> ; 0 then Writeln('Вы ошиблись ', k, ' раз(а).

')

end.

Тестовое решение :

Введите номер месяца : 18

Вы ошиблись, номер должен быть от 1 до 12

Введите номер месяца : 0

Вы ошиблись, номер должен быть от 1 до 12

Введите номер месяца : 5

31 день

Вы ошиблись 2 раз(а).

1999101615 28 июл. 2020 г., 20:28:56 | 10 - 11 классы

Составить программу, которая по заданным году и номеру месяца m определяет количество дней в этом месяце?

Составить программу, которая по заданным году и номеру месяца m определяет количество дней в этом месяце?

В паскале.

ТанТан 22 июл. 2020 г., 05:59:26 | 10 - 11 классы

Напишите программу, которая вводит с клавиатуры номер месяца и определяет, сколько дней в этом месяце?

Напишите программу, которая вводит с клавиатуры номер месяца и определяет, сколько дней в этом месяце.

При вводе неверного номера месяца должно быть выведено сообщение об ошибке.

Считается, что год невисокосный.

Входные данные Входная строка содержит единственное целое число – номер месяца (возможно, неправильный).

Выходные данные Выходная строка должна содержать одно целое число – количество дней в этом месяце или 0, если был введён неверный номер месяца.

Для ABCpascal.

Stepa200326 2 дек. 2020 г., 09:23:29 | 5 - 9 классы

Составить программу для вычисления числа дней в месяце по введенному номеру месяца?

Составить программу для вычисления числа дней в месяце по введенному номеру месяца.

Karpenkoy1997 26 мая 2020 г., 03:55:54 | 5 - 9 классы

Написать программу в Паскале Пользователь вводит количество недель, месяцев, лет и получает количество дней за это время?

Написать программу в Паскале Пользователь вводит количество недель, месяцев, лет и получает количество дней за это время.

Считать, что в месяце 30 дней.

Fadeev 15 мар. 2020 г., 12:24:30 | 5 - 9 классы

Написать программу, которая бы по введенному номеру времени года (1 - зима, 2 - весна, 3 - лето, 4 - осень) выдавала соответствующие этому времени года месяцы, количество дней в каждом из месяцев?

Написать программу, которая бы по введенному номеру времени года (1 - зима, 2 - весна, 3 - лето, 4 - осень) выдавала соответствующие этому времени года месяцы, количество дней в каждом из месяцев.

Вася162ро 29 июл. 2020 г., 07:11:31 | 5 - 9 классы

Составить программу, которая запрашивает у пользователя год количество дней в текущем месяце и сегодняшнее число?

Составить программу, которая запрашивает у пользователя год количество дней в текущем месяце и сегодняшнее число.

После этого выводит сообщение о том, сколько дней осталось до конца месяца.

Пример работы программы : Сколько дней в текущем месяце?

31 Какое сегодня число?

26 Количество дней до конца текущего месяца : 5.

Davletyarov 18 апр. 2020 г., 09:41:14 | 10 - 11 классы

Напишите программу, которая вводит номер месяца и выводит название времени года на английском языке?

Напишите программу, которая вводит номер месяца и выводит название времени года на английском языке.

При вводе неверного номера месяца должно быть выведено слово 'NO'.

Konovaljva1999 1 сент. 2020 г., 03:04:55 | 10 - 11 классы

Паскаль?

Паскаль.

Написать программу которая после введения месяца, выводит на экран количество дней этого месяца.

Anel9913 30 мая 2020 г., 12:09:13 | 5 - 9 классы

Помогите пожалуйста?

Помогите пожалуйста!

Напишите программу : По заданному номеру месяца выводилось его название и указано количество дней в месяце.

Nikki09 15 мая 2020 г., 14:49:26 | 5 - 9 классы

Напишите программу, которая вводит с клавиатуры номер месяца и определяет, сколько дней в этом месяце?

Напишите программу, которая вводит с клавиатуры номер месяца и определяет, сколько дней в этом месяце.

При вводе неверного номера месяца должно быть выведено сообщение об ошибке.

Считается, что год невисокосный.

Входные данные Входная строка содержит единственное целое число – номер месяца (возможно, неправильный).

Выходные данные Выходная строка должна содержать одно целое число – количество дней в этом месяце или 0, если был введён неверный номер месяца.

Для PYTHON, не для Pascal.

Вопрос Составьте программу которая определяет по номеру месяца количество дней в этом месяце и количество ошибок при вводе N месяца?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 5 - 9 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.