Алгоритм обработки массива int N = 20 ; int [] A = new int[N] ; int S = 0 ; for(J = 4 ; J if (J%3 = = 0) S + = A[J] ; textBox1?

Информатика | 1 - 4 классы

Алгоритм обработки массива int N = 20 ; int [] A = new int[N] ; int S = 0 ; for(J = 4 ; J if (J%3 = = 0) S + = A[J] ; textBox1.

Text(s) ; определяет сумму элементов массива с индексами, кратными 1)2 2)3 3)4 4)6 5)12 поподробнее если можно, спасибо).

Ответить на вопрос
Ответы (1)
Chyrik55 23 окт. 2020 г., 14:23:36

Как видно из синтаксиса цикла for, итерация идёт по массиву A, где J выступает индексом.

Видим, что условие - J%3 = = 0, то есть J должно без остатка делиться на 3.

Следовательно, ответ 2).

Pigalevacat 11 февр. 2020 г., 21:12:00 | 5 - 9 классы

Массив из 40 случайных чисел, каждое из которых находится в диапазоне от - 30 до 30 :А) выведите на экран количество и индексы отрицательных элементов массива?

Массив из 40 случайных чисел, каждое из которых находится в диапазоне от - 30 до 30 :

А) выведите на экран количество и индексы отрицательных элементов массива.

Б) выведите на экран количество, индексы и значения элементов массива, кратных шести.

Дополнительно :

Выведите на экран максимальный элемент массива и его индекс.

Выведите на экран количество элементов массива, равных 7.

Лё8а 5 нояб. 2020 г., 07:42:59 | 10 - 11 классы

Int * arr = (int * )malloc(N * sizeof(int)) ; выручайте, спросили что такое (int * )?

Int * arr = (int * )malloc(N * sizeof(int)) ; выручайте, спросили что такое (int * ).

84193135 11 июн. 2020 г., 00:41:12 | 10 - 11 классы

Язык С?

Язык С.

Написать программу, которая печатает объем памяти занимаемый одной переменной для типов int, short int, long int, float и double.

Alfiya001 24 сент. 2020 г., 07:03:19 | 10 - 11 классы

Как преобразовать символ char в переменную int на языке с (не с + + )?

Как преобразовать символ char в переменную int на языке с (не с + + )?

Например char c ; int x ; чтобы 'c' = x ; Спасибо заранее.

ArkneyA 15 июл. 2020 г., 16:32:35 | 10 - 11 классы

Определите сумму элементов массива, кратных 5?

Определите сумму элементов массива, кратных 5.

Mmtrr 6 сент. 2020 г., 12:50:34 | 10 - 11 классы

Написать алгоритмы нахождения суммы, произведения всех элементов массива и поиска максимального элемента массива?

Написать алгоритмы нахождения суммы, произведения всех элементов массива и поиска максимального элемента массива.

КрАсАвЧиК007 30 сент. 2020 г., 10:49:38 | 5 - 9 классы

Помогите создать программу) Найти элемент массива кратный 7 и его индекс?

Помогите создать программу) Найти элемент массива кратный 7 и его индекс.

9 класс Заранее спасибо!

Klepininaa 7 авг. 2020 г., 07:12:50 | 10 - 11 классы

ЯЗЫК СИ?

ЯЗЫК СИ!

ПОМОГИТЕ, ПОЖАЛУЙСТА, ИСПРАВИТЬ КОД.

НЕ МОГУ ПОНЯТЬ ПОЧЕМУ НЕ РАБОТАЕТ.

Написать функцию, умножающую все элементы массива на число.

Параметрами функции является массив и число, на которое нужно умножить его элементы.

#include #include int fun1(int b[], int k) { b[] = b[] * k ; } int main() { system ("chcp 1251 > ; nul") ; printf(" \ n Условие : Написать функцию, умножающую все элементы массива на число.

Параметрами функции является массив и число, на которое нужно умножить его элементы.

") ; int i ; int k ; int n ; printf(" \ n \ t Введите n - > ; ") ; scanf("%i", & ; n) ; printf(" \ n \ t Введите k - > ; ") ; scanf("%i", & ; k) ; int mas[n] ; printf(" \ n \ t Исходный массив : ") ; printf(" ") ; for(i = 0 ; i < ; n ; i + + ) mas[i] = rand()%10 ; for(i = 0 ; i < ; n ; i + + ) printf("%i ", mas[i]) ; printf(" \ n") ; printf("Преобразованный массив : \ n") ; for (i = 0 ; i printf("%i ", fun1(mas[i]) ; return 0 ;

89132730587 18 нояб. 2020 г., 03:41:12 | 10 - 11 классы

Что не так в программе?

Что не так в программе?

Нужно вывести минимальный элемент, который есть в массиве.

С + +

#include

#include

#include

#include

#include

int main()

{

int a[5], i, min ;

srand (time(0)) ;

printf("a : \ n") ;

for (i = 0 ; i.

Полинка1547 12 дек. 2020 г., 05:06:46 | 5 - 9 классы

Умоляю , Пожалуйста ?

Умоляю , Пожалуйста !

Напишите функцию int min (int a, int b, int c, int d) (C / C + + ), static int min (int a, int b, int c, int d) (Java) function min (a, b, c, d : integer) : integer (Pascal), находящую наименьшее из четырех данных чисел.

Входные данные Вводится четыре числа.

Выходные данные Необходимо вывести наименьшее из 4 - х данных чисел.

Вопрос Алгоритм обработки массива int N = 20 ; int [] A = new int[N] ; int S = 0 ; for(J = 4 ; J if (J%3 = = 0) S + = A[J] ; textBox1?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 1 - 4 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.