С клавиатуры вводится произвольная строка, состоящая из символов латинского алфавита?

Информатика | 10 - 11 классы

С клавиатуры вводится произвольная строка, состоящая из символов латинского алфавита.

Группы символов, раздельные пробелами, и не имеющие пробелов внутри будем называть словами.

Напишите программу, которая заменяет каждое слово строки на его длину.

Длина строки не более 100 символов.

Например : Исходная строка : "An example of a string of characters " Преобразованная строка "2 7 2 1 2 10".

Ответить на вопрос
Ответы (1)
Mamie1999 21 янв. 2020 г., 18:59:09

Pascal

var

s : string ;

i, k : integer ;

begin

readln (s) ;

k : = 0 ;

for i : = 1 to Length(s) do

begin

if s[i] < ; > ; ' ' then

k : = k + 1

else

begin

write (k + s[i]) ;

k : = 0 ;

end ;

end ;

end.

89129627357 12 апр. 2020 г., 07:10:10 | 10 - 11 классы

Составить программу для ввода строки символов с клавиатуры в буфер и вывод этой строки на экран?

Составить программу для ввода строки символов с клавиатуры в буфер и вывод этой строки на экран.

BDepVikafeangie 3 нояб. 2020 г., 14:17:34 | 5 - 9 классы

Письмо состояло из 30 строк?

Письмо состояло из 30 строк.

В каждой строке вместе с пробелами по 48 символов.

Письмо содержало 900 байт информации.

Какова мощность алфавита (количество символов), которым было написано письмо?

Marinapavlova21 30 авг. 2020 г., 08:23:36 | 5 - 9 классы

Дана строка, содержащая, по крайней мере, один символ пробела?

Дана строка, содержащая, по крайней мере, один символ пробела.

Вывести подстроку, расположенную между первым и последним пробелом исходной строки.

Если строка содержит только один пробел, то вывести пустую строку после пробела.

Dima21011979 26 дек. 2020 г., 02:07:37 | 10 - 11 классы

Письмо состояло из 45 строк?

Письмо состояло из 45 строк.

В каждой строке вместе с пробелами было 64 символа.

Сколько байт информации содержало письмо?

ЗаЙкА004567 23 нояб. 2020 г., 13:18:45 | 10 - 11 классы

Ввести с клавиатуры строку?

Ввести с клавиатуры строку.

Сформировать новую строку, в которой все символы из первой строки разделены пробелами.

Помогите, пожалуйста).

GlebovichPolinka 22 дек. 2020 г., 15:42:26 | 10 - 11 классы

Pascal abc Написать программу, которая вводит с клавиатуры строку и выводит на экран символ, код которого в два раза больше, чем количество символов в исходной строке (использовать функции Length и ch?

Pascal abc Написать программу, которая вводит с клавиатуры строку и выводит на экран символ, код которого в два раза больше, чем количество символов в исходной строке (использовать функции Length и chr).

Emma16 17 окт. 2020 г., 21:07:14 | 5 - 9 классы

Дана строка символов заменить в данной строке все последовательности из одинаковых символов длиной более двух символов на строку вида : ' ^ nc' , где n - количество повторений заменяемого символа, с -?

Дана строка символов заменить в данной строке все последовательности из одинаковых символов длиной более двух символов на строку вида : ' ^ nc' , где n - количество повторений заменяемого символа, с - сам символ.

Например : дана строка 'aaabccdddde' и она должна стать строкой вида : ' ^ 3abcc ^ 4de'.

СинийШар 15 янв. 2020 г., 00:09:44 | 10 - 11 классы

Составьте программу которая находит позицию пробела в строке s состоящей из двух слов разделенных пробелом?

Составьте программу которая находит позицию пробела в строке s состоящей из двух слов разделенных пробелом.

Строка вводится с клавиатуры.

Meneewa2015 29 нояб. 2020 г., 07:41:35 | 5 - 9 классы

Письмо состояло из 30 строк?

Письмо состояло из 30 строк.

В каждой строке вместе с пробелами по 48 символов.

Письмо содержало 900 байт информации.

Какова мощность алфавита

(количество символов), которым было написано письмо?

Непонятно 6 дек. 2020 г., 01:10:08 | 10 - 11 классы

Программа вводит две строки?

Программа вводит две строки.

Из более длинной строки программа выводит все символы, коды которых > ; 70.

В короткой строке заменяет все «!

» знаки на « * » и выводит короткую строку на экран.

Перед вами страница с вопросом С клавиатуры вводится произвольная строка, состоящая из символов латинского алфавита?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 10 - 11 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.