1. Вычислите сумму элементов массива?

Информатика | 5 - 9 классы

1. Вычислите сумму элементов массива.

Элементы массива вводятся с клавиатуры.

Составить алгоритм решения задачи и написать программный код на языке Паскаль.

2. Составьте алгоритм и программу нахождения полупроизведения двух чисел.

Составить алгоритм решения задачи и написать программный код на языке Паскаль.

3. Составьте программу, реализующую эпизод применения компьютера в книжном магазине.

Компьютер запрашивает стоимость книг, сумму денег, внесённую покупателем.

Если здачи не требуется, печатает на экране"Спасибо" ; если денег внесено больше, то печатает "Возьмите сдачу" и сумму сдачи ; если денег недостаточно , то печатает об этом сообщение и указывает размер недостающей суммы.

Составить алгоритм решения задачи и написать программный код на языке Паскаль.

Ответить на вопрос
Ответы (1)
Сом5 2 нояб. 2020 г., 10:16:18

1. programz_1 ;

var i, s ; intger ;

a : array[1.

50] of integer ;

begin

for i : = 1 to 50 do

begin

readln(a[i]) ;

s : = s + a[i] ;

end ;

writeln(s) ;

end.

2. programz_2 ;

varc1, c2, pp : integer ;

begin

readln(c1) ;

readln(c2) ;

pp : = round((c1 * c2) / 2) ; / / полупроизведениедвух чисел

writeln(pp) ;

end.

3. program z_3 ;

var k, v, s : integer ;

begin

readln(k) ; / / Стоимость книги

readln(v) ; / / Внесено денег

if k = v then

writeln('Спасибо!

')

else

if k< ; v then

writeln('Возьмите сдачу : ', v - k)

else

writeln('Недостаточно средств : ', k - v) ;

end.

Ksyushagordien 4 окт. 2020 г., 08:14:12 | 10 - 11 классы

Циклические алгоритмы и разработка программыЦиклы с параметрамиРазработать схему алгоритма (блок схему), написать программный код на языке паскаль, используя оператор FOR?

Циклические алгоритмы и разработка программы

Циклы с параметрами

Разработать схему алгоритма (блок схему), написать программный код на языке паскаль, используя оператор FOR.

Forti5 30 авг. 2020 г., 10:12:48 | 10 - 11 классы

Составить алгоритм и написать программу для решения задачи с ИСПОЛЬЗОВАНИЕМ ОДНОМЕРНЫХ МАССИВОВ?

Составить алгоритм и написать программу для решения задачи с ИСПОЛЬЗОВАНИЕМ ОДНОМЕРНЫХ МАССИВОВ.

Вычислить (см.

Фото).

Valia11 6 июн. 2020 г., 20:10:21 | 5 - 9 классы

Составить программу реализующую эпизод применение компьютера в книжном магазине?

Составить программу реализующую эпизод применение компьютера в книжном магазине.

Компьютер запрпшивает стоимость книг.

Сумму денег.

Если сдача не требуется , то пишет "спасибо" .

Если денег внесли больше, то пишет "возьмите сдачу" и указывает сдачу.

Если денег не достаточно , то пишет "денег не достаточно" и пишет сколько надо доплатить.

PandusHas 4 окт. 2020 г., 02:50:12 | 5 - 9 классы

Составьте программу, реализующую эпизод применения компьютера в книжном магазине?

Составьте программу, реализующую эпизод применения компьютера в книжном магазине.

Компьютер запрашивает стоимость книг и сумму денег, внесенную покупателем.

Если сдачи не требуется, печатает на экране «Спасибо».

Если денег внесено больше, то печатает «Возьмите сдачу» и указывает сумму сдачи.

Если денег недостаточно, то печатает об этом сообщение и указывает размер недостающей суммы.

Gevork65 8 июл. 2020 г., 03:50:21 | 10 - 11 классы

Циклы с постусловиями?

Циклы с постусловиями.

Разработать схему алгоритма и написать программный код на языке Паскаль.

Используя оператор Repeat Until.

Olesay3478 23 июл. 2020 г., 16:15:24 | 5 - 9 классы

Найти сумму двух чисел А и Б написать код программы на языке паскаль?

Найти сумму двух чисел А и Б написать код программы на языке паскаль.

Mmtrr 6 сент. 2020 г., 12:50:34 | 10 - 11 классы

Написать алгоритмы нахождения суммы, произведения всех элементов массива и поиска максимального элемента массива?

Написать алгоритмы нахождения суммы, произведения всех элементов массива и поиска максимального элемента массива.

Renata210913 23 июл. 2020 г., 11:16:01 | 5 - 9 классы

Составьте алгоритм нахождения суммы четных и нечетных чисел от 1 до 100?

Составьте алгоритм нахождения суммы четных и нечетных чисел от 1 до 100.

На языке ПАСКАЛЬ.

Артур1254 10 окт. 2020 г., 22:10:16 | 5 - 9 классы

Написать программу на языке Паскаль, где пользователь вводит с клавиатуры 99 элементов массива, а программа рассчитывает сумму значений элементом при условии четности индекса элемента и значения этого?

Написать программу на языке Паскаль, где пользователь вводит с клавиатуры 99 элементов массива, а программа рассчитывает сумму значений элементом при условии четности индекса элемента и значения этого элемента.

Leopoldtv 13 нояб. 2020 г., 08:53:33 | 5 - 9 классы

Написать программу на языке Паскаль, где пользователь вводит с клавиатуры 99 элементов массива, а программа рассчитывает сумму значений элементом при условии четности индекса элемента и значения этого?

Написать программу на языке Паскаль, где пользователь вводит с клавиатуры 99 элементов массива, а программа рассчитывает сумму значений элементом при условии четности индекса элемента и значения этого элемента.

На этой странице находится вопрос 1. Вычислите сумму элементов массива?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 5 - 9 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.