Найти место положение и значение максимального элемента массива 7 на 7?

Информатика | 5 - 9 классы

Найти место положение и значение максимального элемента массива 7 на 7.

Написать на паскале.

Ответить на вопрос
Ответы (2)
Baranuyt 3 апр. 2020 г., 07:28:51

/ / Pascal ABC.

NET сборка 1256

Const

n = 7 ;

Var

ma : array[1.

N, 1.

N] of integer ;

i, j, max, maxi, maxj : integer ;

begin

randomize ;

max : = - 1 ;

writeln('Matrix : ') ;

for i : = 1 to n do begin for j : = 1 to n do begin ma[i, j] : = random(1000) ; write(ma[i, j] : 4) ; if max< ; ma[i, j] then begin max : = ma[i, j] ; maxi : = i ; maxj : = j ; end ; end ; writeln ; end ;

writeln('Max = ', max) ;

writeln('Строка : ', maxi) ;

write('Столбец : ', maxj) ;

end.

Лпси 3 апр. 2020 г., 07:28:54

Const n = 7 ;

var a : array[1.

N, 1.

N] of integer ; i, j, imax, jmax : integer ;

begin Randomize ; imax : = 1 ; jmax : = 1 ; Writeln('Исходный массив') ; for i : = 1 to n do begin for j : = 1 to n do begin a[i, j] : = Random(90) + 10 ; Write(a[i, j] : 3) ; if a[i, j]> ; a[imax, jmax] then begin imax : = i ; jmax : = j end ; end ; Writeln end ; Writeln('Max[', imax, ', ', jmax, '] = ', a[imax, jmax])

end.

Тестовое решение

Исходный массив

76 22 34 68 78 87 98

67 76 68 10 70 63 68

78 83 88 38 89 83 88

41 70 55 59 34 37 86

48 55 86 64 98 92 59

14 47 94 74 99 15 52

35 91 31 89 31 16 91

Max[6, 5] = 99.

Een929 11 июн. 2020 г., 12:23:29 | 10 - 11 классы

Паскаль?

Паскаль.

Вычислить разность максимального среди элементов, имеющих четные значения, и максимального среди элементов, имеющих нечетные значения, в заданном целочисленном массиве из 30 положительных элементов (в предположении, что в массиве есть и четные, и нечетные элементы).

Artiomkonopli 27 сент. 2020 г., 07:42:34 | 1 - 4 классы

Найти максимальный элемент массива X(10)?

Найти максимальный элемент массива X(10).

Помогите написать программу в паскале пожалуйста.

Froburl 14 мар. 2020 г., 09:31:52 | 10 - 11 классы

Написать программу поиска значения максимального элемента массива?

Написать программу поиска значения максимального элемента массива.

Настя631прдлвптррии 2 июн. 2020 г., 15:30:58 | 5 - 9 классы

1) Удвоить все элементы массива?

1) Удвоить все элементы массива.

2)Найти сумму элементов двух массивов одинаковой размерности.

4) Найти Минимальные элементы массива и его индекс.

5) Найти максимальные элементы среди положительных элементов массива 6) Найти максимальные элементы среди отрицательных элементов массива 7) Определить количество максимальных элементов массива P.

S Ребят, все в паскале.

Заранее спасибо = *.

2001viola 24 янв. 2020 г., 05:33:36 | 5 - 9 классы

Написать программу которая формирует массив из n элементов (максимальное количество элементов равно 20), значения элементов массива случайные целые числа от - 10 до 25?

Написать программу которая формирует массив из n элементов (максимальное количество элементов равно 20), значения элементов массива случайные целые числа от - 10 до 25.

Программа должна :

1)выводить на экран сначала все элементы массива, стоящие на чётных местах, а затем - все элементы массива, стоящие на нечётных местах ;

2)вывести на экран сумму всех элементов массива, значение которых кратны 3 или 5.

3)найти минимальное значение и максимальное значение элементов массива.

Angelina2016a 26 авг. 2020 г., 04:14:27 | 10 - 11 классы

В одномерном массиве найти максимальный элемент заменить на 0 , и вывести массив на экран?

В одномерном массиве найти максимальный элемент заменить на 0 , и вывести массив на экран.

На паскале.

SpiderMan1997 3 авг. 2020 г., 10:04:59 | 10 - 11 классы

Написать в программу в паскале (сразу все) - найти максимальный и минимальный элемент в массиве?

Написать в программу в паскале (сразу все) - найти максимальный и минимальный элемент в массиве.

Linochk552 1 окт. 2020 г., 20:41:06 | 5 - 9 классы

Найти наибольшее значение элементов двумерного массива паскаль?

Найти наибольшее значение элементов двумерного массива паскаль.

Смерш199 4 окт. 2020 г., 05:22:53 | 10 - 11 классы

Найти минимальный и максимальный элементы массивы(программку написать)?

Найти минимальный и максимальный элементы массивы(программку написать).

Slideq 30 окт. 2020 г., 04:08:28 | 5 - 9 классы

Найти номера минимального и максимального элементов массива, в Паскале?

Найти номера минимального и максимального элементов массива, в Паскале.

На этой странице находится вопрос Найти место положение и значение максимального элемента массива 7 на 7?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 5 - 9 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.