Помогите пожалуйста с задачей в паскале В одномерном массиве, состоящем из N элементов, вычислить : 1) количество элементов массива, больших С 2) произведение элементов массива, расположенных после ма?

Информатика | 5 - 9 классы

Помогите пожалуйста с задачей в паскале В одномерном массиве, состоящем из N элементов, вычислить : 1) количество элементов массива, больших С 2) произведение элементов массива, расположенных после максимального по модулю элемента 3) преобразовать массив таким образом, чтобы сначала размещались все отрицательные элементе, а потом - все положительные (0 считать положительным).

Ответить на вопрос
Ответы (1)
Lubovivarlamova 23 янв. 2020 г., 11:41:01

/ / PascalABC.

NET (версия 3.

1, сборка 1210 от 29.

03. 2016)

const n = 10 ;

var a : array[1.

N] of integer ; i, j, c, nc, max, imax : integer ; p : BigInteger ;

begin / / Заполним массив сл.

Числами max : = - MaxInt ; for i : = 1 to n do begin a[i] : = random( - 100, 100) ; write(a[i] : 4) ; if abs(a[i]) > ; max then begin max : = a[i] ; imax : = i ; end ; end ; writeln ; / / 1.

Количество элементов массива, больших С.

Writeln('Введите число "с"') ; readln(c) ; for i : = 1 to n do if a[i] > ; c then nc : = nc + 1 ; writeln('Элементов больше чем ', c, ' : ', nc) ; / / 2.

Произведение элементов массива, / / расположенных после мак симального / / по модулю элемента p : = 1 ; for i : = imax + 1 to n do p : = p * a[i] ; writeln('Максимальный по модулю элемент находится на ', imax, ' месте') ; writeln('Произведение элементов массива, расположенных после максимального по модулю элемента ', p) ; / / 3.

Преобразовать массив таким образом, чтобы сначала размещались все / / отрицательные элементы, а потом все положительные for i : = 1 to n - 1 do for j : = 1 to n - i do if a[j] > ; a[j + 1] then begin swap(a[j], a[j + 1]) ; end ; writeln('Преобразованный массив : ') ; for i : = 1 to n do write(a[i] : 4) ;

end.

Тестовое решение : - 6 91 52 62 - 28 - 64 86 86 - 91 - 61

Введите число "с"

15

Элементов больше чем 15 : 5

Максимальный по модулю элемент находится на 2 месте

Произведение элементов массива, расположенных после максимального по модулю элемента - 1246076928

Преобразованный массив : - 91 - 64 - 61 - 28 - 6 52 62 86 86 91.

Mirysa230902 6 дек. 2020 г., 07:15:14 | 10 - 11 классы

Найти количество положительных и отрицательных элементов в одномерном массиве?

Найти количество положительных и отрицательных элементов в одномерном массиве.

Vanoli4 11 февр. 2020 г., 07:27:15 | 10 - 11 классы

Написать программу на С + + или паскаль?

Написать программу на С + + или паскаль.

Помогите пожалуйста!

В одномерном массиве, состоящем из n вещественных элементов, вычислить : - максимальный элемент массива ; - сумма элементов массива, расположенных до последнего положительного элемента .

Сжать массив, удалив из него все элементы, модуль которых находится в интервале (a.

B). Освободившийся в конце массива элементы заполнить нулями.

Ssv1973 23 апр. 2020 г., 13:58:22 | 10 - 11 классы

Задача 1 В одномерном массиве , состоящем из n вещественных элементов , вычислить ; 1) номер минимального элемента ; 2) сумму элементов массива ; Преобразовать массив таким образом , чтобы сначала рас?

Задача 1 В одномерном массиве , состоящем из n вещественных элементов , вычислить ; 1) номер минимального элемента ; 2) сумму элементов массива ; Преобразовать массив таким образом , чтобы сначала располагались все элементы , модуль которых не превышает 1 , а потом - все остальные .

Задача 2 В одномерном массиве , состоящем из n вещественных элементов , вычислить ; !

) минимальный по модулю элемент массива ; 2) сумму модулей элементов массива , расположенных после первого элемента , равного нулю .

Преобразовать массив таким образом , чтобы в первой его половине располагались элементы в четных позивиях , а во второй половине - элементы , стоявшие в нечетных позициях.

Настя2005 3 янв. 2020 г., 06:37:14 | 5 - 9 классы

Дан одномерный массив, состоящий из вещественных элементов?

Дан одномерный массив, состоящий из вещественных элементов.

Найти сумму элементов массива, расположенных до последнего положительного элемента.

Qleb 12 июн. 2020 г., 21:57:19 | 5 - 9 классы

Дан массив состоящий из 30 элементов?

Дан массив состоящий из 30 элементов.

Найти в массиве максимальный элемент, вывести его значение и номер на экран.

Отрицательный элемент массива заменить на равные по модулю положительные элементы.

Moskvina04 31 авг. 2020 г., 07:25:56 | 10 - 11 классы

Дан массив А(к)?

Дан массив А(к).

Из элементов массива А сформировать массив В таким образом : сначала поместить все отрицательные массивы элемента А, потом равные нулю, а положительные в конце.

Fgjhkkhg 4 февр. 2020 г., 17:16:13 | 10 - 11 классы

С + + одномерный массив из 15 элементов нужно посчитать сумму положительных элементов массива и произведение отрицательных элементов и узнать что больше сумма или произведение?

С + + одномерный массив из 15 элементов нужно посчитать сумму положительных элементов массива и произведение отрицательных элементов и узнать что больше сумма или произведение.

DanyaMac 8 янв. 2020 г., 23:31:29 | 10 - 11 классы

Задача на C + + : В одномерном массиве, Задача на C + + : В одномерном массиве, состоящем из n вещественных элементов?

Задача на C + + : В одномерном массиве, Задача на C + + : В одномерном массиве, состоящем из n вещественных элементов.

Преобразовать массив таким образом, чтобы сначала располагались все отрицательные элементы, а потом - все положительные (элементы, равные 0, считать положительными).

Катюшащенок 21 нояб. 2020 г., 01:23:06 | 10 - 11 классы

Помогите написать программу В одномерном массиве, состоящем из 15 вещественных элементов (значения элементов массива задать случайными числами из интервала [ - 10 ; 10]), вычислить произведение элемен?

Помогите написать программу В одномерном массиве, состоящем из 15 вещественных элементов (значения элементов массива задать случайными числами из интервала [ - 10 ; 10]), вычислить произведение элементов массива, расположенных между максимальным и минимальным элементами.

Сформировать из этих элементов новый массив.

Azamatova 11 янв. 2020 г., 18:17:13 | 10 - 11 классы

В одномерном массиве, состоящем из n целых случайных элементов из диапазона от - 10 до 10 вычислите : 1) среднее арифметическое отрицательных нечетных элементов массива , 2) сумму элементов массива, р?

В одномерном массиве, состоящем из n целых случайных элементов из диапазона от - 10 до 10 вычислите : 1) среднее арифметическое отрицательных нечетных элементов массива , 2) сумму элементов массива, расположенных за вторым нечетным положительным элементом.

На странице вопроса Помогите пожалуйста с задачей в паскале В одномерном массиве, состоящем из N элементов, вычислить : 1) количество элементов массива, больших С 2) произведение элементов массива, расположенных после ма? из категории Информатика вы найдете ответ для уровня учащихся 5 - 9 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.