В одномерном массиве, состоящем из n целых случайных элементов из диапазона от - 10 до 10 вычислите : 1) среднее арифметическое отрицательных нечетных элементов массива , 2) сумму элементов массива, р?

Информатика | 10 - 11 классы

В одномерном массиве, состоящем из n целых случайных элементов из диапазона от - 10 до 10 вычислите : 1) среднее арифметическое отрицательных нечетных элементов массива , 2) сумму элементов массива, расположенных за вторым нечетным положительным элементом.

Ответить на вопрос
Ответы (1)
Prada77707 11 янв. 2020 г., 18:17:16

Const n = 13 ;

var a : array[1.

N] of integer ; i, s1, s2, p, k, e : integer ; m : real ;

begin Randomize ; Write('Исходный массив : ') ; s1 : = 0 ; k : = 0 ; p : = 0 ; s2 : = 0 ; for i : = 1 to n do begin a[i] : = Random(21) - 10 ; Write(a[i], ' ') ; if a[i] mod 2 < ; > ; 0 then begin if a[i]< ; 0 then begin s1 : = s1 + a[i] ; k : = k + 1 end else begin p : = p + 1 ; if p = 2 then e : = a[i] end end ; if p> ; = 2 then s2 : = s2 + a[i] end ; Writeln ; if k> ; 0 then m : = s1 / k else m : = 0 ; if s2< ; > ; e then s2 : = s2 - e ; Writeln(m, ' ', s2)

end.

Контрольное решение

Исходный массив : 7 3 10 3 3 0 1 - 2 9 - 2 5 - 5 1 - 5 23.

Saalaus 17 апр. 2020 г., 21:09:47 | 10 - 11 классы

Найти среднее арифметическое всех положительных элементов одномерного массива?

Найти среднее арифметическое всех положительных элементов одномерного массива.

В Delphi.

Vanoli4 11 февр. 2020 г., 07:27:15 | 10 - 11 классы

Написать программу на С + + или паскаль?

Написать программу на С + + или паскаль.

Помогите пожалуйста!

В одномерном массиве, состоящем из n вещественных элементов, вычислить : - максимальный элемент массива ; - сумма элементов массива, расположенных до последнего положительного элемента .

Сжать массив, удалив из него все элементы, модуль которых находится в интервале (a.

B). Освободившийся в конце массива элементы заполнить нулями.

Ssv1973 23 апр. 2020 г., 13:58:22 | 10 - 11 классы

Задача 1 В одномерном массиве , состоящем из n вещественных элементов , вычислить ; 1) номер минимального элемента ; 2) сумму элементов массива ; Преобразовать массив таким образом , чтобы сначала рас?

Задача 1 В одномерном массиве , состоящем из n вещественных элементов , вычислить ; 1) номер минимального элемента ; 2) сумму элементов массива ; Преобразовать массив таким образом , чтобы сначала располагались все элементы , модуль которых не превышает 1 , а потом - все остальные .

Задача 2 В одномерном массиве , состоящем из n вещественных элементов , вычислить ; !

) минимальный по модулю элемент массива ; 2) сумму модулей элементов массива , расположенных после первого элемента , равного нулю .

Преобразовать массив таким образом , чтобы в первой его половине располагались элементы в четных позивиях , а во второй половине - элементы , стоявшие в нечетных позициях.

Инфинитив 23 июл. 2020 г., 13:42:12 | 10 - 11 классы

В одномерном массиве А , состоящий из N действительных элементов , вычислить : a ) сумму отрицательных элементов массива ; b ) количество элементов , удовлетворяющих условию 7 Pascal?

В одномерном массиве А , состоящий из N действительных элементов , вычислить : a ) сумму отрицательных элементов массива ; b ) количество элементов , удовлетворяющих условию 7 Pascal.

Настя2005 3 янв. 2020 г., 06:37:14 | 5 - 9 классы

Дан одномерный массив, состоящий из вещественных элементов?

Дан одномерный массив, состоящий из вещественных элементов.

Найти сумму элементов массива, расположенных до последнего положительного элемента.

Julia8282 3 дек. 2020 г., 11:36:00 | 5 - 9 классы

Дан одномерный массив, состоящий из N элементов?

Дан одномерный массив, состоящий из N элементов.

Найти максимальный из нечетных элементов массива.

Budnik170678gmailcom 23 янв. 2020 г., 11:41:00 | 5 - 9 классы

Помогите пожалуйста с задачей в паскале В одномерном массиве, состоящем из N элементов, вычислить : 1) количество элементов массива, больших С 2) произведение элементов массива, расположенных после ма?

Помогите пожалуйста с задачей в паскале В одномерном массиве, состоящем из N элементов, вычислить : 1) количество элементов массива, больших С 2) произведение элементов массива, расположенных после максимального по модулю элемента 3) преобразовать массив таким образом, чтобы сначала размещались все отрицательные элементе, а потом - все положительные (0 считать положительным).

Artem1918 1 янв. 2020 г., 05:23:47 | 10 - 11 классы

Создать два одномерных массива, состоящих из целых чисел?

Создать два одномерных массива, состоящих из целых чисел.

Элементы массива вводятся с клавиатуры.

В первом массиве найти номер первого нечетного элемента массива.

Во втором массиве найти первый четный элемент массива.

Решить на Pascal ABC (При решении задач обязательно использовать одномерные массивы и процедуры или функции работы с одномерными массивами.

).

Помогать1 6 нояб. 2020 г., 19:51:15 | 5 - 9 классы

Pascal 1?

Pascal 1.

Найти среднее арифметическое положительных элементов одномерного массива.

2. Найти минимальный элемент одномерного массива.

Pro100zheka 5 нояб. 2020 г., 16:50:49 | 5 - 9 классы

Заполнить массив из 10 элементов случайными целыми числами из диапазона - 100 – + 100?

Заполнить массив из 10 элементов случайными целыми числами из диапазона - 100 – + 100.

Найти :

a) наименьший элемент массива и его порядковый номер ;

b) наибольший элемент массива и его порядковый номер ;

c) сумму отрицательных и положительных элементов массива ;

d) среднее арифметическое отрицательных и положительных элементов массива ;

e) количество значений отрицательных, положительных и равных нулю элементов массива ;

Вы находитесь на странице вопроса В одномерном массиве, состоящем из n целых случайных элементов из диапазона от - 10 до 10 вычислите : 1) среднее арифметическое отрицательных нечетных элементов массива , 2) сумму элементов массива, р? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 10 - 11 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.