Дан прямоугольник, длины сторон которого a и b являются натуральными числами?

Информатика | 5 - 9 классы

Дан прямоугольник, длины сторон которого a и b являются натуральными числами.

Определить, на сколько квадратов максимальной площади можно разделить данный прямоугольник, укажите их размеры.

Составьте программу на паскале абс.

Ответить на вопрос
Ответы (1)
111Ulya111 28 дек. 2020 г., 00:03:58

Var a, b, c, d, nod, k : integer ;

begin

write('a = ') ; readln(a) ;

write('b = ') ; readln(b) ;

c : = a ; d : = b ;

while (c> ; 0)and(d> ; 0) do

if c> ; d then c : = c mod d else d : = d mod c ;

nod : = c + d ;

k : = (a div nod) * (b div nod) ;

writeln(k, ' квадратов размером ', nod, 'x', nod) ;

end.

Пример :

a = 6

b = 15

10 квадратов размером 3x3.

Oksanasambur 8 февр. 2020 г., 08:15:41 | 5 - 9 классы

1)даны целые положительные числа А, В, С?

1)даны целые положительные числа А, В, С.

На прямоугольнике размера А * В размещено максимально возможное количество квадратов со стороной С(без наложений).

Найти количество квадратов, размещенных на прямоугольнике, а также площадь незанятой части прямоугольника 2)Дан номер некоторого года (целое положительное число).

Определить соответствующий ему номер столетия, учитывая, что, к примеру, началом 20 столетия был 1901 год.

Ainura20005 28 июл. 2020 г., 12:21:19 | 5 - 9 классы

Программа на языке паскаль?

Программа на языке паскаль.

Дано натуральное N .

Определить, является ли оно простым.

Соня183 11 янв. 2020 г., 21:06:13 | 10 - 11 классы

Даны три натуральных числа, являющиеся длинами сторон треугольника?

Даны три натуральных числа, являющиеся длинами сторон треугольника.

Число ввести с клавиатуры.

Определить является ли треугольник прямоугольным, если эти отрезки позволяют его построить.

Написать программу на паскале только на паскале и не на другом языке!

Ivanushun12345 2 июл. 2020 г., 12:04:02 | 5 - 9 классы

Pascal ABC?

Pascal ABC.

Дано натуральное число "n".

Составьте программу которая выводит максимальную цифру этого числа.

Улка1 29 мар. 2020 г., 10:07:58 | 5 - 9 классы

Паскаль составьте программу определения наибольшей цифры в записи данного натурального числа?

Паскаль составьте программу определения наибольшей цифры в записи данного натурального числа.

89512170510 16 янв. 2020 г., 19:39:07 | 5 - 9 классы

Дана площадь квадрата?

Дана площадь квадрата.

Составьте программу для вычисления его стороны и периметра.

Программу хорошую и понятную составить( в Паскале), все - таки баллов не мало.

Arishakarimova 3 авг. 2020 г., 21:36:47 | 10 - 11 классы

Делать в Паскале?

Делать в Паскале.

Даны стороны прямоугольника.

Найти его площадь и периметр.

Dasha20022183 24 мар. 2020 г., 09:51:05 | 5 - 9 классы

Составьте программу, которая вводит с клавиатуры длину и ширину прямоугольника и определяет, является ли прямоугольник квадратом?

Составьте программу, которая вводит с клавиатуры длину и ширину прямоугольника и определяет, является ли прямоугольник квадратом.

Постройте данный прямоугольник (единицу длины показать 10 пикселями).

Викатарина 30 янв. 2020 г., 10:28:39 | 10 - 11 классы

Составить программу, печатающую все простые числа, не превосходящие данного числа?

Составить программу, печатающую все простые числа, не превосходящие данного числа.

Паскаль абс.

Anastasia20025 23 окт. 2020 г., 08:47:58 | 5 - 9 классы

Дана сторона квадрата ?

Дана сторона квадрата .

Составьте программу для вычисления а)периметра б) длины диагонали в) площади квадрата.

Вы находитесь на странице вопроса Дан прямоугольник, длины сторон которого a и b являются натуральными числами? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 5 - 9 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.