Паскаль составьте программу определения наибольшей цифры в записи данного натурального числа?

Информатика | 5 - 9 классы

Паскаль составьте программу определения наибольшей цифры в записи данного натурального числа.

Ответить на вопрос
Ответы (1)
Sasha900000 29 мар. 2020 г., 10:08:02

Program prog ;

uses crt ;

var x, y : integer ;

begin

clrscr ;

write ('x = ') ;

readln(x) ;

while abs(x)> ; 0 do begin

if abs(x mod 10)> ; y then y : = abs(x mod 10) ;

x : = x div 10 ;

end ;

writeln('Наибольшая цифра чсла = ', y) ;

end.

Vedma12 13 февр. 2020 г., 05:20:31 | 5 - 9 классы

Помогите, пожалуйста, составить программу в паскале?

Помогите, пожалуйста, составить программу в паскале!

Дано четырехзначное число заменить в нем наибольшую цифру нулем.

Черноключница 9 нояб. 2020 г., 08:18:46 | 10 - 11 классы

Дано натуральное число N?

Дано натуральное число N.

Составте программу, котора определяет, сколько раз в числе N содержится наибольшая цифра этого числа.

Antonkhvorov 20 июн. 2020 г., 12:56:51 | 10 - 11 классы

1) дано натуральное а?

1) дано натуральное а.

Верно ли, что данное число состоит из 3 цифр?

2) дано натуральное число.

Верно ли, что в данном числе четыре цифры?

3) Даны два натуральных числа.

Определить в каком числе первая цифра больше.

4) Дано натуральное n.

Найти количество 6, входящих в данное число.

Нужно решить в программе паскаль.

Если поможет, то мы учим цикл в паскале, div, mod.

Gulchatayogly 26 апр. 2020 г., 08:30:02 | 5 - 9 классы

Напишите программу на языке программирования (или составьте алгоритм)?

Напишите программу на языке программирования (или составьте алгоритм).

Дано натуральное число n.

Определите, сколько раз цифра «7» встречается в записи данного числа.

CamKo 22 мар. 2020 г., 10:05:22 | 5 - 9 классы

Составить программу на паскале Дано натуральное число, найти сумму цифр этого числа?

Составить программу на паскале Дано натуральное число, найти сумму цифр этого числа!

Физика9клас 14 дек. 2020 г., 14:38:56 | 5 - 9 классы

Составьте алгоритм для определения количества цифр в записи произвольного натурального числа?

Составьте алгоритм для определения количества цифр в записи произвольного натурального числа.

Sofiykas 5 июн. 2020 г., 20:18:17 | 10 - 11 классы

Даны натуральные числа m и n?

Даны натуральные числа m и n.

Получить число состоящее из m последних чётных цифр числа n.

Написать программу на Паскале только на Паскале.

Надежжжжжж 13 дек. 2020 г., 19:28:04 | 5 - 9 классы

Составьте алгоритм для определения количества цифр в записи произвольного натурального числа (для программы Паскаль)?

Составьте алгоритм для определения количества цифр в записи произвольного натурального числа (для программы Паскаль).

Anyaeremkina 20 сент. 2020 г., 10:13:27 | 10 - 11 классы

Помогите написать программу на C + + (целоцисленная арифметика)?

Помогите написать программу на C + + (целоцисленная арифметика).

Найти наибольшую и наименьшую цифры в записи заданного натурального числа.

Катюшка170212 27 сент. 2020 г., 04:27:12 | 5 - 9 классы

Написать программу в паскале?

Написать программу в паскале.

Дано натуральное число Х.

Найти сумму квадратов чётных цифр в числе.

Вы открыли страницу вопроса Паскаль составьте программу определения наибольшей цифры в записи данного натурального числа?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 5 - 9 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.