Задан текст в виде последовательности из 40 слов, каждое не более 25 символов?

Информатика | 10 - 11 классы

Задан текст в виде последовательности из 40 слов, каждое не более 25 символов.

Сколько раз в тексте встречаются слова : ЗНАЧИТ, ВОТ, АВТМОБИЛЬ?

Через процедуры.

Ответить на вопрос
Ответы (2)
Ильмира6 11 янв. 2020 г., 11:08:24

В программе предполагается, что слова отделяются друг от друга одним пробелом, знаков препинания нет.

Const m = 3 ;

var s : string ;

sl : array[1.

M] of string = ('ЗНАЧИТ', 'ВОТ', 'АВТОМОБИЛЬ') ;

n : array[1.

M] of integer ;

i : integer ;

procedure pr(s1, s2 : string ; var k : integer) ;

var l, p : integer ;

begin

s1 : = ' ' + s1 + ' ' ;

l : = length(s2) ;

k : = 0 ;

p : = pos(s2, s1) ;

while p> ; 0 do begin if (s1[p - 1] = ' ')and(s1[p + l] = ' ') then k : = k + 1 ; delete(s1, 1, p + l) ; p : = pos(s2, s1) ; end ;

end ;

begin

writeln('Введите текст : ') ;

readln(s) ;

for i : = 1 to m do

begin

pr(s, sl[i], n[i]) ;

writeln(sl[i], ' - ', n[i]) ;

end ;

end.

Пример (слов меньше 40) :

Введите текст :

ЗНАЧИТ ТАК ВОТ АВТОМОБИЛЬ РАЗ ВОТ АВТОМОБИЛЬ ДВА ВОТ АВТОМОБИЛЬ ТРИ

ЗНАЧИТ - 1

ВОТ - 3

АВТОМОБИЛЬ - 3.

Саша55517 11 янв. 2020 г., 11:08:27

Этой программе все равно, сколько слов во фразе и какой они длины.

А заодно, ей все равно, сколько между словами пробелов.

/ / PascalABC.

NET 3.

1, сборка 1230 от 27.

04. 2016

procedure Times(a : array of string ; pic : string ; var n : integer) ;

begin n : = a.

Where(s - > ; s = pic).

Count

end ;

begin var s : = ReadlnString('> ; ').

ToWords ; var k : integer ; var w : = 'ЗНАЧИТ' ; Times(s, w, k) ; Println(k, ' - ', w) ; w : = 'ВОТ' ; Times(s, w, k) ; Println(k, ' - ', w) ; w : = 'АВТОМОБИЛЬ' ; Times(s, w, k) ; Println(k, ' - ', w) ;

end.

Тестовое решение

> ; ВОТ ЗНАЧИТ КАКОЕ ДЕЛО БЫЛО ЕХАЛ ПО ДОРОГЕ АВТОМОБИЛЬ И ВОТ СТОИТ ЧЕЛОВЕК И ДУМАЕТ А ЧТО ЗНАЧИТ СЛОВО АВТОМОБИЛЬ А СЛОВО АВТОМОБИЛЬ ЭТО ОТ ГРЕЧЕСКОГО АУТОС (САМ) И ЛАТИНСКОГО МОБИЛИС (ПОДВИЖНЫЙ) ВОТ ТАКОЕ ЭТО СЛОВО

2 - ЗНАЧИТ

3 - ВОТ

3 - АВТОМОБИЛЬ.

Srybtsova1 7 апр. 2020 г., 22:03:21 | 5 - 9 классы

Срочно?

Срочно!

Pascal

Из заданного текста предложения выбрать и напечатать только те символы, которые встречаются в нем только один раз (в том порядке, в котором они встречаются в тексте).

DimonStrizhakov 14 мая 2020 г., 15:45:38 | 1 - 4 классы

Отметьте что может рассматриваться в качестве фрагмента текста : cимвол слово строкa последовательность символов предложение абзац документ?

Отметьте что может рассматриваться в качестве фрагмента текста : cимвол слово строкa последовательность символов предложение абзац документ.

Vikaviking 12 янв. 2020 г., 10:53:41 | 10 - 11 классы

Cтроки?

Cтроки.

Паскаль.

1. Задано слово - последовательность произвольных символов.

Сделать программу, в которой составляется слово перевертыш к данному ( символы записываются в обратной последовательности.

) 2. Дана символьная строка.

Слово - последовательность символов между пробелами, не содержащая пробелы внутри себя.

Составить программу, в которой выводились бы все слова, в которых есть заданный символ.

Vikaermo 3 мая 2020 г., 12:32:34 | 10 - 11 классы

Pascal?

Pascal.

Задана последовательность символов, за которой следует точка (в саму последовательность точка не входит).

Напечатать текст, удалив из него все цифры.

89671631134vova 21 апр. 2020 г., 18:29:27 | 10 - 11 классы

В заданном тексте перевернуть каждое слово Программу сделать с помощью процедур Текст набить вручную(не больше 10 слов)?

В заданном тексте перевернуть каждое слово Программу сделать с помощью процедур Текст набить вручную(не больше 10 слов).

Pascal.

Iera89229317811 8 авг. 2020 г., 06:48:22 | 10 - 11 классы

Ввести текст?

Ввести текст.

Определить сколько раз встречается заданное слово.

Паскаль.

Inkonas 18 февр. 2020 г., 22:37:27 | 5 - 9 классы

1. Сформировать текст заданной длины, состоящий из 2 символов А и В?

1. Сформировать текст заданной длины, состоящий из 2 символов А и В.

2. Найдите количество символов заданного числа 25

3.

Написать программу обращения заданного слова (вывести символы строки в обратном порядке).

(слово привет)

4.

Составить программу печати кодов всех символов, входящих в состав заданного текста.

5. Найти сумму цифр заданного числа.

(число 25)

6.

Составить программу для подсчета русских букв «А» в заданном тексте

7.

Произвести подсчет слогов в данном русском тексте задания про тексты, там можно любое предложение, какое хотите.

Ииачсаомо 23 апр. 2020 г., 18:48:27 | 10 - 11 классы

Дана страка символов, содержашая слова, то есть группы символов, разделеные пробелами( не менее одного)?

Дана страка символов, содержашая слова, то есть группы символов, разделеные пробелами( не менее одного).

Составте программу, которая определяет , сколько раз в тексте встречается задоное слово».

Jenybeliuycom 1 сент. 2020 г., 08:36:16 | 10 - 11 классы

Встречается ли в тексте слово, начинающееся на заданную букву?

Встречается ли в тексте слово, начинающееся на заданную букву?

(турбо паскаль).

Alinakhudiakova 16 дек. 2020 г., 18:14:48 | 1 - 4 классы

Задать произвольный текст, сколько слов в тексте начинаются на букву "а"?

Задать произвольный текст, сколько слов в тексте начинаются на букву "а".

На этой странице находится ответ на вопрос Задан текст в виде последовательности из 40 слов, каждое не более 25 символов?, из категории Информатика, соответствующий программе для 10 - 11 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.