Дан целочисленный массив из 50 элементов?

Информатика | 5 - 9 классы

Дан целочисленный массив из 50 элементов.

Элементы массива могут приннимать целые значения от 0 до 1000.

Найти и вывести номер элемента массива, имеющего максимальное значение среди элементов массива, которые больше, чем 4 и меньше , чем 9.

Гарантируется , что в исходном массиве есть хотя бы один такой элемент.

На паскале , помогите пожалуйста.

Ответить на вопрос
Ответы (1)
Dudubala1 14 апр. 2020 г., 00:11:04

Var

a : array[1.

10] of integer ;

i, max, imax : integer ;

begin

for i : = 1 to 10 do

readln(a[i]) ;

max : = 0 ;

for i : = 1 to 10 do

if (a[i] > ; max) and (a[i] > ; 4) and (a[i] < ; 9) then

begin

max : = a[i] ;

imax : = i ;

end ;

writeln(imax) ;

end.

Een929 11 июн. 2020 г., 12:23:29 | 10 - 11 классы

Паскаль?

Паскаль.

Вычислить разность максимального среди элементов, имеющих четные значения, и максимального среди элементов, имеющих нечетные значения, в заданном целочисленном массиве из 30 положительных элементов (в предположении, что в массиве есть и четные, и нечетные элементы).

Abdusalamova99 8 апр. 2020 г., 20:11:35 | 10 - 11 классы

Составить программу на языке Паскаль : 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0?

Составить программу на языке Паскаль : 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0.

2)В массиве М из 10 целых чисел найти количество элементов равных 3.

3)В массиве из 8 целых найти номер массива с наибольшим значением.

4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента.

5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

Alsuska18 11 апр. 2020 г., 04:10:32 | 5 - 9 классы

Дан целочисленный массив из 20 элементов элементы могут принимать значения - 1000 до 1000 позволяет найти и вывести минимальные значения среди элементов массива которые имеют четные значения и не деля?

Дан целочисленный массив из 20 элементов элементы могут принимать значения - 1000 до 1000 позволяет найти и вывести минимальные значения среди элементов массива которые имеют четные значения и не делятся на 3.

Настя631прдлвптррии 2 июн. 2020 г., 15:30:58 | 5 - 9 классы

1) Удвоить все элементы массива?

1) Удвоить все элементы массива.

2)Найти сумму элементов двух массивов одинаковой размерности.

4) Найти Минимальные элементы массива и его индекс.

5) Найти максимальные элементы среди положительных элементов массива 6) Найти максимальные элементы среди отрицательных элементов массива 7) Определить количество максимальных элементов массива P.

S Ребят, все в паскале.

Заранее спасибо = *.

Karinka1984 7 авг. 2020 г., 17:21:14 | 10 - 11 классы

Дан массив из 30 элементов, принимающих значения от 0 до 100?

Дан массив из 30 элементов, принимающих значения от 0 до 100.

Найти произведение двузначных чётных элементов массива, которые начинаются с цифры 5, 6 или 7.

Гарантируется, что в исходном массиве есть хотя бы один такой элемент.

Qleb 12 июн. 2020 г., 21:57:19 | 5 - 9 классы

Дан массив состоящий из 30 элементов?

Дан массив состоящий из 30 элементов.

Найти в массиве максимальный элемент, вывести его значение и номер на экран.

Отрицательный элемент массива заменить на равные по модулю положительные элементы.

Bog100 12 мая 2020 г., 16:05:02 | 5 - 9 классы

Дан целочисленный массив из 30 элементов?

Дан целочисленный массив из 30 элементов.

Элементы массива могут принимать значения от 0 до 1000.

Напишите программу, позволяющую найти и вывести количество элементов массива, кратных трём, запись которых заканчивается цифрой 1.

Паскаль АБС.

Olgapirog163 19 мар. 2020 г., 06:29:50 | 10 - 11 классы

Помогите пожалуйста : записать чётные положительные элементы целочисленных массивов X и Y в массив Z?

Помогите пожалуйста : записать чётные положительные элементы целочисленных массивов X и Y в массив Z.

Поменять минимальный и максимальный элементы массива Z.

Вывести элементы массива Z в четверичной системе счисления .

4yBAK4 28 окт. 2020 г., 14:55:27 | 5 - 9 классы

Дан целочисленный массив из 10 элементов?

Дан целочисленный массив из 10 элементов.

Элементы массива могут принимать целые значения от 0 до 1000.

Опишите на русском языке или на одном из языков программирования алгоритм, позволяющий найти и вывести номер первого элемента массива, который делится на 3.

Гарантируется, что в исходном массиве есть хотя бы один такой элемент.

Программу я написал, но выводит все значения, а мне нужно первое.

GrafAleksandr1 7 дек. 2020 г., 19:21:13 | 10 - 11 классы

Дан целочисленный массив из 20 элементов?

Дан целочисленный массив из 20 элементов.

Элементы массива могут принимать целые значения от 0 до 10000 включительно.

Опишите алгоритм, позволяющий найти и вывести максимальное значение среди трёхзначных элементов массива, не делящихся на 7.

Если в исходном массиве нет элемента, значение которого является трёхзначным числом и при этом кратно 7, то вывести сообщение «Не найдено».

На языке PHP.

Вы находитесь на странице вопроса Дан целочисленный массив из 50 элементов? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 5 - 9 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.