Помогите пжлст?

Информатика | 5 - 9 классы

Помогите пжлст.

Даны натуральные число n и целые числа a1, a2, .

, an.

Верно ли, что максимальное из чисел ai превышает минимальное не более чем на 25.

Ответить на вопрос
Ответы (1)
Gigabator 22 мар. 2020 г., 22:42:52

/ / PascalABC.

NET (версия 3.

1, сборка 1210 от 29.

03. 2016)

var a, n, i, min, max : integer ;

begin min : = maxint ; max : = - maxint ; write('Число элементов последовательности ') ; readln(n) ; for i : = 1 to n do begin a : = random(61) - 30 ; if a> ; max then max : = a ; if a< ; min then min : = a ; write(a : 4) ; end ; writeln ; if max< ; = (min + 25) then writeln ('максимальное ', max , ' превышает минимальное ', min, ' не более чем на 25') else writeln ('максимальное ', max , ' превышает минимальное ', min, ' более чем на 25') ;

end.

Тест №1

Число элементов последовательности 3 - 9 2 10

максимальное 10 превышает минимальное - 9 не более чем на 25

Тест №2

Число элементов последовательности 5 10 - 17 13 26 - 2

максимальное 26 превышает минимальное - 17 более чем на 25.

Irinanovikova1 15 июн. 2020 г., 13:28:36 | 5 - 9 классы

Напишите программу, которая в последовательности натуральныхчисел определяет минимальное число, оканчивающееся на 6?

Напишите программу, которая в последовательности натуральных

чисел определяет минимальное число, оканчивающееся на 6.

Программа получает на вход количество чисел в последовательности, а затем

сами числа.

В последовательности всегда имеется число, оканчивающееся

на 6.

Количество чисел не превышает 1000.

Введённые числа не превышают

30 000.

Программа должна вывести одно число – минимальное число,

оканчивающееся на 6.

Колямашина 31 авг. 2020 г., 20:24:19 | 10 - 11 классы

Дано натуральное число b и n целых чисел?

Дано натуральное число b и n целых чисел.

Верно ли, что сумма данных целых чисел не превышает b.

Татьяна821 22 окт. 2020 г., 01:31:31 | 10 - 11 классы

Дана последовательность чисел?

Дана последовательность чисел.

Найти минимальное и максимальное число и вычислить их среднее арифметическое.

Asasin007 8 дек. 2020 г., 18:06:28 | 5 - 9 классы

Программа в Паскале?

Программа в Паскале!

"Напишите программу, которая в последовательности целых чисел определяет сумму максимального и минимального чисел .

Программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом ноль (ноль – признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введенные числа по модулю не превышают 30000.

" Отдал все пункты что есть!

Помогите!

Murad345 4 окт. 2020 г., 05:28:04 | 5 - 9 классы

C + + Напишите программу, которая в последовательности целых чисел определяет разность максимального и минимального чисел?

C + + Напишите программу, которая в последовательности целых чисел определяет разность максимального и минимального чисел.

Программа получает на входе целее числа, количество введённых чисел неизвестно, последовательность чисел заканчивается число 0 (0 - признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введённые числа по модулю не превышают 30000.

Программа должна вывести одно число : разность максимального и минимального чисел.

Dasyona1 11 нояб. 2020 г., 22:37:20 | 5 - 9 классы

Дано натуральное число N, в котором все цифры различны?

Дано натуральное число N, в котором все цифры различны.

Найти остаток от деления максимальной цифры на минимальную цифру данного числа.

Alfa257604 21 июн. 2020 г., 14:20:13 | 5 - 9 классы

ПОМОГИТЕ, ПОЖАЛУЙСТА?

ПОМОГИТЕ, ПОЖАЛУЙСТА!

Дано натуральное число.

Верно ли, что сумма его чисел больше k, а само число четное?

Chokopy 18 июн. 2020 г., 13:10:32 | 10 - 11 классы

Напишите программу, которая в последовательности целых чисел определяет максимальное число?

Напишите программу, которая в последовательности целых чисел определяет максимальное число.

Программа получает на вход целые числа, количество введенных чисел неизвестно.

Последовательность числа заканчивается числом 0.

Количество чисел не превышает 1000.

Введённые числа по модулю не превышает 30000.

Программа должна вывести одно максимальное число.

Luxor1 17 дек. 2020 г., 01:12:22 | 10 - 11 классы

Даны 5 целых чисел?

Даны 5 целых чисел.

Посчитайте минимально возможную и максимально возможные

суммы выбрав ровно 4 числа из заданных изначально с + +.

GHOST2323 17 дек. 2020 г., 08:04:12 | 5 - 9 классы

ПАСКАЛЬдано натуральные число н и действительные числа а1, а2 ?

ПАСКАЛЬ

дано натуральные число н и действительные числа а1, а2 .

Ан. Найти минимальное и максимальное число.

Перед вами страница с вопросом Помогите пжлст?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 5 - 9 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.