Пользователь вводит число N программа считает сумму четных чисел до N и сумму не четных чисел до N?

Информатика | 10 - 11 классы

Пользователь вводит число N программа считает сумму четных чисел до N и сумму не четных чисел до N.

Написать алгоритм решения.

Ответить на вопрос
Ответы (1)
Katrin137 28 авг. 2020 г., 18:27:37

PascalABC :

var s1, s2, n, i : integer ;

begin

writeln('До какого числа будем считать?

') ; readln(n) ;

for i : = 1 to n - 1 do begin

if i mod 2 = 0 then s1 : = s1 + i ;

if i mod 2 < ; > ; 0 then s2 : = s2 + i ;

end ;

writeln('Сумма четных чисел = ', s1) ;

writeln('Сумма нечетных чисел = ', s2) ;

end.

Dadzvonik 22 мар. 2020 г., 08:10:31 | 5 - 9 классы

Написать программу которая находит сумму четных чисел от 0 до 1000?

Написать программу которая находит сумму четных чисел от 0 до 1000.

Duble 19 февр. 2020 г., 07:21:32 | 10 - 11 классы

Создать алгоритм вычисления суммы кубов четных чисел от 100 до 300?

Создать алгоритм вычисления суммы кубов четных чисел от 100 до 300.

Medko 27 апр. 2020 г., 21:52:53 | 10 - 11 классы

Написать программу в Паскале?

Написать программу в Паскале.

Подсчитать сумму четных целых чисел находящихся от одного до значения введенного пользователем.

Гордон11111 4 авг. 2020 г., 18:14:55 | 5 - 9 классы

Написать программу Пользователь вводит 5 целых чисел, программа находит сумму всех отрицательных и произведение всех положительных чисел?

Написать программу Пользователь вводит 5 целых чисел, программа находит сумму всех отрицательных и произведение всех положительных чисел.

Ugarashka 1 дек. 2020 г., 20:27:25 | 5 - 9 классы

Написать программу, которая вычисляет сумму первых n целых положительных чисел?

Написать программу, которая вычисляет сумму первых n целых положительных чисел.

Кол - во суммируемых чисел должно вводиться во время работы программы.

Ниже представлен рекомендуемый вид экрана во время работы программы : Вычисление суммы четных положительных чисел.

Введите количество суммируемых чисел и нажмите - > ; 12 Сумма первых 12 положительных четных чисел равна 156.

Валерия123123 20 июл. 2020 г., 11:14:21 | 10 - 11 классы

С клавиатуры вводятся 3 числа?

С клавиатуры вводятся 3 числа.

Найти количество и сумму четных чисел среди них.

Если среди введенных четных нет, то вывести соответствующее сообщение.

Zakirkhan 8 авг. 2020 г., 11:41:09 | 5 - 9 классы

В кумире : найти сумму четных чисел натурального числа?

В кумире : найти сумму четных чисел натурального числа.

( надсо ставить программу).

Leonid1bmx 8 окт. 2020 г., 12:20:21 | 5 - 9 классы

Написать в Паскале, с клавиатуры набрать 15 чисел, программа считает сумму четных чисел?

Написать в Паскале, с клавиатуры набрать 15 чисел, программа считает сумму четных чисел.

ЛенаГрабовская 9 нояб. 2020 г., 03:15:23 | 5 - 9 классы

Написать алгоритм нахождения суммы четных чисел от 0 до 12?

Написать алгоритм нахождения суммы четных чисел от 0 до 12.

12333333312121312 11 нояб. 2020 г., 09:54:13 | 5 - 9 классы

Помогите пожалуйста?

Помогите пожалуйста.

Пользователь вводит 20 чисел.

Напишите программу, которая будет считать количество четных чисел.

Надо сделать в PascalABC .

8 класс.

СРОЧНО!

Вопрос Пользователь вводит число N программа считает сумму четных чисел до N и сумму не четных чисел до N?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 10 - 11 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.