Даны стороны треугольника?

Информатика | 10 - 11 классы

Даны стороны треугольника.

Определить его вид : равносторонний, равнобедренный или разносторонний - и вывести сообщение об этом.

И кроме того, если треугольник равносторонний, то найти его высоту, если он равнобедренный, то найти его полупериметр, а в противном случае найти его наибольшую сторону.

Ответить на вопрос
Ответы (1)
Olesja2015 7 янв. 2020 г., 19:54:35

Var a, b, c : real ;

begin

readln(a, b, c) ;

if (a = b) and (b = c) then begin

writeln ('Треугольник равносторонний') ;

writeln('Его высота = ', (sqrt(3) * a) / 2 : 0 : 3)

endelse

if (a = b) or (b = c) or (c = a) then begin

writeln('Треугольник равнобедренный') ;

writeln('Его полупериметр = ', (a + b + c) / 2) ;

endelse

begin

writeln('Треугольник разносторонний') ;

if (a> ; b) and (a> ; c) then writeln('Большая сторона = ', a) else

if (b> ; a) and (b> ; c) then writeln('Большая сторона = ', b) else

writeln('Большая сторона = ', c) ; end ;

end.

Dsfgh 18 февр. 2020 г., 11:50:16 | 10 - 11 классы

Даны три положительных числа?

Даны три положительных числа.

Если они могут быть длинами сторон остроугольного треугольника, то вычислить его площадь и определить вид треугольника ( равносторонний, равнобедренный или разносторонний), иначе выдать соответсвующее сообщение.

Piopikpiopik 8 апр. 2020 г., 06:16:07 | 5 - 9 классы

Составить программу, классифицирующую треугольники по сторонам, если заданы градусные меры трех углов (равносторонний, равнобедренный, разносторонний, прямоугольный)?

Составить программу, классифицирующую треугольники по сторонам, если заданы градусные меры трех углов (равносторонний, равнобедренный, разносторонний, прямоугольный).

Жайнуля 22 февр. 2020 г., 08:47:05 | 5 - 9 классы

Найти сторону равностороннего треугольника по его площади в программе паскаль?

Найти сторону равностороннего треугольника по его площади в программе паскаль.

Tatyanarybonka 9 апр. 2020 г., 08:24:43 | 10 - 11 классы

ПОМОГИТЕ?

ПОМОГИТЕ!

Дана сторона равностороннего треугольника.

Найти площадь этого треугольника.

(в бейсике) Заранее спасибо!

Sedoykuliga 18 сент. 2020 г., 02:46:40 | 5 - 9 классы

Даны три стороны треугольника ?

Даны три стороны треугольника .

Определить существует ли треугольник с заданными сторонами, если да , то определить является ли он прямоугольным, равнобедренным или равносторонним, какой треугольник тупоугольный или остроугольный.

Missisanat 14 дек. 2020 г., 22:04:05 | 10 - 11 классы

Помогите пж?

Помогите пж.

Составить линейную программу для решения задачи.

Дана сторона равностороннего треугольника.

Найти высоту этого треугольника.

Korolcs777 2 февр. 2020 г., 08:58:39 | 5 - 9 классы

Даны три натуральных числа?

Даны три натуральных числа.

Напишите программу, определяющую, существует ли треугольник с такими длинами сторон.

Если такой треугольник существует, то определите его тип(равносторонний, равнобедренный, разносторонний).

НАПИСАТЬ В БЛОК СХЕМЕ!

021 17 мая 2020 г., 22:00:21 | 10 - 11 классы

1. Дана сторона равностороннего треугольника?

1. Дана сторона равностороннего треугольника.

Найти площадь этого треугольника и радиусы вписанной и описанной окружностей.

Kamila2597 15 апр. 2020 г., 14:00:24 | 5 - 9 классы

1)Даны стороны треугольник?

1)Даны стороны треугольник.

Определить является ли этот треугольник : а)равносторонним б)равнобедренным в)прямоугольным Надо делать через блок схему, помогите : (.

Kuganova30 1 мар. 2020 г., 11:19:21 | 10 - 11 классы

Даны три натуральных числа?

Даны три натуральных числа.

Напишите программу, определяющую, существует ли треугольник с такими длинами сторон.

Если такой треугольник существует, то определите его тип ( равносторонний, равнобедренный, разносторонний).

На этой странице находится ответ на вопрос Даны стороны треугольника?, из категории Информатика, соответствующий программе для 10 - 11 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.