Дан массив, содержащий 2016 целых чисел?

Информатика | 10 - 11 классы

Дан массив, содержащий 2016 целых чисел.

Необходимо найти и вывести сумму тех элементов этого массива, чётность которых совпадает с чётностью максимального элемента.

Например, в массиве из 6 элементов, равных соответственно 2, 3, 1, 5, 6, 4, максимальный элемент чётный (6), значит, ответом будет сумма чётных элементов этого массива 2 + 6 + 4 = 12.

Помогите написать программу на паскале.

Ответить на вопрос
Ответы (1)
Ismial2222 24 нояб. 2020 г., 05:24:55

Var a, max, sum : integer ; arr : array [0.

2015] of integer ; begin

randomize ;

max : = - 500 ;

sum : = 0 ;

for a : = 0 to 2015 do begin

arr[a] : = random(1001) - 500 ;

if max< ; arr[a] then max : = arr[a] ;

end ;

write('максимальный элемент массива = = > ; ', max) ;

writeln() ;

if max mod 2 = 1 then begin

for a : = 0 to 2015 do begin

if arr[a] mod 2 = 1 then sum : = sum + arr[a] ;

end ;

writeln('сумма чисел одинаковой чётности числу ', max, ' = ', sum) ;

end ;

sum : = 0 ;

if max mod 2 = 0 then begin

for a : = 0 to 2015 do begin

if arr[a] mod 2 = 0 then sum : = sum + arr[a] ;

end ;

writeln('сумма чисел одинаковой чётности числу ', max, ' = ', sum) ;

end ;

end.

Abdusalamova99 8 апр. 2020 г., 20:11:35 | 10 - 11 классы

Составить программу на языке Паскаль : 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0?

Составить программу на языке Паскаль : 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0.

2)В массиве М из 10 целых чисел найти количество элементов равных 3.

3)В массиве из 8 целых найти номер массива с наибольшим значением.

4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента.

5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

Миньон4 2 янв. 2020 г., 08:46:10 | 10 - 11 классы

Дан массив всех целых чисел ?

Дан массив всех целых чисел .

Найти сумму элементов в массиве.

(Паскаль).

Настя631прдлвптррии 2 июн. 2020 г., 15:30:58 | 5 - 9 классы

1) Удвоить все элементы массива?

1) Удвоить все элементы массива.

2)Найти сумму элементов двух массивов одинаковой размерности.

4) Найти Минимальные элементы массива и его индекс.

5) Найти максимальные элементы среди положительных элементов массива 6) Найти максимальные элементы среди отрицательных элементов массива 7) Определить количество максимальных элементов массива P.

S Ребят, все в паскале.

Заранее спасибо = *.

Shkololo228339 21 апр. 2020 г., 13:14:36 | 10 - 11 классы

Задан массив из 10 целых чисел?

Задан массив из 10 целых чисел.

Написать программу которая находт - сумму всех элементов массива - колличество чётных и нечётных элементов массива.

2001viola 24 янв. 2020 г., 05:33:36 | 5 - 9 классы

Написать программу которая формирует массив из n элементов (максимальное количество элементов равно 20), значения элементов массива случайные целые числа от - 10 до 25?

Написать программу которая формирует массив из n элементов (максимальное количество элементов равно 20), значения элементов массива случайные целые числа от - 10 до 25.

Программа должна :

1)выводить на экран сначала все элементы массива, стоящие на чётных местах, а затем - все элементы массива, стоящие на нечётных местах ;

2)вывести на экран сумму всех элементов массива, значение которых кратны 3 или 5.

3)найти минимальное значение и максимальное значение элементов массива.

Mmtrr 6 сент. 2020 г., 12:50:34 | 10 - 11 классы

Написать алгоритмы нахождения суммы, произведения всех элементов массива и поиска максимального элемента массива?

Написать алгоритмы нахождения суммы, произведения всех элементов массива и поиска максимального элемента массива.

MRcoffee 14 мар. 2020 г., 08:36:28 | 5 - 9 классы

Помогите решить задачи на паскаль?

Помогите решить задачи на паскаль.

1) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти произведение всех элементов массива.

2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти сумму четных элементов массива.

3) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти максимальный элемент массива.

4) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти максимальный элемент массива среди элементов, кратных 3.

Aylovat40 16 окт. 2020 г., 08:55:54 | 10 - 11 классы

Дан одномерный массив из 12 чисел?

Дан одномерный массив из 12 чисел.

Элементами массива являются целые числа.

Найти максимальный элемент указанного массива.

Elenashmeleva1 14 апр. 2020 г., 00:10:59 | 5 - 9 классы

Дан целочисленный массив из 50 элементов?

Дан целочисленный массив из 50 элементов.

Элементы массива могут приннимать целые значения от 0 до 1000.

Найти и вывести номер элемента массива, имеющего максимальное значение среди элементов массива, которые больше, чем 4 и меньше , чем 9.

Гарантируется , что в исходном массиве есть хотя бы один такой элемент.

На паскале , помогите пожалуйста.

Polinok290 8 янв. 2020 г., 04:29:13 | 10 - 11 классы

Напишите программу которая находит максимальный и минимальный из чётных пложителных элементов массива?

Напишите программу которая находит максимальный и минимальный из чётных пложителных элементов массива.

Если в массиве нет чётных положительных элементов, нужно вывести сообщение об этом.

По информатика с ответам.

На странице вопроса Дан массив, содержащий 2016 целых чисел? из категории Информатика вы найдете ответ для уровня учащихся 10 - 11 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.