Определить, является ли трамвайный билет счастливым?

Информатика | 10 - 11 классы

Определить, является ли трамвайный билет счастливым?

Счастливым будем считать такое число из шести цифр, в котором сумма левых трех цифр равна сумме правых трех цифр.

Паскаль.

Ответить на вопрос
Ответы (2)
Niyaz971 26 мар. 2020 г., 21:38:01

Var n, n1, n2, s1, s2 : integer ;

begin

write('n = ') ; readln(n) ;

n1 : = n div 1000 ;

n2 : = n mod 1000 ;

s1 : = n1 div 100 + (n1 div 10 mod 10) + n1 mod 10 ;

s2 : = n2 div 100 + (n2 div 10 mod 10) + n2 mod 10 ;

if s1 = s2 then writeln('Билет счастливый')

else writeln('Билет не счастливый') ;

end.

Пример 1 :

n = 156309

Билет счастливый

Пример 2 :

n = 762453

Билет не счастливый.

Екатирина1245 26 мар. 2020 г., 21:38:06

Program lucky ;

var

n, l, r : integer ;

begin

writeln('введите номер билета') ;

readln(n) ;

l : = (n div 100000) + (n mod 100000 div 10000) + (n mod 100000 mod 10000 div 1000) ;

r : = (n mod 100000 mod 10000 mod 1000 div 100) + (n mod 100000 mod 10000 mod 1000 mod 100 div 10) + (n mod 100000 mod 10000 mod 1000 mod 100 mod 10) ;

if l = = r then

writeln('ваш билет счастливый')

else

writeln('ваш билет не счастливый') ;

end.

Tatanka212128 16 авг. 2020 г., 19:41:15 | 5 - 9 классы

Дано двузначное число?

Дано двузначное число.

Определить : а) является ли сумма его цифр двузначным числом ; б) больше ли числа а сумма его цифр.

Strelok8697 14 янв. 2020 г., 01:46:39 | 10 - 11 классы

Вывести щестизначных "счастливых" чисел (сумма первых трех цифр равна сумме трех последних), кратных семи в 10 колонок?

Вывести щестизначных "счастливых" чисел (сумма первых трех цифр равна сумме трех последних), кратных семи в 10 колонок.

Live96 12 февр. 2020 г., 23:57:43 | 10 - 11 классы

Напишите программу, которая считает сумму цифр введенного числа(паскаль)?

Напишите программу, которая считает сумму цифр введенного числа(паскаль).

Александра170997 28 дек. 2020 г., 11:05:44 | 5 - 9 классы

Определить сумму трех цифр пятизначного числа?

Определить сумму трех цифр пятизначного числа.

Otli4nik3 31 мая 2020 г., 01:48:43 | 10 - 11 классы

Помогите написать программу по информатике по задаче?

Помогите написать программу по информатике по задаче!

Пожалуйста!

Проверьте является ли шестизначный номер билета счастливым (сумма первых трёх цифр ровна сумме последних трёх цифр) надо через поскали как то ((( НА ФОТО 3 ЗАДАЧА.

Tigrankholod2 26 янв. 2020 г., 01:29:40 | 5 - 9 классы

Паскаль?

Паскаль!

Дано число.

Умножить его на 9 (один раз).

Получить сумму его цифр.

Т. е.

Доказать, что сумма цифр этого числа будет равна 9.

(В первом раскладе или во втором сумма цифр этого числа будет равна 9.

).

Данюшкин 27 июн. 2020 г., 22:16:15 | 5 - 9 классы

Номер билета в трамвае состоит из 6 цифр?

Номер билета в трамвае состоит из 6 цифр.

Счастливым называется билет, сумма первых трех цифр в котором равна сумме последних трех.

Сколько существует счастливых билетов таких, что они состоят только из цифр от 0 до 5 (при этом могут использоваться не все цифры)?

Innaganeva 2 окт. 2020 г., 22:03:11 | 10 - 11 классы

Номер билета в трамвае состоит из 6 цифр?

Номер билета в трамвае состоит из 6 цифр.

Счастливым называется билет, сумма первых трех цифр в котором равна сумме последних трех.

Сколько существует счастливых билетов таких, что они состоят только из цифр от 2 до 9 (при этом могут использоваться не все цифры)?

Kenzzo 24 нояб. 2020 г., 17:16:23 | 5 - 9 классы

Написать программу которая считает количество цифр в числе и их сумму?

Написать программу которая считает количество цифр в числе и их сумму.

Паскаль.

Число вводится с клавиатуры.

Milanka20021 7 окт. 2020 г., 10:11:45 | 5 - 9 классы

Cоставить программу, которая определяет, является ли 2 * N значное число "счастливым" (сумма цифр первой половины равна сумме цифр второй половины), где 1?

Cоставить программу, которая определяет, является ли 2 * N значное число "счастливым" (сумма цифр первой половины равна сумме цифр второй половины), где 1.

На этой странице находится ответ на вопрос Определить, является ли трамвайный билет счастливым?, из категории Информатика, соответствующий программе для 10 - 11 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.