Дан массив размера n x n?

Информатика | 10 - 11 классы

Дан массив размера n x n.

Найдите сумму, минимальный и максимальный из его элементов, расположенных над главной и над побочной диагоналями (элементы обеих диагоналей включить в рассмотрение).

Ответить на вопрос
Ответы (2)
Kos767676 20 дек. 2020 г., 13:52:01

Решение во вложении

Такая задача уже была раньше.

SanapackLerk 20 дек. 2020 г., 13:52:06

Пусть уже ответили, не пропадать же работе даром))

program test ;

var a : array[1.

10, 1.

10] of integer ; min, max, i, i1, sum, sum2 : integer ;

begin for i : = 1 to 10 do begin for i1 : = 1 to 10 do begin a[i, i1] : = random(1, 100) ; write(a[i, i1] : 4) ; end ; writeln ; end ; writeln('ГЛАВНАЯ ДИАГОНАЛЬ') ; min : = a[1, 1] ; for i : = 1 to 10 do begin for i1 : = i to 10 do begin sum : = sum + a[i, i1] ; if a[i, i1]> ; max then max : = a[i, i1] ; if a[i, i1]< ; min then min : = a[i, i1] ; end ; end ; writeln('сумма ', sum) ; writeln('Максимальное ', max) ; writeln('Минимальное ', min) ; sum : = 0 ; writeln('ПОБОЧНАЯ ДИАГОНАЛЬ') ; min : = a[1, 1] ; for i : = 10 downto 1 do begin for i1 : = 1 to i do begin sum : = sum + a[i, i1] ; if a[i, i1]> ; max then max : = a[i, i1] ; if a[i, i1]< ; min then min : = a[i, i1] ; end ; end ; writeln('сумма ', sum) ; writeln('Максимальное ', max) ; writeln('Минимальное ', min) ;

end.

Ila2904 29 сент. 2020 г., 23:03:04 | 10 - 11 классы

Ввести двумерный массив 4х4, найти произведение элементов главной диагонали матрицы, а так же сумму элементов подобных диагоналей?

Ввести двумерный массив 4х4, найти произведение элементов главной диагонали матрицы, а так же сумму элементов подобных диагоналей.

Polinadudiy 4 июн. 2020 г., 02:46:07 | 10 - 11 классы

Дана вещественная квадратная матрица А, размерностью n * n?

Дана вещественная квадратная матрица А, размерностью n * n.

Найти сумму элементов матрицы, расположенных под главной диагональю.

Angel1999861 24 июн. 2020 г., 05:15:04 | 10 - 11 классы

Дан одномерный массив на 15 элементов?

Дан одномерный массив на 15 элементов.

Переставить в обратном порядке элементы, расположенные между максимальным и минимальным элементами, включая их.

Veronica1902 22 окт. 2020 г., 22:58:05 | 10 - 11 классы

Помогите пожалуйста написать программу на паскале : дан массив целых чисел?

Помогите пожалуйста написать программу на паскале : дан массив целых чисел.

Найти количество элементов, кратных 5, расположенных между максимальным и минимальным элементами массива (включая их).

Серый1985 11 сент. 2020 г., 01:09:04 | 10 - 11 классы

Дан двумерный массив размером n * m, заполненный случайными числами?

Дан двумерный массив размером n * m, заполненный случайными числами.

Найти сумму его элементов, расположенных между максимальным и минимальным элементами (включая оба этих числа) - программный код для делфи.

Неугомонная 11 янв. 2020 г., 19:37:59 | 10 - 11 классы

Решение нужно в паскале?

Решение нужно в паскале.

Составьте программу вычисления суммы элементов двумерного массива A(N, N), расположенных под побочной диагональю.

Salvatore210 17 апр. 2020 г., 11:31:23 | 10 - 11 классы

Программирование C + + ?

Программирование C + + .

Дана целочисленная прямоугольная матрица.

Найти разность сумм элементов на главной и побочной диагоналях.

Gvovan007 14 окт. 2020 г., 08:11:59 | 10 - 11 классы

В двумерном массиве 7Х7 произвольных целых чисел вычислить сумму элементов, расположенных слева от побочной диагонали?

В двумерном массиве 7Х7 произвольных целых чисел вычислить сумму элементов, расположенных слева от побочной диагонали.

Определить минимальный элемент главной диагонали (значение и координаты).

Пatrick 27 февр. 2020 г., 12:13:59 | 10 - 11 классы

Определить сумму всех элементов массива, расположенных над главной диагональю?

Определить сумму всех элементов массива, расположенных над главной диагональю.

Chernjva 25 сент. 2020 г., 14:17:19 | 5 - 9 классы

Задан массив из семи элементов?

Задан массив из семи элементов.

Найти сумму максимального и минимального элементов и их индексы.

Если вам необходимо получить ответ на вопрос Дан массив размера n x n?, относящийся к уровню подготовки учащихся 10 - 11 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.