Написать программу, которая по введеным баллам за экзамен по инфлрматике, определяет какую оценку получил ученик : оценка 2 : 0 - 4 баллов, оценка 3 : 5 - 11 баллов, оценка 4 : 12 - 17 баллов, оценка ?

Информатика | 5 - 9 классы

Написать программу, которая по введеным баллам за экзамен по инфлрматике, определяет какую оценку получил ученик : оценка 2 : 0 - 4 баллов, оценка 3 : 5 - 11 баллов, оценка 4 : 12 - 17 баллов, оценка 5 : 18 - 22 баллов.

(Pascal).

Ответить на вопрос
Ответы (1)
Vasilij1 1 окт. 2020 г., 05:21:32

Var b : integer ;

begin

write('Введите количество баллов = ') ;

readln(b) ;

case b of

0.

4 : writeln('оценка 2') ;

5.

11 : writeln('оценка 3') ;

12.

17 : writeln('оценка 4') ;

18.

22 : writeln('оценка 5') ;

else writeln('ошибка ввода') ;

end ;

end.

Пример :

Введите количество баллов = 10

оценка 3.

Hgkugjkkl 29 февр. 2020 г., 22:34:17 | 10 - 11 классы

DamikbaltabarvJos?

DamikbaltabarvJos.

Помогите решить задачу на QbasikВ классе были проведены 2 контрольные работы .

Ученики получили соответствующие оценки .

Учитель решил их наказать и сказал что за четверть будет выставлена средняя арифметическая оценка с округлением в меньшую сторону.

Определить максимальную оценку за четверть и номер ученика получившего эту оценку.

Вы получите 20 баллов.

89030125117 11 июн. 2020 г., 20:29:55 | 10 - 11 классы

Написать программу тестирования(на javascript, чтобы в браузере открывался) : тест состоит из пяти вопросов?

Написать программу тестирования(на javascript, чтобы в браузере открывался) : тест состоит из пяти вопросов.

За каждый верный ответ начисляется один балл.

В итоге выставляется оценка от 2 до 5 по правилу : оценка равна 2, если верных ответов меньше 3 ; оценка равна числу верных ответов в противном случае.

GANJAMAN 22 окт. 2020 г., 16:51:26 | 5 - 9 классы

Ребята, помогите, очень нужно?

Ребята, помогите, очень нужно.

В классе 20 учеников писали контрольную работу по физике.

Оценки задаются как целые случайные числа в интервале от 2 до 5.

Напишите программу, которая подсчитывает средний балл за контрольную и определяет количество учеников, получивших балл ниже среднего.

Kolotucha 9 дек. 2020 г., 14:29:27 | 10 - 11 классы

Написать программу , для выставления оценок всего баллов до 25 - оценка 2 от 25 до 35 оценка 3 иначе 2 баллов от 36 до 46 оценка 4 иначе 3 баллов больше 47 оценка 5 Бейсик?

Написать программу , для выставления оценок всего баллов до 25 - оценка 2 от 25 до 35 оценка 3 иначе 2 баллов от 36 до 46 оценка 4 иначе 3 баллов больше 47 оценка 5 Бейсик.

Pavlyukova57 16 июн. 2020 г., 03:35:52 | 10 - 11 классы

При применении тестов оценка на экзамене выставляется в зависимости от суммы набранных баллов?

При применении тестов оценка на экзамене выставляется в зависимости от суммы набранных баллов.

Так, если эта сумма ≥80% от общего количества ответов, то выставляется оценка – «отлично» ; если сумма баллов ≥60%, но < ; 80%, то выставляется оценка – «хорошо» ; если сумма баллов ≥40%, но < ; 60%, то оценка - «удовлетворительно», если сумма, меньше 40%, то выставляется оценка - «неудовлетворительно».

Определить оценку на экзамене, если известна сумма набранных баллов за правильные ответы в процентном отношении.

Задача на Паскале.

Помогите пожалуйста!

Иринка5602665 6 июл. 2020 г., 00:27:10 | 5 - 9 классы

N учащихся получили оценки за контрольную работу?

N учащихся получили оценки за контрольную работу.

Ввести оценку каждого ученика, найти средний балл, кол - во неудовлетворительных оценок.

Спорт11 20 окт. 2020 г., 06:21:07 | 5 - 9 классы

Помогите?

Помогите!

Программирование циклических структур : 1.

Известны оценки по информатике каждого ученика в классе.

Определите средний балл.

NastyaBushueva 30 дек. 2020 г., 16:15:24 | 5 - 9 классы

В классе 35 человек?

В классе 35 человек.

Последовательно вводятся оценки учеников за контрольную работу.

Найдите средний балл и количество пятёрок.

PASCAL.

Анастасия22211 20 сент. 2020 г., 20:34:13 | 5 - 9 классы

В классе 35 человек?

В классе 35 человек.

Последовательно вводятся оценки учеников за контрольную работу.

Найдите средний балл и количество пятёрок.

PASCAL С помощью алгоритма for .

To . do.

Zarema654 18 дек. 2020 г., 19:20:50 | 5 - 9 классы

Пожалуйста с : Нужно составить программу среднего балла за экзамен по предмету для абитуриента?

Пожалуйста с : Нужно составить программу среднего балла за экзамен по предмету для абитуриента.

Использовать Паскаль, при этом учитывать, что существует 3 эксперта, которые ставят оценки по данному предмету.

Вы перешли к вопросу Написать программу, которая по введеным баллам за экзамен по инфлрматике, определяет какую оценку получил ученик : оценка 2 : 0 - 4 баллов, оценка 3 : 5 - 11 баллов, оценка 4 : 12 - 17 баллов, оценка ?. Он относится к категории Информатика, для 5 - 9 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.