Ребята, помогите, очень нужно?

Информатика | 5 - 9 классы

Ребята, помогите, очень нужно.

В классе 20 учеников писали контрольную работу по физике.

Оценки задаются как целые случайные числа в интервале от 2 до 5.

Напишите программу, которая подсчитывает средний балл за контрольную и определяет количество учеников, получивших балл ниже среднего.

Ответить на вопрос
Ответы (1)
Hhhjg 22 окт. 2020 г., 16:51:27

Const n = 20 ;

var x : array[1.

N] of integer ; i, k, s : integer ; c : real ;

begin Randomize ; Writeln('Полученные баллы') ; s : = 0 ; for i : = 1 to n do begin x[i] : = Random(4) + 2 ; Write(x[i] : 2) ; s : = s + x[i] ; end ; Writeln ; c : = s / n ; k : = 0 ; for i : = 1 to n do if x[i]< ; c then Inc(k) ; Writeln('Средний балл : ', c : 4 : 2, ', количество получивших баллы ниже него : ', k)

end.

Тестовое решение :

Полученные баллы

5 2 5 2 5 3 4 2 2 2 2 4 5 2 4 4 5 5 4 4

Средний балл : 3.

55, количество получивших баллы ниже него : 8.

Hgkugjkkl 29 февр. 2020 г., 22:34:17 | 10 - 11 классы

DamikbaltabarvJos?

DamikbaltabarvJos.

Помогите решить задачу на QbasikВ классе были проведены 2 контрольные работы .

Ученики получили соответствующие оценки .

Учитель решил их наказать и сказал что за четверть будет выставлена средняя арифметическая оценка с округлением в меньшую сторону.

Определить максимальную оценку за четверть и номер ученика получившего эту оценку.

Вы получите 20 баллов.

Slavyan2002 25 окт. 2020 г., 19:26:27 | 10 - 11 классы

Создайте массив случайным образом, содержащий оценки десяти учеников за выполнение трёх контрольных работ (по три оценки для каждого)?

Создайте массив случайным образом, содержащий оценки десяти учеников за выполнение трёх контрольных работ (по три оценки для каждого).

Выведите на экран средний балл каждого ученика.

Подсчитайте число учеников : * выполнивших первую работу на "5" * выполнивших хотя бы одну работу на "5" * выполнивших все работы на "5" * выполнивших вторую работу на "4" или "5" * не получивших ни одной оценки "5" * выполнивших первую работу на "3", вторую - на "4" и третью - на "5".

Narminwampir20 17 сент. 2020 г., 09:03:00 | 10 - 11 классы

НАЙТИ средний бал за контрольную работу если кол - во учеников выполнявших работу n?

НАЙТИ средний бал за контрольную работу если кол - во учеников выполнявших работу n.

Также найти колличество учеников которые получили оченку 4 или 5, а также оченку 2 составить программу в гамбас(не обязательно программу если можно просто решение объяните).

Иринка5602665 6 июл. 2020 г., 00:27:10 | 5 - 9 классы

N учащихся получили оценки за контрольную работу?

N учащихся получили оценки за контрольную работу.

Ввести оценку каждого ученика, найти средний балл, кол - во неудовлетворительных оценок.

Спорт11 20 окт. 2020 г., 06:21:07 | 5 - 9 классы

Помогите?

Помогите!

Программирование циклических структур : 1.

Известны оценки по информатике каждого ученика в классе.

Определите средний балл.

Даша850 1 окт. 2020 г., 05:21:30 | 5 - 9 классы

Написать программу, которая по введеным баллам за экзамен по инфлрматике, определяет какую оценку получил ученик : оценка 2 : 0 - 4 баллов, оценка 3 : 5 - 11 баллов, оценка 4 : 12 - 17 баллов, оценка ?

Написать программу, которая по введеным баллам за экзамен по инфлрматике, определяет какую оценку получил ученик : оценка 2 : 0 - 4 баллов, оценка 3 : 5 - 11 баллов, оценка 4 : 12 - 17 баллов, оценка 5 : 18 - 22 баллов.

(Pascal).

Lexa11111 11 авг. 2020 г., 23:08:48 | 10 - 11 классы

Дан целочисленный массив из 30 элементов, которые могут принимать значения от 0 до 100 – баллы, полученные на ЕГЭ?

Дан целочисленный массив из 30 элементов, которые могут принимать значения от 0 до 100 – баллы, полученные на ЕГЭ.

Напишите программу, которая подсчитывает и выводит средний балл учащихся, сдавших экзамен (получивших оценку более 20).

Числа вводятся рандомно (не с клавиатуры).

NastyaBushueva 30 дек. 2020 г., 16:15:24 | 5 - 9 классы

В классе 35 человек?

В классе 35 человек.

Последовательно вводятся оценки учеников за контрольную работу.

Найдите средний балл и количество пятёрок.

PASCAL.

Анастасия22211 20 сент. 2020 г., 20:34:13 | 5 - 9 классы

В классе 35 человек?

В классе 35 человек.

Последовательно вводятся оценки учеников за контрольную работу.

Найдите средний балл и количество пятёрок.

PASCAL С помощью алгоритма for .

To . do.

Тупишкаяяяя 19 сент. 2020 г., 22:47:58 | 10 - 11 классы

Помогите сделать блок - схему алгоритма решения задачи 1)Определить средний балл 4 слушателей по результатам контрольной работы?

Помогите сделать блок - схему алгоритма решения задачи 1)Определить средний балл 4 слушателей по результатам контрольной работы.

2) Если средний балл ≥ 3, то вывести сообщение "Контрольная работа написана удовлетворительно".

На этой странице сайта размещен вопрос Ребята, помогите, очень нужно? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 5 - 9 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.