N учащихся получили оценки за контрольную работу?

Информатика | 5 - 9 классы

N учащихся получили оценки за контрольную работу.

Ввести оценку каждого ученика, найти средний балл, кол - во неудовлетворительных оценок.

Ответить на вопрос
Ответы (1)
Платон2003 6 июл. 2020 г., 00:27:12

Var p : real ;

i, n, k, s : integer ;

begin

writeln('Введите количество учащихся') ;

readln(n) ;

k : = 0 ;

p : = 0 ; for i : = 1 to n do begin read(s) ; if s = 5 then k : = k + 1 ; p : = p + s ; end ;

write('Средний балл ', p / n, ' Количество отличных оценок ', k)

end.

Hgkugjkkl 29 февр. 2020 г., 22:34:17 | 10 - 11 классы

DamikbaltabarvJos?

DamikbaltabarvJos.

Помогите решить задачу на QbasikВ классе были проведены 2 контрольные работы .

Ученики получили соответствующие оценки .

Учитель решил их наказать и сказал что за четверть будет выставлена средняя арифметическая оценка с округлением в меньшую сторону.

Определить максимальную оценку за четверть и номер ученика получившего эту оценку.

Вы получите 20 баллов.

Slavyan2002 25 окт. 2020 г., 19:26:27 | 10 - 11 классы

Создайте массив случайным образом, содержащий оценки десяти учеников за выполнение трёх контрольных работ (по три оценки для каждого)?

Создайте массив случайным образом, содержащий оценки десяти учеников за выполнение трёх контрольных работ (по три оценки для каждого).

Выведите на экран средний балл каждого ученика.

Подсчитайте число учеников : * выполнивших первую работу на "5" * выполнивших хотя бы одну работу на "5" * выполнивших все работы на "5" * выполнивших вторую работу на "4" или "5" * не получивших ни одной оценки "5" * выполнивших первую работу на "3", вторую - на "4" и третью - на "5".

Zeys1975 31 янв. 2020 г., 13:21:52 | 5 - 9 классы

Известны оценки по физике каждого ученика двух классов?

Известны оценки по физике каждого ученика двух классов.

Определить среднюю оценку в каждом классе.

Кол - во учащихся в классе - не более 25.

Кетрин9528 31 июл. 2020 г., 07:37:48 | 5 - 9 классы

Напишите программу для решения следующей задачи?

Напишите программу для решения следующей задачи.

На контрольной работе по алгебре ученикам 9 класса было предложено 10 примеров.

Неудовлетворительная оценка выставляется, если правильно решено менее половины примеров.

Сколько неудовлетворительных оценок было получено учениками?

Если хотя бы один из учеников правильно решил все задачи, выведите YES, иначе выведите NO.

Программа получает на вход количество учеников в классе N (1 ≤ N ≤ 30), затем для каждого ученика вводится количество правильно решённых примеров.

(Pascal).

GANJAMAN 22 окт. 2020 г., 16:51:26 | 5 - 9 классы

Ребята, помогите, очень нужно?

Ребята, помогите, очень нужно.

В классе 20 учеников писали контрольную работу по физике.

Оценки задаются как целые случайные числа в интервале от 2 до 5.

Напишите программу, которая подсчитывает средний балл за контрольную и определяет количество учеников, получивших балл ниже среднего.

Eosha 2 дек. 2020 г., 14:36:57 | 5 - 9 классы

Требуется написать программу для выставления оценки учащемуся за четверть?

Требуется написать программу для выставления оценки учащемуся за четверть.

Оценка выставляется как среднее арифметическое из 10 полученных оценок.

Каждая оценка - случайное число из промежутка от 2 до 5.

Использовать массив из 10 целых чисел.

Mshemireva1980 17 июл. 2020 г., 16:34:35 | 5 - 9 классы

За решение задач студент получил четыре оценки?

За решение задач студент получил четыре оценки.

Составьте программу, которая определит среднее значение оценок.

Masha131 29 апр. 2020 г., 18:57:42 | 5 - 9 классы

Python Известны оценки по алгебре каждого ученика класса?

Python Известны оценки по алгебре каждого ученика класса.

Определить среднюю оценку.

NastyaBushueva 30 дек. 2020 г., 16:15:24 | 5 - 9 классы

В классе 35 человек?

В классе 35 человек.

Последовательно вводятся оценки учеников за контрольную работу.

Найдите средний балл и количество пятёрок.

PASCAL.

Анастасия22211 20 сент. 2020 г., 20:34:13 | 5 - 9 классы

В классе 35 человек?

В классе 35 человек.

Последовательно вводятся оценки учеников за контрольную работу.

Найдите средний балл и количество пятёрок.

PASCAL С помощью алгоритма for .

To . do.

На этой странице находится вопрос N учащихся получили оценки за контрольную работу?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 5 - 9 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.