В классе 35 человек?

Информатика | 5 - 9 классы

В классе 35 человек.

Последовательно вводятся оценки учеников за контрольную работу.

Найдите средний балл и количество пятёрок.

PASCAL.

Ответить на вопрос
Ответы (1)
Ewjfgeigfber 30 дек. 2020 г., 16:15:30

/ / PascalABC.

NET 3.

2, сборка 1346 от 25.

11. 2016 / / Внимание!

Если программа не работает, обновите её версию!

Begin var a : = ReadArrInteger(' - > ; ', 35) ; Writeln('Средний балл ', a.

Average : 4 : 2) ; Writeln('Количество пятерок - ', a.

Where(x - > ; x = 5).

Count)

end.

Пример - > ; 4 4 2 4 5 2 3 3 4 3 2 3 2 4 4 2 4 2 4 5 2 2 5 4 4 2 4 2 4 5 5 2 3 3 4

Средний балл 3.

34

Количество пятерок - 5.

Hgkugjkkl 29 февр. 2020 г., 22:34:17 | 10 - 11 классы

DamikbaltabarvJos?

DamikbaltabarvJos.

Помогите решить задачу на QbasikВ классе были проведены 2 контрольные работы .

Ученики получили соответствующие оценки .

Учитель решил их наказать и сказал что за четверть будет выставлена средняя арифметическая оценка с округлением в меньшую сторону.

Определить максимальную оценку за четверть и номер ученика получившего эту оценку.

Вы получите 20 баллов.

Slavyan2002 25 окт. 2020 г., 19:26:27 | 10 - 11 классы

Создайте массив случайным образом, содержащий оценки десяти учеников за выполнение трёх контрольных работ (по три оценки для каждого)?

Создайте массив случайным образом, содержащий оценки десяти учеников за выполнение трёх контрольных работ (по три оценки для каждого).

Выведите на экран средний балл каждого ученика.

Подсчитайте число учеников : * выполнивших первую работу на "5" * выполнивших хотя бы одну работу на "5" * выполнивших все работы на "5" * выполнивших вторую работу на "4" или "5" * не получивших ни одной оценки "5" * выполнивших первую работу на "3", вторую - на "4" и третью - на "5".

Кетрин9528 31 июл. 2020 г., 07:37:48 | 5 - 9 классы

Напишите программу для решения следующей задачи?

Напишите программу для решения следующей задачи.

На контрольной работе по алгебре ученикам 9 класса было предложено 10 примеров.

Неудовлетворительная оценка выставляется, если правильно решено менее половины примеров.

Сколько неудовлетворительных оценок было получено учениками?

Если хотя бы один из учеников правильно решил все задачи, выведите YES, иначе выведите NO.

Программа получает на вход количество учеников в классе N (1 ≤ N ≤ 30), затем для каждого ученика вводится количество правильно решённых примеров.

(Pascal).

GANJAMAN 22 окт. 2020 г., 16:51:26 | 5 - 9 классы

Ребята, помогите, очень нужно?

Ребята, помогите, очень нужно.

В классе 20 учеников писали контрольную работу по физике.

Оценки задаются как целые случайные числа в интервале от 2 до 5.

Напишите программу, которая подсчитывает средний балл за контрольную и определяет количество учеников, получивших балл ниже среднего.

Иринка5602665 6 июл. 2020 г., 00:27:10 | 5 - 9 классы

N учащихся получили оценки за контрольную работу?

N учащихся получили оценки за контрольную работу.

Ввести оценку каждого ученика, найти средний балл, кол - во неудовлетворительных оценок.

Спорт11 20 окт. 2020 г., 06:21:07 | 5 - 9 классы

Помогите?

Помогите!

Программирование циклических структур : 1.

Известны оценки по информатике каждого ученика в классе.

Определите средний балл.

Kristiakononov 23 мая 2020 г., 16:17:57 | 5 - 9 классы

Напишите программу для решения следующей задачи?

Напишите программу для решения следующей задачи.

На контрольной работе по алгебре ученикам 9 класса было предложено 10 примеров.

Неудовлетворительная оценка выставляется, если правильно решено менее половины примеров.

Сколько неудовлетворительных оценок было получено учениками?

Если хотя бы один из учеников правильно решил все задачи, выведите YES, иначе выведите NO.

Программа получает на вход количество учеников в классе N (1 ≤ N ≤ 30), затем для каждого ученика вводится количество правильно решённых примеров.

(Pascal) Входные данные 4 3 9 2 8 Выходные данные 2 NO.

Masha131 29 апр. 2020 г., 18:57:42 | 5 - 9 классы

Python Известны оценки по алгебре каждого ученика класса?

Python Известны оценки по алгебре каждого ученика класса.

Определить среднюю оценку.

Katenkaspb 7 дек. 2020 г., 13:23:54 | 5 - 9 классы

Из 30 учеников класса 15 человек написали контрольную работу на оценку 4, 10 школьников - на оценку 5, а остальные получили тройку?

Из 30 учеников класса 15 человек написали контрольную работу на оценку 4, 10 школьников - на оценку 5, а остальные получили тройку.

Постройте адекватную графическую модель отображения успеваемости класса.

Анастасия22211 20 сент. 2020 г., 20:34:13 | 5 - 9 классы

В классе 35 человек?

В классе 35 человек.

Последовательно вводятся оценки учеников за контрольную работу.

Найдите средний балл и количество пятёрок.

PASCAL С помощью алгоритма for .

To . do.

На этой странице сайта размещен вопрос В классе 35 человек? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 5 - 9 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.