Составьте программу нахождения количества делителей числа n (значение n вводится с клавиатуры)?

Информатика | 5 - 9 классы

Составьте программу нахождения количества делителей числа n (значение n вводится с клавиатуры).

Ответить на вопрос
Ответы (1)
Сабина131 19 февр. 2020 г., 22:50:38

Var n, i, k : integer ;

begin

write('n = ') ; readln(n) ;

k : = 2 ;

for i : = 2 to n div 2 do

if n mod i = 0 then k : = k + 1 ;

writeln('k = ', k) ;

end.

Пример :

n = 20

k = 6.

Димка200211 4 нояб. 2020 г., 02:42:40 | 5 - 9 классы

Составить программу нахождения значения выражения : у = х2 + 8х, если значение х вводится с клавиатуры?

Составить программу нахождения значения выражения : у = х2 + 8х, если значение х вводится с клавиатуры.

Anna48russ2 5 авг. 2020 г., 03:11:26 | 5 - 9 классы

Вычислить сумму натуральных чисел от 1 до N ?

Вычислить сумму натуральных чисел от 1 до N .

Составить программу нахождения кол - ва делителей числа N ( значение N вводится с клавиатуры ).

Valera1316 28 янв. 2020 г., 05:59:53 | 5 - 9 классы

Составьте программу нахождения количество слов в предложении?

Составьте программу нахождения количество слов в предложении.

Предложение состоит из слов, отделёный друг от друга одним пробелом, вводится с клавиатуры.

Icycat1 5 авг. 2020 г., 13:55:18 | 5 - 9 классы

Написать программу поскаля, нахождение площади квадрата, значение сторон вводить с клавиатуры Помогите?

Написать программу поскаля, нахождение площади квадрата, значение сторон вводить с клавиатуры Помогите.

Tatar4eg 14 дек. 2020 г., 08:09:30 | 10 - 11 классы

Составьте программу нахождения значения выражения (a - (d + 21) * 2) * (c - 7 * k), где значения переменных а, d, с, и k вводятся с клавиатуры?

Составьте программу нахождения значения выражения (a - (d + 21) * 2) * (c - 7 * k), где значения переменных а, d, с, и k вводятся с клавиатуры.

Tihij 13 сент. 2020 г., 21:46:02 | 5 - 9 классы

Составить программу нахождения ширины прямоугольника, если площадь и длина вводятся с клавиатуры?

Составить программу нахождения ширины прямоугольника, если площадь и длина вводятся с клавиатуры.

Natali20103 25 авг. 2020 г., 11:35:43 | 5 - 9 классы

Составьте программу для ввода с клавиатуры 10 чисел и вывода количества нулей среди них?

Составьте программу для ввода с клавиатуры 10 чисел и вывода количества нулей среди них.

Danil104 16 окт. 2020 г., 21:39:55 | 1 - 4 классы

1. Составить программу нахождения скорости пешехода, если расстояние и время прохождения вводятся с клавиатуры?

1. Составить программу нахождения скорости пешехода, если расстояние и время прохождения вводятся с клавиатуры.

2. Составить программу нахождения значения выражения : у = х2 + 8х, если значение х вводится с клавиатуры.

3. Составить программу нахождения значения выражения : к = 2х3 - 5х2 + х - 6, если значение х вводится с клавиатуры.

4. Составить программу нахождения ширины прямоугольника, если площадь и длина вводятся с клавиатуры.

5. Составить программу нахождения основания равнобедренного треугольника, если боковая сторона и периметр вводятся с клавиатуры.

6. Составить программу нахождения боковой стороны равнобедренного треугольника, если основание и периметр вводятся с клавиатуры.

7. Составить программу нахождения средней численности учащихся в трех классах, если количество учеников в каждом классе вводится с клавиатуры.

8. Составить программу нахождения суммы и разности двух чисел вводимых с клавиатуры.

9. Составить программу нахождения произведения и частного двух чисел вводимых с клавиатуры.

Алиде 13 дек. 2020 г., 00:06:39 | 5 - 9 классы

Составьте программу нахождения количества делителей числа n (значение n вводится с клавиатуры)?

Составьте программу нахождения количества делителей числа n (значение n вводится с клавиатуры).

Влад1233 19 нояб. 2020 г., 01:00:42 | 5 - 9 классы

С клавиатуры вводится целоя пятизначное число?

С клавиатуры вводится целоя пятизначное число.

Написать программу нахождения суммы 1 - ой и последней цифры.

Если вам необходимо получить ответ на вопрос Составьте программу нахождения количества делителей числа n (значение n вводится с клавиатуры)?, относящийся к уровню подготовки учащихся 5 - 9 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.