4 а) составьте программу , которая заполняет массив а[1?

Информатика | 5 - 9 классы

4 а) составьте программу , которая заполняет массив а[1.

10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами удваиваются , а элементы с нечетными индексами утраивает.

Выведите на экран исходный и полученный массив.

Б)составьте программу , которая заполняет массив b[1.

8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .

Выведите на экран исходный и полученный массивы.

5) а)составьте программу , которая заполняет массив а[1.

10 ] случайными целыми числами в диапозоне от 1 до 10 , и находит количество элементов , которые больше своего соседа слева б)составьте программу , которая заполняет массив b[1.

8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.

6) а)составьте программу , которая заполняет массив а[1.

20 ] случайными целыми числами в диапозоне от 1 до 10 , и находит среднее арифметическое элементов с четными значениями и нечетными индексами.

Б) составьте программу , которая заполняет массив b[1.

15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.

Ответить на вопрос
Ответы (1)
Svetazuli 15 февр. 2020 г., 00:37:16

Program pr_a ;

var a : array[1.

10] of integer ;

i, x, y : integer ;

begin

x : = 0 ;

y : = 0 ;

for i : = 1 to 10 do

begin

a[i] : = random(11) ;

write(a[i], ' ') ;

writeln ;

end ;

for i : = 1 to 10 do

begin

if a[i] mod 2 = 0 then

x : = a[i] * 2

else

y : = a[i] * 3 ;

write(y, ' ') ;

write(x, ' ') ;

end ;

end.

А дальше мне лень : ).

Zhekagutarev 10 июл. 2020 г., 18:59:19 | 5 - 9 классы

Составте программу, которая заполняет массив b [1?

Составте программу, которая заполняет массив b [1.

8] случайными целыми числами в диапазоне от 1 до 10, а затем изменяет знак элементов с четными индексами на противоположный.

Выведите на экран исходный и полученный массивы.

Nicolay1996 26 мар. 2020 г., 21:44:12 | 5 - 9 классы

Составьте программу, которая заполняет массив а[1?

Составьте программу, которая заполняет массив а[1.

10] случайными целыми числами в диапозоне от 1 до 10, затем меняет местами первый элемент со вторым, третий с четвертым и тд.

Выведите на экран исходный и полученный массивы.

Нафангор 28 янв. 2020 г., 13:57:48 | 5 - 9 классы

Составьте программу, которая заполняет массив a [1?

Составьте программу, которая заполняет массив a [1.

10] случайными целыми числами в диапозоне от 1 до 10, затем меняет местами первый и последний элементы.

Выведите на экран исходный и полученный массивы.

Nina1234567 4 мая 2020 г., 21:31:44 | 5 - 9 классы

Составьте программу, которая заполняет массив а[1?

Составьте программу, которая заполняет массив а[1.

10] случайными целыми числами в диапазоне от 1 до 10, затем элементы с четными индексами удваивает, а элементы с нечетными индексами утраивает.

Выведите на экран исходный и полученный массивы.

Jabaagmerzaev5 26 янв. 2020 г., 12:04:20 | 5 - 9 классы

Составьте программу, которая заполняет массив a [1?

Составьте программу, которая заполняет массив a [1.

10] случайными целыми числами в диапазоне от 1 до 10 а затем элементы с чётными индексами удваивает, а элементы с нечетны

ми индексами утраивает.

Выведите на экран исходный и полученный массивы.

Vniekoz 20 февр. 2020 г., 04:07:44 | 5 - 9 классы

1) составьте программу , которая заполняет массив а [1?

1) составьте программу , которая заполняет массив а [1.

10] случайными целыми числами в диапозоне от 1 до 10 , затем меняет местами первый элемент со вторым, третий с четвертым и т.

Д. Выведите на экран исходный и полученный массивы.

2)составьте программу , которая заполняет массив а[1.

10] случайными целыми числами в диапозоне от 0 до 10 , затем превый элемент меняет местами с максимальным элементом .

Выведите на экран исходный и полученный массив.

Полина2045 4 сент. 2020 г., 15:02:31 | 5 - 9 классы

Составте программу которая заполняет массив а 1?

Составте программу которая заполняет массив а 1.

10 случайными целыми числами в диапазоне от 0 до 10 и находит максимальный элемент массива среди элементов с четными индексами.

Anya8a 7 авг. 2020 г., 02:55:25 | 10 - 11 классы

Решите задачи : 1) Составьте программу ввода элементов массива [1?

Решите задачи : 1) Составьте программу ввода элементов массива [1.

8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями.

2) Составьте программу, которая заполняет массив а [1.

10] случайными целыми числами в диапазоне от 1 до 10 и находит количество элементов с четными значениями.

3) Составьте программу, которая заполняет массив а [1.

10] случайными целыми числами в диапазоне от 1 до 10 и находит сумму элементов с четными значениями и количество элементов с нечетными значениями.

4) Составьте программу, которая заполняет массив а [1.

10] случайными целыми числами в диапазоне от 1 до 10, затем элементы с четными индексами удваивает, а элементы с нечетными индексами утраивает.

Выведите на экран исходный и полученный массивы.

Alena180719 27 дек. 2020 г., 10:02:42 | 5 - 9 классы

Составьте программу которая заполняет массив a [1?

Составьте программу которая заполняет массив a [1.

10] случайными целыми числами в диапозоне от 1 до 10, затем преобразовывает его увеличивая все элементы с нечетными значениями в три раза, а элементы с четными значениями заменяя на 0.

PASCAL ABC.

Sveta8508 10 нояб. 2020 г., 04:17:47 | 5 - 9 классы

Составьте программу, которая заполняет массив a[1?

Составьте программу, которая заполняет массив a[1.

8] случайными целыми числами в диапозоне от 1 до 10 и выводит на экран количество элементов с чётными значениями и сумму элементов массива с нечётными значениями(составьте программу пожалуйста).

На этой странице сайта размещен вопрос 4 а) составьте программу , которая заполняет массив а[1? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 5 - 9 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.