В Паскале с помощью repeat?

Информатика | 10 - 11 классы

В Паскале с помощью repeat.

Составьте программу, которая выводит на экран сумму нечетных чисел от 36 до 66.

Ответить на вопрос
Ответы (1)
Саша1063265 19 дек. 2020 г., 05:41:14

Begin Writeln(((65 + 37) * ((65 - 37) div 2 + 1)) div 2) ;

end.

Или более универсально :

Var A, B : Integer ;

Begin Readln(A, B) ; Inc(A, Ord(not Odd(A))) ; Dec(B, Ord(not Odd(B))) ; Writeln(((B + A) * ((B - A) div 2 + 1)) div 2) ;

end.

А если строго по заданию, то так :

Var S, i : Integer ;

Begin s : = 0 ; i : = 37 ; Repeat s : = s + i ; Inc(i, 2) ; Until i> ; 65 ; Writeln(s) ;

end.

Cat146 11 дек. 2020 г., 10:07:58 | 5 - 9 классы

1)Составить программу(паскаль) вывода на экран всех нечетных двухзначных чисел?

1)Составить программу(паскаль) вывода на экран всех нечетных двухзначных чисел.

2)составить программу вычисления суммы всех трехзначных чисел, кратных 5.

Лововтшоцшпруща 8 нояб. 2020 г., 11:52:22 | 10 - 11 классы

Составьте программу, которая выводит на экран сумму чисел кратных 8 - ми от 50 до 600?

Составьте программу, которая выводит на экран сумму чисел кратных 8 - ми от 50 до 600.

Lollal1 16 февр. 2020 г., 13:00:11 | 10 - 11 классы

Напишите пожалуйста программу на pascal?

Напишите пожалуйста программу на pascal.

Составьте программу, которая выводит на экран сумму чисел кратных 5 - и от 30 до 60.

Цикл repeat.

Sabrinakotsk1 27 сент. 2020 г., 00:02:27 | 5 - 9 классы

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC?

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC.

Составить программу, которая выводит на экран сумму нечетных чисел от 1 до 30 в Pascal ABC.

TaeSica 28 сент. 2020 г., 11:41:50 | 5 - 9 классы

Составьте программу, которая выводит на экран нечетные числа в диапазоне от 20 до 50?

Составьте программу, которая выводит на экран нечетные числа в диапазоне от 20 до 50.

Молдовашка5432 21 авг. 2020 г., 09:13:01 | 10 - 11 классы

Напишите программу паскаль (с использованием оператора repeat), которая выводит на экран цифры в обратном порядке – от 9 до 0?

Напишите программу паскаль (с использованием оператора repeat), которая выводит на экран цифры в обратном порядке – от 9 до 0.

Zhdanov1805 17 июл. 2020 г., 09:48:40 | 5 - 9 классы

Составьте программу, которая вычисляет сумму натуральных чисел от 10 до 15 и выводит на экран результат?

Составьте программу, которая вычисляет сумму натуральных чисел от 10 до 15 и выводит на экран результат.

99Денис 15 сент. 2020 г., 16:03:54 | 5 - 9 классы

Составьте программу которая выводит на экран все двузначные числа сумма цифр которых четнаяв Паскаль абс?

Составьте программу которая выводит на экран все двузначные числа сумма цифр которых четная

в Паскаль абс.

Dariakonstantinowa 12 дек. 2020 г., 02:56:06 | 5 - 9 классы

Составьте программу вывода на экран "столбиком" четырех любых чисел?

Составьте программу вывода на экран "столбиком" четырех любых чисел.

Через Паскаль.

Лиза70 17 сент. 2020 г., 19:32:27 | 10 - 11 классы

ПАСКАЛЬ ?

ПАСКАЛЬ .

Составьте программу, которая выводит на экран все двузначные числа сумма цифр которых делится на 3 и 4.

Вы открыли страницу вопроса В Паскале с помощью repeat?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 10 - 11 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.