Дано трехзначное число?

Информатика | 5 - 9 классы

Дано трехзначное число.

Получить 6 различных чисел, образованных перестановкой цифр заданного числа.

ЗАПИСАТЬ ПРОГРАММУ НА ЯЗЫКЕ ПАСКАЛЬ.

Ответить на вопрос
Ответы (1)
Lizaselukova 8 мар. 2020 г., 16:33:41

Var n, n1, n2, n3 : integer ;

function srostit(a, b, c : integer) : integer ;

begin srostit : = a * 100 + b * 10 + c ;

end ;

Begin read(n) ; n1 : = n div 100 ; n2 : = n mod 100 div 10 ; n3 : = n mod 10 ; writeln(srostit(n1, n2, n3)) ; writeln(srostit(n1, n3, n2)) ; writeln(srostit(n2, n1, n3)) ; writeln(srostit(n2, n3, n1)) ; writeln(srostit(n3, n1, n2)) ; writeln(srostit(n3, n2, n1)) ;

End.

Irkavoloxovich 14 нояб. 2020 г., 02:01:30 | 10 - 11 классы

Дано двузначное число?

Дано двузначное число.

Получить число, образованное при перестановки цифр заданного числа.

Myrick 10 авг. 2020 г., 07:02:32 | 5 - 9 классы

Дано трехзначное число?

Дано трехзначное число.

Найти сумму цифр числа.

(Написать программу на языке Паскаль).

KirillBrownG 15 нояб. 2020 г., 03:48:20 | 5 - 9 классы

Задача по программированию 8 класс?

Задача по программированию 8 класс.

Решите как положено через паскаль!

Дано трехзначное число.

Найти число, полученное при перестановке первой и второй цифр заданного числа.

Unicorn12 17 июн. 2020 г., 15:51:25 | 5 - 9 классы

Запишите на языке Паскаль программу, которая для произвольного двузначного числа определяет : а) сумму и произведение его цифр ; б) число, образованное перестановкой цифр исходного числа?

Запишите на языке Паскаль программу, которая для произвольного двузначного числа определяет : а) сумму и произведение его цифр ; б) число, образованное перестановкой цифр исходного числа.

Natakorn 24 янв. 2020 г., 01:19:20 | 10 - 11 классы

Задача, состав те программу в паскале?

Задача, состав те программу в паскале!

1)Дано трехзначное число.

Определить количество всех различных трехзначных чисел, которые можно составить из цифр этого числа.

2) Даны три числа.

Подсчитать количество четных чисел .

Заранее спасибо !

Kilmetova72 17 сент. 2020 г., 02:04:14 | 5 - 9 классы

Домашнее задание :1?

Домашнее задание :

1.

Запишите на языке Паскаль программу, которая для произвольного двузначного числа определяет сумму и произведение его цифр.

2. Запишите на языке Паскаль программу, которая для произвольного двузначного числа определяет число, образованное перестановкой цифр исходного числа.

3. Запишите на языке Паскаль программу, которая для произвольного трехзначного числа определяет сумму его цифр.

Prisakargalina 5 июн. 2020 г., 01:13:11 | 10 - 11 классы

Паскаль?

Паскаль.

1) Дано трехзначное число, нужно найти число, полученное при прочтении его цифр справа налево.

2) Дано трехзначное число.

В нем зачеркнули последнюю справа цифру и приписали ее в начале.

Найти полученное число.

3) Дано трехзначное число.

Найти число, полученное при перестановке первой и второй цифр заданного числа.

Persianovandrey 15 окт. 2020 г., 07:39:07 | 5 - 9 классы

Задано трехзначное число, написать программу на языке Паскаль, которая находит сумму его цифр и проверить четное оно или нет?

Задано трехзначное число, написать программу на языке Паскаль, которая находит сумму его цифр и проверить четное оно или нет.

Viktorova2303 1 мая 2020 г., 07:41:21 | 5 - 9 классы

Запишите на языке Паскаль программу, которая для произвольного натурального двузначного числа определяет : 1) сумму и произведение его цифр ; 2) число, образованное перестановкой цифр исходного числа?

Запишите на языке Паскаль программу, которая для произвольного натурального двузначного числа определяет : 1) сумму и произведение его цифр ; 2) число, образованное перестановкой цифр исходного числа.

Alinplwww16 16 сент. 2020 г., 17:12:24 | 5 - 9 классы

Дано трехзначное число?

Дано трехзначное число.

Найти число, полученное при перестановке первой и последней

цифр заданного числа.

Pascal.

На этой странице находится вопрос Дано трехзначное число?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 5 - 9 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.