Вывести все 3хзначные числа, квадрат которого заканчивается этим же числом (например : 376 ^ 2 = 141376)?

Информатика | 5 - 9 классы

Вывести все 3хзначные числа, квадрат которого заканчивается этим же числом (например : 376 ^ 2 = 141376).

Ответить на вопрос
Ответы (1)
Белка123456789876 24 авг. 2020 г., 20:56:32

Pascal (гдето так.

)

program treska ;

var a, i, k, b, b2, b3 : integer ;

begin

for i : = 100 to 999 do

begin

a : = sqr(i) ;

k : = a - i ;

b : = a - k ;

if i = b then write (i, ' ') ;

end ;

readln

end.

Boris4344 10 апр. 2020 г., 20:46:05 | 10 - 11 классы

Дано натуральное число А?

Дано натуральное число А.

Вывести число, полученное из А путем прочтения его цифр справа налево.

Например, 12345 - > ; 54321.

Donia1974 27 февр. 2020 г., 13:05:56 | 5 - 9 классы

1. Квадрат трехзначного числа оканчивается тремя цифрами, которые как раз и составляют это число?

1. Квадрат трехзначного числа оканчивается тремя цифрами, которые как раз и составляют это число.

Найти такие числа (например, 625 : 625 ^ 2 = 390 625).

2. Найти сумму целых положительных чисел, больших 20, меньших 100, кратных 3 и заканчивающихся на 2, 4 или 8.

Решить в Паскале.

Ilyaerecha 30 июн. 2020 г., 01:14:38 | 5 - 9 классы

Вывести на экран все двузначные числа которые заканчиваются на 1 (паскаль) Срочно?

Вывести на экран все двузначные числа которые заканчиваются на 1 (паскаль) Срочно!

Otlichnayk 26 мая 2020 г., 10:12:34 | 5 - 9 классы

С клавиатуры вводится натуральное число n выясните является ли оно квадратом какого то натурального числа если является то выведите это число если нет то вывести - 1 например 4 является квадратом 2 а ?

С клавиатуры вводится натуральное число n выясните является ли оно квадратом какого то натурального числа если является то выведите это число если нет то вывести - 1 например 4 является квадратом 2 а 17 не является квадратом никакого числа.

Matvey1070 11 февр. 2020 г., 04:59:40 | 10 - 11 классы

С клавиатуры вводятся 2 числа?

С клавиатуры вводятся 2 числа.

Если хотя бы одно из этих чисел является трёхзначным и кратным 3, вывести слово YES, иначе возвести первое число в квадрат, а из второго извлеч корень, вывести эти числа на экран.

Гулден99 14 окт. 2020 г., 02:04:08 | 10 - 11 классы

1 Определить, является ли число автоморфным, то есть квадрат этого числа заканчивается этим же числом, например, числа 6 и 25, т?

1 Определить, является ли число автоморфным, то есть квадрат этого числа заканчивается этим же числом, например, числа 6 и 25, т.

К. их квадратами являются числа 36 и 625.

2 Составьте программу, проверяющую, является ли число палиндромом (например, число 12421 - палиндром).

3 Среди чисел из интервала от А до В найти все простые.

Alkiso 14 авг. 2020 г., 02:22:22 | 10 - 11 классы

ПОМОГИТЕ ПОЖАЛУЙСТА?

ПОМОГИТЕ ПОЖАЛУЙСТА!

Напишите программу, которая вводит трёхзначное число и разбивает его на цифры.

Например, при вводе числа 123 программа должна вывести"1, 2, 3".

Kusena 17 апр. 2020 г., 05:15:06 | 10 - 11 классы

Паскаль?

Паскаль.

Вывести на экран квадрат средней цифры пятизначного числа.

Drakosha2013 3 дек. 2020 г., 10:52:42 | 5 - 9 классы

Помогите, прошу?

Помогите, прошу!

Программирование на языке Pascal, используя Case Ввести число ( от 1 до 4) если число = 1 то вывести окружность, если - 2, то вывести квадрат, если - 3, вывести ромб, если - 4, вывести параллелограмм.

Mikana8376372 12 дек. 2020 г., 22:02:30 | 5 - 9 классы

Вывести на экран все числа от 10 до 2030 которые заканчиваются на 11?

Вывести на экран все числа от 10 до 2030 которые заканчиваются на 11.

Паскаль.

Вы зашли на страницу вопроса Вывести все 3хзначные числа, квадрат которого заканчивается этим же числом (например : 376 ^ 2 = 141376)?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 5 - 9 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.