Создать файл содержащий структуру записи человек : пол, имя, рост?

Информатика | 10 - 11 классы

Создать файл содержащий структуру записи человек : пол, имя, рост.

Вывести на экран средний женский рост и имя самого высокого мужчины.

Ответить на вопрос
Ответы (1)
24423003 4 июл. 2020 г., 18:05:49

Const gend = ['м', 'ж'] ;

type tMan = record gender : char ; fio : string ; height : integer end ;

var man : tMan ; max1, max2 : integer ; mfio : string ; f : file ;

begin { Заполнение файла } Assign(f, 'manfile.

Txt') ; Rewrite(f) ; Writeln('Введите через Enter пол (м / ж), фамилию и рост в см') ; Writeln('Для отказа введите 0') ; repeat Readln(man.

Gender) ; if man.

Gender in gend then begin Readln(man.

Fio) ; Readln(man.

Height) ; Write(f, man) ; Writeln('Данные приняты, продолжайте') end until not (man.

Gender in gend) ; Close(f) ; { Работа с файлом } Assign(f, 'manfile.

Txt') ; Reset(f) ; max1 : = 0 ; max2 : = 0 ; while not Eof(f) do begin Read(f, man) ; with man do if (gender = 'м') and (max1 < ; height) then begin max1 : = height ; mfio : = fio end else if (gender = 'ж') and (max2 < ; height) then max2 : = height ; end ; Writeln('Самый высокий - ', mfio, ', рост самой высокой равен ', max2) ; Close(f) ;

end.

Тестовое решение :

Введите через Enter пол (м / ж), фамилию и рост в см

Для отказа введите 0

м

Иванов И.

И. 176

Данные приняты, продолжайте

ж

Егорова К.

С. 169

Данные приняты, продолжайте

ж

Старова Г.

К. 168

Данные приняты, продолжайте

м

Минкин Р.

Т. 179

Данные приняты, продолжайте

0

Самый высокий - Минкин Р.

Т. , рост самой высокой равен 169.

Ange3000 21 окт. 2020 г., 04:10:46 | 5 - 9 классы

Какие символы не может содержать имя файла?

Какие символы не может содержать имя файла.

Leokat61 30 апр. 2020 г., 08:50:41 | 10 - 11 классы

Дан текстовый файл?

Дан текстовый файл.

Вывести на экран самую длинную строку из файла.

Через паскале.

Erlan19061971 15 февр. 2020 г., 14:41:45 | 10 - 11 классы

Создайте файл состоящий из записей содержащих поля : 1) номер 2) фамилия 3) телефон?

Создайте файл состоящий из записей содержащих поля : 1) номер 2) фамилия 3) телефон.

Организуйте вывод на экран монитора номера телефона по введённой с клавиатуры фамилии.

Нужно сделать через указатели, помогите пожалуйста.

050529 7 сент. 2020 г., 13:36:38 | 5 - 9 классы

В некотором каталоге хранился файл Задача5?

В некотором каталоге хранился файл Задача5.

После того как в этом каталоге создали подкаталог и переместили в созданный подкаталог файл Задача5, полное имя файла стало Е : \ Класс8 \ Физика \ Задачник \ Задача5.

Каково было полное имя этого файла до перемещения ?

Simlich 11 янв. 2020 г., 12:56:45 | 5 - 9 классы

С клавиатуры вводится три строки вида Фамилия пробел Имя пробел Рост?

С клавиатуры вводится три строки вида Фамилия пробел Имя пробел Рост.

Определить фамилию и имя самого высокого человека d pascal abc.

Kamolkaroboev 7 мар. 2020 г., 23:59:39 | 5 - 9 классы

Класс сформировать массив роста учеников класса в метрах Затем на его основе сформирован второй массив роста учеников класса в сантиметрах и вывести оба на экран?

Класс сформировать массив роста учеников класса в метрах Затем на его основе сформирован второй массив роста учеников класса в сантиметрах и вывести оба на экран.

Kanev98 13 авг. 2020 г., 08:24:53 | 10 - 11 классы

Написать программу сортировки имен и фамилий С + + то есть : программа должна открыть файл, считать из него фамилии, сортировать по алфавиту , занести результат на экран и в новый созданный файл?

Написать программу сортировки имен и фамилий С + + то есть : программа должна открыть файл, считать из него фамилии, сортировать по алфавиту , занести результат на экран и в новый созданный файл.

Sevdabelieber 18 июл. 2020 г., 13:58:10 | 10 - 11 классы

Ввести рост человека?

Ввести рост человека.

Вывести на экран "высокий", если его рост превышает, 180 см и "не очень высокий" в противном случае.

Phil0t 30 окт. 2020 г., 19:45:13 | 5 - 9 классы

Напишите на языке C + + ?

Напишите на языке C + + !

1) Ввести число.

Если оно неотрицательно (больше 0), вычесть из него 10, иначе – прибавить к нему 10 2) Ввести 2 числа.

Если их произведение отрицательно, умножить его на - 2 и вывести на экран, иначе – увеличить его в 3 раза и вывести на экран 3) Ввести два числа.

Вычесть из большего меньшее 4) Ввести рост человека.

Вывести на экран “высокий”, если его рост превышает 180 см, “нормальный” и “низкий”.

Perizat1784 11 нояб. 2020 г., 03:06:10 | 5 - 9 классы

1) Ввести число?

1) Ввести число.

Если оно неотрицательно (больше 0), вычесть из него 10, иначе – прибавить к нему 10 2) Ввести 2 числа.

Если их произведение отрицательно, умножить его на - 2 и вывести на экран, иначе – увеличить его в 3 раза и вывести на экран 3) Ввести два числа.

Вычесть из большего меньшее 4) Ввести рост человека.

Вывести на экран “высокий”, если его рост превышает 180 см, “нормальный” и “низкий”.

На этой странице находится вопрос Создать файл содержащий структуру записи человек : пол, имя, рост?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 10 - 11 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.