Дан текстовый файл?

Информатика | 10 - 11 классы

Дан текстовый файл.

Вывести на экран самую длинную строку из файла.

Через паскале.

Ответить на вопрос
Ответы (1)
Nancy1202 30 апр. 2020 г., 08:50:45

Var

f : text ; s : string ; max : string : = '' ;

begin / / в папке с программой должен быть файл "input.

Txt"

if FileExists('input.

Txt') then begin Assign(f, 'input.

Txt') ; Reset(f) ; while not Eof(f) do begin Readln(f, s) ; if Length(s) > ; Length(max) then max : = s ; end ; Writeln('Самая длинная строка в файле : ') ; Writeln(max) ; Close(f) ; end else Writeln('Файл не найден') ;

end.

Den9898 18 апр. 2020 г., 15:54:24 | 10 - 11 классы

Дан текстовый файл содержащий вещественные числа по одному в каждой строке?

Дан текстовый файл содержащий вещественные числа по одному в каждой строке.

Поместить эти числа в другой файл по 6 в строку перед десятичной точкой оставить 5 знаков после точки 8 знаков.

Т - паскаль.

Jennifer121 22 мая 2020 г., 14:36:43 | 10 - 11 классы

Определить количество строк в текстовом файле, в которых есть символ «?

Определить количество строк в текстовом файле, в которых есть символ «!

». напишите плз код на Паскале.

= 3.

21nikkorol95 5 апр. 2020 г., 12:44:01 | 10 - 11 классы

С помощью Паскаля найти самую короткую строку в файле и вывести её на экран?

С помощью Паскаля найти самую короткую строку в файле и вывести её на экран.

Если таких строк несколько, то последнюю из них.

Tatgiljova 28 окт. 2020 г., 15:51:09 | 10 - 11 классы

Создайте текстовый файл?

Создайте текстовый файл.

Определите, сколько строк файла имеют длину большую, равную и меньшую, чем заданное значение k.

Alexey1776 17 апр. 2020 г., 12:14:00 | 10 - 11 классы

Помогите пожалуйста, срочно?

Помогите пожалуйста, срочно!

Написать программу в Турбо Паскале.

Задание : Дан текстовый файл f.

Исключить гласные буквы из строк и поместить результат в файл q.

Julis1 4 янв. 2020 г., 16:00:42 | 10 - 11 классы

Написать программу, которая запишет в текстовый файл 6 разных строк?

Написать программу, которая запишет в текстовый файл 6 разных строк.

Строки вводятся с клавиатуры.

Паскаль.

Camal111 4 мая 2020 г., 15:15:19 | 5 - 9 классы

Дан текстовый файл?

Дан текстовый файл.

Подсчитать количество символов в каждой строке.

Kukoviski 12 июл. 2020 г., 04:09:47 | 10 - 11 классы

Дан текстовый файл?

Дан текстовый файл.

Напечатать в алфавитном порядке все слова из данного файла, имеющие заданную длину n.

Паскаль.

Nadezdasang 26 янв. 2020 г., 13:43:07 | 10 - 11 классы

Помогите решить кто знает паскаль Вот задача Дан файл с оценками ?

Помогите решить кто знает паскаль Вот задача Дан файл с оценками .

Txt учащихся Написать программу которая определяет количество пятерок, четвёрок, троек.

Вывести их количество на экран.

Нужно написать в текстовом документе а с помощью Паскаля это прочитать Пожалуйста!

Maksimko15 1 июн. 2020 г., 15:00:44 | 10 - 11 классы

С клавиатуры вводится строка?

С клавиатуры вводится строка.

Найти и вывести на экран её длину.

Паскаль.

На этой странице сайта вы найдете ответы на вопрос Дан текстовый файл?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 10 - 11 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.