СРОЧНО?

Информатика | 5 - 9 классы

СРОЧНО!

Решить задачу на Паскале на компьютере : Найти сумму нечетных положительных чисел из N введенных чисел.

ЗАРАНЕЕ СПАСИБО!

(через for) program z1 ; var i, a : real ; s, n : integer ; writeln('введите кол - во чисел') ; readln(n) ; s : = 0 ; for i : = 1 to n do begin ; readln(a) ; if a mod 2 < ; > ; 0 and a> ; 0 then begin s : = s + a end ; end ; writeln (s) ; end.

Начала решать, не получается(((.

Ответить на вопрос
Ответы (1)
Маринаиникита 24 мар. 2020 г., 22:59:10

Var a, s, mn : real ; n, i : integer ;

begin

clrscr ;

repeat

write('Сколько чисел ввести n> ; 0 n = ') ;

readln(n) ;

until n> ; 0 ;

writeln('Введите ', n, ' чисел : ') ;

s : = 0 ;

for i : = 1 to n do

begin write('a = ') ; readln(a) ; if i = 1 then mn : = a else if odd(i)and(a< ; mn) then mn : = a ; if(i mod 2 = 0)and(a> ; 0) then s : = s + a ;

end ;

writeln('Сумма положительных с четными индексами = ', s : 0 : 2) ;

writeln('Минимальный с нечетным индексом = ', mn : 0 : 2) ;

readln

end.

Valeriykot2016 8 мая 2020 г., 23:26:20 | 5 - 9 классы

Что делать?

Что делать?

Program n1 ; Type Test = class Private Var a : integer : = 10 ; Public Var b : integer : = 15 ; End ; Begin Var cl : Test : = new Test() ; Writeln(cl.

A) ; / / должно не выполняться но паскалю пофиг Writeln(cl.

B) / / выпонится End.

MikaEpt 27 апр. 2020 г., 10:34:15 | 5 - 9 классы

ЧТО НЕ ПРАВИЛЬНО?

ЧТО НЕ ПРАВИЛЬНО?

Program p_1 ;

var x, y : real ;

begin

read(x) ;

if 0< ; x< ; 2 then begin y : = sqr(cos(x)) ;

else begin y : = 1 - sin(sqr(x)) ;

end ;

writeln(y) ;

end.

Учени10101010101010 15 дек. 2020 г., 09:59:59 | 5 - 9 классы

Прошу вас, помогите?

Прошу вас, помогите!

Решается оценка!

Найдите ошибки в программе 1)Program z1 ; var a : integer ; begin a : = 10 ; while a< ; 5 do writeln(a) ; a : = a + 1 ; End.

2)Program z2 ; var a, s : integer ; begin a : = 1 ; s : = 0 ; while a< ; 10 do begin s : = s + a / 2 ; end ; writeln(s) ; end.

Fendoriys 24 апр. 2020 г., 11:49:56 | 5 - 9 классы

Составить программу для вычисления суммы квадратов чисел от 1 до 15?

Составить программу для вычисления суммы квадратов чисел от 1 до 15.

Функция возведения в квадрат sqr() ; Var , , : ; Begin : = 0 ; For : = to do Begin ; ; End ; Writeln(' = ', ) ; End.

Там, где пробелы, вставить что нужно.

Vadeeme798 20 апр. 2020 г., 06:39:09 | 5 - 9 классы

Вычислить сумму 10 натуральных чисел, вводимых с клавиатуры?

Вычислить сумму 10 натуральных чисел, вводимых с клавиатуры.

Program Demofor1 ;

Var S, P, I : integer ; Begin

For I : = .

To . doBeginWriteln (‘Введите число’) ;

(P) ; S : = S + .

;

End ;

Writeln (‘ Сумма равна’, .

) ;

End.

Sonyatoropchina 24 мар. 2020 г., 12:41:52 | 10 - 11 классы

Исправить ошибку Помогите исправить ошибку в программе Вот задание : Разработать программу поиска и печати всех чисел - близнецов, принадлежащих заданному диапазону [N, M ]?

Исправить ошибку Помогите исправить ошибку в программе Вот задание : Разработать программу поиска и печати всех чисел - близнецов, принадлежащих заданному диапазону [N, M ].

Вот программа : program yyy ; function prost(var x : integer) : boolean ; var k, i : integer ; t : boolean ; begin t : = true ; k : = 0 ; for i : = 1 to x do begin if x mod i = 0 then k : = k + 1 ; end ; if k = 2 then t : = true else t : = false ; prost : = t end ; var n, m, i : integer ; begin writeln('1') ; readln(n) ; writeln('2') ; readln(m) ; for i : = n to m - 1 do begin if prost(i) and prost(i + 2) then writeln(i , (i + 2)) ; end ; end.

AvEnTaDoR005 25 сент. 2020 г., 12:43:18 | 5 - 9 классы

Program TELESHOP ; var x : real ; begin writeln ('?

Program TELESHOP ; var x : real ; begin writeln ('.

') ; write ('.

') ; write ('.

') ; readln (x) ; if x< ; = 1 then begin if x = 1 then begin writeln ('.

') ; writeln ('.

') ; end else begin writeln ('.

') ; end ; * else begin writeln ('.

') ; end end.

* - место ошибки.

"встречено 'else', а ожидалось оператор" Вопрос : в чем ошибка?

Ksusha1037 25 июн. 2020 г., 21:03:03 | 5 - 9 классы

Здравствуйте, помогите пожалуйста найти ошибку program name ; uses crt ; var a : integer ; begin writeln ('Введите время = ') ; readln (a) ; if (a)then ; begin writeln ('ночь') ; end ; / / / if a = 3 ?

Здравствуйте, помогите пожалуйста найти ошибку program name ; uses crt ; var a : integer ; begin writeln ('Введите время = ') ; readln (a) ; if (a)then ; begin writeln ('ночь') ; end ; / / / if a = 3 then begin writeln ('утро') ; readln (d) ; if a = 12 then begin writeln ('день') ; end ; if a = 16 then begin writeln ('вечер') ; / / / if a = 21 then begin writeln ('ночь') ; / / / end ; end ;

Darkness590 14 февр. 2020 г., 19:07:10 | 10 - 11 классы

Постройте трассировочную таблицу (Паскаль) var i, n, m : integer ; begin write('введите любое натуральное число : ') ; readln(n) ; for i : = 1 to n do begin m : = m + i ; end ; writeln('сумма всех нат?

Постройте трассировочную таблицу (Паскаль) var i, n, m : integer ; begin write('введите любое натуральное число : ') ; readln(n) ; for i : = 1 to n do begin m : = m + i ; end ; writeln('сумма всех натуральных чисел не превышающих ', n, ' - ', m) ; end.

Денис193 18 нояб. 2020 г., 11:36:28 | 5 - 9 классы

В ЧЁМ ОШИБКА?

В ЧЁМ ОШИБКА?

Program z4 ; var a, i, n, k, f : integer ; begin k : = 0 ; f : = 0 ; writeln ('В начале введите сколько чисел будет в вашей последовательности, а потом введите последовательность целых чисел.

') ; readln(n) ; for i : = 1 to n do begin readln(a) ; if (a mod 10 = 5) and (a mod 5 = 0) then k : = k + a ; f : = f + 1 ; end ; writeln('Среднее арифметическое чисел, кратных 5, но не заканчивающихся на 0 : ', k / f) ; end.

На этой странице находится ответ на вопрос СРОЧНО?, из категории Информатика, соответствующий программе для 5 - 9 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.