Дан текстовый файл?

Информатика | 10 - 11 классы

Дан текстовый файл.

Напечатать в алфавитном порядке все слова из данного файла, имеющие заданную длину n.

Паскаль.

Ответить на вопрос
Ответы (1)
Малика1 12 июл. 2020 г., 04:09:53

Const nx = 100 ;

var T : text ; M : array[1.

Nx] of string ; s, d : string ; ch : char ;

var i, p, j : integer ;

begin

assign(T, 'D : \ 1t \ sip.

Txt') ; reset(T) ;

while not eof(T) do begin

Readln(T, s) ; p : = 1 ;

While p> ; 0 do begin

i : = i + 1 ; p : = pos(' ', s) ; if p> ; 0 then M[i] : = copy(s, 1, p - 1)else M[i] : = s ; delete(s, 1, p) ; / / writeln(M[i]) ;

end ; end ; close(T) ;

for ch : = 'А' to 'Я' do begin

for j : = 1 to i do begin

if (m[j].

Length > ; 0) and (ch = uppercase(copy(m[j], 1, 1))) then begin / / write(ch) ;

writeln(M[j]) ; M[j] : = '' ; end ; end ; end ; end.

Leokat61 30 апр. 2020 г., 08:50:41 | 10 - 11 классы

Дан текстовый файл?

Дан текстовый файл.

Вывести на экран самую длинную строку из файла.

Через паскале.

Алиакберова 4 мая 2020 г., 14:55:50 | 10 - 11 классы

Файлы?

Файлы.

Pascal.

Дано натуральное число n.

Записать в текстовый файл n простых чисел начиная с 2.

Ирка2 9 авг. 2020 г., 08:08:46 | 10 - 11 классы

Дан текстовый файл, содержащий целые числа?

Дан текстовый файл, содержащий целые числа.

Найти количество чисел в файле и их сумму.

Katringn 20 июн. 2020 г., 00:49:15 | 10 - 11 классы

(Код паскаль)Дан текстовый файл?

(Код паскаль)Дан текстовый файл.

Латинские буквы из него поместить в текущем каталоге в файл file.

Lat, русские – в file.

Rus, все остальные символы – в file.

Oth.

Tatgiljova 28 окт. 2020 г., 15:51:09 | 10 - 11 классы

Создайте текстовый файл?

Создайте текстовый файл.

Определите, сколько строк файла имеют длину большую, равную и меньшую, чем заданное значение k.

Vasua203mk 3 авг. 2020 г., 05:55:46 | 5 - 9 классы

Дано предложение?

Дано предложение.

Напечатать его слова в обратном порядке.

(Паскаль).

Alexey1776 17 апр. 2020 г., 12:14:00 | 10 - 11 классы

Помогите пожалуйста, срочно?

Помогите пожалуйста, срочно!

Написать программу в Турбо Паскале.

Задание : Дан текстовый файл f.

Исключить гласные буквы из строк и поместить результат в файл q.

Camal111 4 мая 2020 г., 15:15:19 | 5 - 9 классы

Дан текстовый файл?

Дан текстовый файл.

Подсчитать количество символов в каждой строке.

Lexa1980277 3 июн. 2020 г., 22:28:35 | 5 - 9 классы

Задача в Паскале : Создать текстовый файл f и g, компанентами которого являются случайные целые числа?

Задача в Паскале : Создать текстовый файл f и g, компанентами которого являются случайные целые числа.

Записать в файл h сначала компаненты файла f, а затем компоненты файла g с сохранением порядка.

Anna20031407 8 июн. 2020 г., 13:09:02 | 10 - 11 классы

Помогите написать программу на паскале абс "Файловый тип данных?

Помогите написать программу на паскале абс "Файловый тип данных.

" Дан целочисленный файл А.

Записать в файл В все положительные числа.

Если вам необходимо получить ответ на вопрос Дан текстовый файл?, относящийся к уровню подготовки учащихся 10 - 11 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.