Дан текстовый файл, содержащий целые числа?

Информатика | 10 - 11 классы

Дан текстовый файл, содержащий целые числа.

Найти количество чисел в файле и их сумму.

Ответить на вопрос
Ответы (1)
Bloodymary2 9 авг. 2020 г., 08:08:48

Var f : Text ; n, s, e : integer ;

begin n : = 0 ; s : = 0 ; Assign(f, 'input.

Txt') ; Reset(f) ; while not Eof(f) do begin readln(f, e) ; n : = n + 1 ; s : = s + e end ; Close(f) ; writeln('В файле ', n, ' чисел ; их сумма равна ', s)

end.

Тестовое решение :

В файле 10 чисел ; их сумма равна 213

Содержимое файла input.

Txt :

24

37

14 - 6

42

58

3

14

0

27.

Den9898 18 апр. 2020 г., 15:54:24 | 10 - 11 классы

Дан текстовый файл содержащий вещественные числа по одному в каждой строке?

Дан текстовый файл содержащий вещественные числа по одному в каждой строке.

Поместить эти числа в другой файл по 6 в строку перед десятичной точкой оставить 5 знаков после точки 8 знаков.

Т - паскаль.

Zakievaevelina 14 мар. 2020 г., 09:30:41 | 5 - 9 классы

Помогите?

Помогите!

Нужно написать программу на паскале : Дан файл целых чисел f1.

Создать файл f2 содержащий только отрицательные числа из файла f1.

Leokat61 30 апр. 2020 г., 08:50:41 | 10 - 11 классы

Дан текстовый файл?

Дан текстовый файл.

Вывести на экран самую длинную строку из файла.

Через паскале.

Алиакберова 4 мая 2020 г., 14:55:50 | 10 - 11 классы

Файлы?

Файлы.

Pascal.

Дано натуральное число n.

Записать в текстовый файл n простых чисел начиная с 2.

AdaGasanova 12 июн. 2020 г., 04:43:46 | 10 - 11 классы

Дан файл f, компоненты которого являются целыми числами?

Дан файл f, компоненты которого являются целыми числами.

Найти количество квадратов нечетных чисел среди компонент файла.

Записать это значение в начало нового файла g.

Остальные значения переписать из исходного файла f.

Camal111 4 мая 2020 г., 15:15:19 | 5 - 9 классы

Дан текстовый файл?

Дан текстовый файл.

Подсчитать количество символов в каждой строке.

Иришка356587 15 июл. 2020 г., 20:29:41 | 10 - 11 классы

Решение задач с использованием файлов 1?

Решение задач с использованием файлов 1.

Дано число к и файл, содержащий целые числа.

Вывести элемент файла с номером к.

Если такой элемент отсутствует, то вывести 0.

2. Дан файл вещественных чисел.

Создать 2 новых файла, в первый из которых содержит строки исходного файла с четными номерами, а второй с нечетными номерами.

Lemai2005 19 сент. 2020 г., 16:16:29 | 10 - 11 классы

Дан текстовый файл?

Дан текстовый файл.

Подсчитать количество строк, в которых вторым стоит символ « + », а предпоследним « - ».

UToppent 5 июл. 2020 г., 23:26:03 | 5 - 9 классы

Дан файл из чисел?

Дан файл из чисел.

Создать второй файл из чисел первого файла, у которых сумма цифр находится в пределе от 12 до 34.

Pascal.

Zenit969 30 авг. 2020 г., 08:41:03 | 5 - 9 классы

Скорость передачи данных через модемное соединение равна 32 Кбайт / с?

Скорость передачи данных через модемное соединение равна 32 Кбайт / с.

Через данное соединение был передан текстовый файл, содержащий 4652222 символа.

Определите, сколько времени заняла передача текстового файла.

На этой странице находится вопрос Дан текстовый файл, содержащий целые числа?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 10 - 11 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.