2) Дан целочисленный массив из 20 элементов, все элементы которого – целые числа в интервале от - 1000 до 1000?

Информатика | 10 - 11 классы

2) Дан целочисленный массив из 20 элементов, все элементы которого – целые числа в интервале от - 1000 до 1000.

Опишите на русском языке или на одном из языков программирования алгоритм, который находит минимальное значение из всех нечетных элементов массива, которые делятся на 5.

Ответить на вопрос
Ответы (1)
Плпз 29 мая 2020 г., 16:47:12

Var a : array [1.

100] of integer ; n, k, i, j : integer ;

begin {вводим} for i : = 1 to 20 do {элементы} read (a[i]) ; {массива} for j : = 1 to N - 1 do {сортируем элементы массива по возрастанию, } for i : = 1 to N - j do if a[i] > ; a[i + 1] then begin k : = a[i] ; a[i] : = a[i + 1] ; a[i + 1] : = k ; end ; {то есть от самого маленького до самого большого} for i : = 1 to 20 do {выполняем заданное условие} if ((a[i] mod 2) = 1) and ((a[i] mod 5) = 0) then begin writeln ('Требуемое значение ', a[i]) ; break ; end ; end.

Arrrrt 22 февр. 2020 г., 22:13:18 | 10 - 11 классы

2) Опишите на русском языке или одном из языков программирования алгоритм подсчета максимального количества подряд идущих отрицательных элементов в целочисленном массиве длины 30?

2) Опишите на русском языке или одном из языков программирования алгоритм подсчета максимального количества подряд идущих отрицательных элементов в целочисленном массиве длины 30.

На Паскале АБС.

Maxim12003 28 мая 2020 г., 13:08:15 | 5 - 9 классы

Дан целочисленный массив из 40 элементов?

Дан целочисленный массив из 40 элементов.

Элементы массива могут принимать произвольные значения.

Опишите на русском языке или на одном из языков программирования алгоритм, который находит и выводит номер элемента массива, наименее отличающегося от среднего арифметического всех его элементов.

Но лучше на языке Паскаль.

Rudi8787 31 окт. 2020 г., 18:53:33 | 5 - 9 классы

Дан целочисленный массив из 31 элемента, в котором записаны значения температуры воздуха в марте?

Дан целочисленный массив из 31 элемента, в котором записаны значения температуры воздуха в марте.

Элементы массива могут принимать значения от (–20) до 20.

Опишите на русском языке или на одном из языков программирования алгоритм, который подсчитывает и выводит среднюю температуру по всем дням, когда была оттепель (температура поднималась выше нуля).

Гарантируется, что хотя бы один день в марте была оттепель.

10анна 15 нояб. 2020 г., 12:59:13 | 10 - 11 классы

1)Опишите на русском языке или одном из языков программирования алгоритм подсчета суммы произведений последовательных пар элементов в целочисленном массиве из 30 элементов?

1)Опишите на русском языке или одном из языков программирования алгоритм подсчета суммы произведений последовательных пар элементов в целочисленном массиве из 30 элементов.

(Это означает, что нужно сосчитать сумму произведений первого и второго, третьего и четвертого, пятого и шестого элементов, и так далее.

) 2)Опишите на русском языке или одном из языков программирования алгоритм поиска номера первого из двух последовательных элементов в целочисленном массиве из 30 элементов, сумма которых максимальна (если таких пар несколько, то можно выбрать любую из них).

Zhjkckfdf 3 авг. 2020 г., 13:42:16 | 10 - 11 классы

Дан целочисленный массив из 10 элементов все элементы которого целые числа в интервале от - 1000 до 1000?

Дан целочисленный массив из 10 элементов все элементы которого целые числа в интервале от - 1000 до 1000.

Напишите программу которая находит количество элементов всех нечетных элементов массива которые делятся на 3 на языке Pascal желательно.

Rakhuba1981 29 апр. 2020 г., 00:46:34 | 5 - 9 классы

Дан целочисленный двумерный массив 6x10?

Дан целочисленный двумерный массив 6x10.

Опишите на русском языке и на языке программирования Паскаль алгоритм вычисления произведения минимальных элементов из каждой строки.

Напечатать значение этого произведения.

Предполагается, что в каждой строке минимальный элемент единственный.

4yBAK4 28 окт. 2020 г., 14:55:27 | 5 - 9 классы

Дан целочисленный массив из 10 элементов?

Дан целочисленный массив из 10 элементов.

Элементы массива могут принимать целые значения от 0 до 1000.

Опишите на русском языке или на одном из языков программирования алгоритм, позволяющий найти и вывести номер первого элемента массива, который делится на 3.

Гарантируется, что в исходном массиве есть хотя бы один такой элемент.

Программу я написал, но выводит все значения, а мне нужно первое.

Sanergon 10 февр. 2020 г., 07:57:08 | 5 - 9 классы

Дан целочисленный массив из 20 элементов, все элементы которого – целые числа в интервале от - 1000 до 1000?

Дан целочисленный массив из 20 элементов, все элементы которого – целые числа в интервале от - 1000 до 1000.

Опишите на языке программирования паскаль алгоритм, который находит минимальное значение из всех нечетных элементов массива, которые делятся на 5.

Если таких чисел нет, нужно вывести сообщение "таких чисел нет".

Sidorovakatyus 23 нояб. 2020 г., 14:56:40 | 5 - 9 классы

Дан целочисленный массив из 20 элементов?

Дан целочисленный массив из 20 элементов.

Элементы массива могут принимать целые значения от –10 000 до 10 000 включительно.

Опишите на одном из языков программирования алгоритм, позволяющий найти и вывести количество пар элементов массива, в которых сумма элементов делится на 2, но не делится на 4.

В данной задаче под парой подразумеваются два соседних элемента массива.

GrafAleksandr1 7 дек. 2020 г., 19:21:13 | 10 - 11 классы

Дан целочисленный массив из 20 элементов?

Дан целочисленный массив из 20 элементов.

Элементы массива могут принимать целые значения от 0 до 10000 включительно.

Опишите алгоритм, позволяющий найти и вывести максимальное значение среди трёхзначных элементов массива, не делящихся на 7.

Если в исходном массиве нет элемента, значение которого является трёхзначным числом и при этом кратно 7, то вывести сообщение «Не найдено».

На языке PHP.

Вы перешли к вопросу 2) Дан целочисленный массив из 20 элементов, все элементы которого – целые числа в интервале от - 1000 до 1000?. Он относится к категории Информатика, для 10 - 11 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.