Задать одномерный массив из 50 целочисленных элементов, с помощью цикла repeat until и вывести на экран те элементы которые совпадают с индексом позиции?

Информатика | 10 - 11 классы

Задать одномерный массив из 50 целочисленных элементов, с помощью цикла repeat until и вывести на экран те элементы которые совпадают с индексом позиции.

Ответить на вопрос
Ответы (1)
Milienasokolov 3 нояб. 2020 г., 21:52:48

/ / PascalABC.

NET 3.

0

( * Задать одномерный массив из 50 целочисленных элементов, с помощью цикла repeat until вывести на экран те элементы которые совпадают с индексом позиции *

)var mas : array [1.

50] of integer ;

i : integer ; begin for i : = 1 to 50 do

mas[i] : = random(50) + 1 ;

writeln('Массив : ') ;

for i : = 1 to 50 do

write(mas[i], ' ') ;

writeln ;

writeln('Элементы, совпадающие с индексом позиции : ') ;

i : = 1 ;

repeat

if (mas[i] = i) then

write(mas[i], ' ') ;

inc(i)

until i = 50 ;

end.

Hatashaprudhik 4 авг. 2020 г., 01:37:25 | 10 - 11 классы

Дан целочисленный одномерный массив из n - элементов?

Дан целочисленный одномерный массив из n - элементов.

Вывести на экран четные элементы стоящие на нечетных массивов через паскаль.

Xx880088 13 мар. 2020 г., 19:28:39 | 10 - 11 классы

С + + : В заданной очереди подсчитать число нулевых элементов и вывести на экран их индексы?

С + + : В заданной очереди подсчитать число нулевых элементов и вывести на экран их индексы.

Marjana1996 6 окт. 2020 г., 05:53:21 | 5 - 9 классы

Задать одномерный массив (В) из 25 вещественных элементов с помощью цикла while?

Задать одномерный массив (В) из 25 вещественных элементов с помощью цикла while.

Dedkaa 27 июн. 2020 г., 00:54:48 | 10 - 11 классы

Создайте целочисленный массив А[5?

Создайте целочисленный массив А[5.

3]. Вывести на экран элементы массива, кратные 5, и их индексы.

КатяЛапова123 23 нояб. 2020 г., 00:25:40 | 5 - 9 классы

ЛЮДИ, ПОМОГИТЕ, ПОЖАЛУЙСТА Найти значения минимального элемента одномерного целочисленного массива, сформированного пользователем, и его индекс?

ЛЮДИ, ПОМОГИТЕ, ПОЖАЛУЙСТА Найти значения минимального элемента одномерного целочисленного массива, сформированного пользователем, и его индекс.

Внимание, предусмотреть ситуацию нескольких элементов с минимальным значением.

В этом случае вывести на экран все индексы.

Паскаль.

Diana98n 10 июн. 2020 г., 21:33:13 | 10 - 11 классы

В одномерном массиве А(10) найти максимальный элемент, вывести его значение и индекс?

В одномерном массиве А(10) найти максимальный элемент, вывести его значение и индекс.

Заменить все четные элементы значением максимального элемента.

Полученный массив вывести на экран.

Losemyselft1 22 окт. 2020 г., 23:13:40 | 10 - 11 классы

Сформировать одномерный массив из 20 элементов (значения элементов задаются пользователем)?

Сформировать одномерный массив из 20 элементов (значения элементов задаются пользователем).

Увеличить каждый элемент на 1.

Вывести на экран исходный и итоговый массивы.

Zhasmin04 18 апр. 2020 г., 05:09:19 | 1 - 4 классы

Дан целочисленный массив на n элементов вывести на экран элементы, которые меньше или равны своему номеру?

Дан целочисленный массив на n элементов вывести на экран элементы, которые меньше или равны своему номеру.

Заранее спасибо.

Aishakov2000 5 мар. 2020 г., 16:27:29 | 5 - 9 классы

Решить при помощи паскаль : задан одномерный массив датчиком случайных чисел состоящий из 10 элементов вывести на экран max - элемент?

Решить при помощи паскаль : задан одномерный массив датчиком случайных чисел состоящий из 10 элементов вывести на экран max - элемент.

79685425752 6 нояб. 2020 г., 03:54:58 | 10 - 11 классы

Напишите программу, которая ввод данных в одномерный целочисленный массив осуществляет посредством цикла WHILE?

Напишите программу, которая ввод данных в одномерный целочисленный массив осуществляет посредством цикла WHILE.

DO, а вывод – REPEAT.

UNTIL (в скобках указана размерность массива)

1.

Подсчитать произведение неотрицательных элементов в двухмерном массиве 6 × 3 ;

Вопрос Задать одномерный массив из 50 целочисленных элементов, с помощью цикла repeat until и вывести на экран те элементы которые совпадают с индексом позиции?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 10 - 11 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.