Задано число N вывести соответствующий элемент ряда чисел фибоначи : 11235821?

Информатика | 5 - 9 классы

Задано число N вывести соответствующий элемент ряда чисел фибоначи : 11235821.

Ответить на вопрос
Ответы (1)
Ronia 23 мар. 2020 г., 04:02:16

Ответа нет, напишу по - простому.

Var i, n, f1, f2, t : integer ;

begin Write('Задайте натуральное число : ') ; Readln(n) ; f1 : = 0 ; f2 : = 1 ; for i : = 2 to n do begin t : = f2 ; f2 : = f1 + f2 ; f1 : = t end ; Writeln('F(', n, ') = ', f2)

end.

Тестовое решение :

Задайте натуральное число : 10

F(10) = 55.

Kolotovkinayul 9 янв. 2020 г., 08:06:20 | 10 - 11 классы

Написать программу дан массив целых чисел состоящий из 20 элементов?

Написать программу дан массив целых чисел состоящий из 20 элементов.

Вывести индексы тех элементов значения которых больше заданного числа а.

Алина26032000 21 апр. 2020 г., 02:29:02 | 5 - 9 классы

Сначала задано число N - количество элементов в массиве?

Сначала задано число N - количество элементов в массиве.

Далее через пробел записаны N чисел - элементы массива.

Необходимо вывести все четные элементы массива (то есть те элементы, которые являются четными числами).

Xx880088 13 мар. 2020 г., 19:28:39 | 10 - 11 классы

С + + : В заданной очереди подсчитать число нулевых элементов и вывести на экран их индексы?

С + + : В заданной очереди подсчитать число нулевых элементов и вывести на экран их индексы.

Margo4115 20 июн. 2020 г., 17:50:09 | 5 - 9 классы

Задан массив из 12 вещественных чисел?

Задан массив из 12 вещественных чисел.

Поменять местами два элемента массива, номера которых вводятся с клавиатуры.

Вывести элемент после замены.

Щербинка2000 16 окт. 2020 г., 13:07:15 | 10 - 11 классы

Заполнить массив числами натурального ряда(1, 2?

Заполнить массив числами натурального ряда(1, 2.

) до тех пор пока их сумма не станет больше наперед заданного числа м вывести на печать сумму и число элементов массива.

Ntoniy10 30 мар. 2020 г., 04:29:04 | 10 - 11 классы

Дан массив целых чисел, состоящий из 10 элементов?

Дан массив целых чисел, состоящий из 10 элементов.

Заполнить его с клавиатуры.

Найти : - Удвоенную сумму положительных элементов ; - Вывести значения тех элементов, которые меньше заданного числа А кратны 3.

Orchok 2 мая 2020 г., 17:28:09 | 10 - 11 классы

Задан массив с(9)вывести элементы расположенные за минимальным элементом?

Задан массив с(9)вывести элементы расположенные за минимальным элементом.

Кариночка222 23 нояб. 2020 г., 19:01:35 | 10 - 11 классы

Помогите решить на С + + Вывести на экран все делители заданного числа?

Помогите решить на С + + Вывести на экран все делители заданного числа.

Вывести на экран заданное количество чисел, кратных заданному.

Для двух чисел определить наименьшее общее кратное.

Приблизительно посчитать квадратный корень заданного числа.

Aishakov2000 5 мар. 2020 г., 16:27:29 | 5 - 9 классы

Решить при помощи паскаль : задан одномерный массив датчиком случайных чисел состоящий из 10 элементов вывести на экран max - элемент?

Решить при помощи паскаль : задан одномерный массив датчиком случайных чисел состоящий из 10 элементов вывести на экран max - элемент.

Macosktyarezni 26 дек. 2020 г., 21:29:35 | 10 - 11 классы

Напишите программу на PascalAbc, которая находит n - ое число из ряда Фибоначи?

Напишите программу на PascalAbc, которая находит n - ое число из ряда Фибоначи.

На этой странице сайта размещен вопрос Задано число N вывести соответствующий элемент ряда чисел фибоначи : 11235821? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 5 - 9 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.