Составить программу на языке Паскаль числа по возрастанию?

Информатика | 10 - 11 классы

Составить программу на языке Паскаль числа по возрастанию.

Ответить на вопрос
Ответы (1)
Fooz123 17 февр. 2020 г., 15:31:01

Program parampampam ;

uses crt ;

var

i : integer ; {счетчик}

s : integer ;

begin

clrscr ; {очистка экрана}

writeln ('Программа выводит числа от 1 до 99, сумма цифр которых равна числу S') ;

writeln ('Введите число S, от 0 до 18 : ') ;

{ввод числа S с проверкой на корректность}

repeat

readln (s) ;

if (s> ; 18) or (s< ; 0) then

writeln ('Неверный ввод.

Повторите')

until (s< ; = 18) and (s> ; = 0) ;

{вывод нужных чисел на экран (цикл с предусловием)}

for i : = 1 to 99 do

if ((i div 10) + (i mod 10) = s) then {div дает целую часть, mod - остаток от деления}

write (i, ' ') ;

repeat until keypressed ; {пустой цикл для задержки экрана до нажатия клавиши}

end.

VlaDikKravaev 12 дек. 2020 г., 00:21:46 | 10 - 11 классы

Составить программу на языке паскаль : ввести 4 числа и вывести большее из них?

Составить программу на языке паскаль : ввести 4 числа и вывести большее из них.

( срочно).

Milana2003m 20 нояб. 2020 г., 19:20:06 | 5 - 9 классы

Составить программу на Паскале сортировки массива по возрастанию?

Составить программу на Паскале сортировки массива по возрастанию.

Melks 16 сент. 2020 г., 20:59:29 | 5 - 9 классы

Составить программу на языке паскаль для преобразования цифр в слова?

Составить программу на языке паскаль для преобразования цифр в слова.

Кристинаагилеровна 24 авг. 2020 г., 07:24:06 | 5 - 9 классы

Составить программу, которая составит из двух таблиц 3 - ю, упорядоченную по возрастаннию?

Составить программу, которая составит из двух таблиц 3 - ю, упорядоченную по возрастаннию.

В паскале.

Valenti98 28 дек. 2020 г., 20:05:12 | 10 - 11 классы

Составить программу вывода любого числа любое заданное число раз в одну строчку?

Составить программу вывода любого числа любое заданное число раз в одну строчку.

Язык программирования : Паскаль.

Айбек87292 16 янв. 2020 г., 07:24:13 | 5 - 9 классы

Составить алгоритм и программу : вывести на экран числа, кратные 2 ( язык Паскаль)?

Составить алгоритм и программу : вывести на экран числа, кратные 2 ( язык Паскаль).

Alikosha2003 7 июн. 2020 г., 10:03:08 | 5 - 9 классы

Составить программу с использованием WhileЯзык : Паскаль?

Составить программу с использованием While

Язык : Паскаль.

Mihalka08 2 июн. 2020 г., 07:08:33 | 10 - 11 классы

Составить программу на языке паскаль нохождения площади трапеции?

Составить программу на языке паскаль нохождения площади трапеции.

STARK93 17 нояб. 2020 г., 21:14:52 | 5 - 9 классы

Извлеките корень (составить программу на языке Паскаль)?

Извлеките корень (составить программу на языке Паскаль).

Arisha1983 24 сент. 2020 г., 23:04:46 | 5 - 9 классы

Составить программу на языке программирования паскаль с 3 и более переменными?

Составить программу на языке программирования паскаль с 3 и более переменными.

На этой странице находится вопрос Составить программу на языке Паскаль числа по возрастанию?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 10 - 11 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.