Дан массив из целых чисел X[1?

Информатика | 5 - 9 классы

Дан массив из целых чисел X[1.

5]. Заменить каждый элемент массива с нечетным номером средним арифметическим индексов соседних элементов.

Ответить на вопрос
Ответы (1)
Malaya267 31 мар. 2020 г., 17:07:46

Var x : array [1.

5] of real ;

i : integer ; begin for i : = 1 to 5 do if i mod 2 = 1 then x[i] : = (i + 1 + i - 1) / 2 ; for i : = 1 to 5 do writeln (x[i] : 3 : 2) ; end.

Kashetay 27 февр. 2020 г., 07:31:35 | 5 - 9 классы

Сформировать одномерный массив из 6 целых чисел, элементы которого вводятся с клавиатуры?

Сформировать одномерный массив из 6 целых чисел, элементы которого вводятся с клавиатуры.

Подсчитать среднее арифметическое элементов с нечетными номерами.

Ariname 14 мая 2020 г., 07:02:43 | 5 - 9 классы

1. Дан массив целых чисел, найти среднее арифметическое всех элементов массива?

1. Дан массив целых чисел, найти среднее арифметическое всех элементов массива.

2. Дан массив целых чисел, найти количество отрицательных элементов массива.

3. Дан массив целых чисел, найти количество чётных чисел в массиве.

Klimova14355 7 янв. 2020 г., 18:01:34 | 10 - 11 классы

Дан массив из 10 целых чисел найти произведение элементов массива с четными индексами?

Дан массив из 10 целых чисел найти произведение элементов массива с четными индексами.

Настя6462 6 нояб. 2020 г., 06:22:34 | 10 - 11 классы

Дан массив целых чисел (заполнить случайными числами от 20 до 99)?

Дан массив целых чисел (заполнить случайными числами от 20 до 99).

Найти номер первого нечетного элемента.

Если нечетных элементов в массиве нет, то напечатать соответствующее сообщение.

Risha88 8 мая 2020 г., 22:23:56 | 5 - 9 классы

Кто решит задачу?

Кто решит задачу?

Дан массив из N целых чисел.

Написать программу, определяющую, есть ли в массиве два соседних положительных элемента.

Если есть, то вывести индекс первого элемента, входящего в первую пару.

Glebdrokin 27 янв. 2020 г., 18:50:45 | 10 - 11 классы

Напишите программу, Дан целый одномерный массив А, неотрицательных чисел, с индексами от 1 до 6?

Напишите программу, Дан целый одномерный массив А, неотрицательных чисел, с индексами от 1 до 6.

Заполнить данный массив с клавиатуры, найти и вывести наименьшую нечетную сумму двух соседних элементов массива.

Grooooyl 2 сент. 2020 г., 04:57:55 | 10 - 11 классы

Задан массив из 10 целых чисел?

Задан массив из 10 целых чисел.

Замените все положительные элементы данного массива его максимальным элементом.

Ovsyanikovanas 28 мар. 2020 г., 18:53:34 | 5 - 9 классы

Дан одномерный массив чисел?

Дан одномерный массив чисел.

Определить среднее арифметическое элементов массива.

Kristina1009 9 дек. 2020 г., 11:37:10 | 5 - 9 классы

Задан массив из 7 целых чисел?

Задан массив из 7 целых чисел.

Заменить все положительные элементы данного массива на его максимальный элемент.

Flover11 18 дек. 2020 г., 00:43:03 | 10 - 11 классы

Дан массив целых чисел, определить сколько среди его элементов больших, чем среднее арифметическое всех элементов массива?

Дан массив целых чисел, определить сколько среди его элементов больших, чем среднее арифметическое всех элементов массива.

С + + или С.

Вы зашли на страницу вопроса Дан массив из целых чисел X[1?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 5 - 9 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.